Today's Obscure Glitch

Just about no one will encounter the following problem, but because this blog tends to reflect the daily doings in the Borough of Breen, this one pops to the top of the heap. It deals with an obscure iChat error.

When I launched iChat after upgrading to Panther, typed a word, and then pressed the Space Bar, up popped an error message that read:

NSInternalInconsistencyException:
Invalid parameter not satisfying: (index >= 0) && (index < (_itemArray ? CFArrayGetCount(_itemArray)

Which, BabelFish tells me, translates roughly to: "Better luck next time, Buster."

I did what most folks in my position would do -- fixed permissions, tossed out iChat preferences, and, when it still wouldn't work, cursed a blue streak. Rather than muck with it while on deadline, I simply used iChat on my PowerBook, where it behaved as expected. When the OmniGroup's OmniOutliner produced the same error after I pressed the Space Bar, it was time to take action.

I turned to Google, which took me to Rob Griffiths' outstanding Mac OS X Hints site. There, forum member Robbo revealed that this problem can appear when Panther is installed over a previous version of the Mac OS that's using the open-source dictionary, CocoAspell. Sure enough, I had installed CocoAspell while running Jaguar. Removing any files that contained the word "aspell" put things right.

Shop Tech Products at Amazon