Bugs & Fixes: Locate missing sound files in GarageBand

When attempting to open a lesson file via GarageBand ’09’s Learn to Play, you may get an unwelcome “Audio file…not found” error. This happened to me, for example, after copying files from an old to a new computer.

Although the error message includes a Search button, I wouldn’t waste my time trying it. Inevitably, the error returns to inform you that it was still unable to find the MIA files. If you instead select Skip, the lesson should eventually open. However, not surprisingly, you won’t be hearing much, if any, sound.

Where exactly are these missing audio files? Oddly enough, they are most likely exactly where they are supposed to be: inside the Lesson item itself. To confirm this, navigate to /Library/Application Support/GarageBand/Learn to Play. Open either Basic Lessons or Artist Lessons to find the .mwand lesson item that is not working for you. These items are packages, which means they are really folders in disguise. To peer inside, select Show Package Contents from the lesson’s contextual menu. Next, go to the lesson’s Media folder. Here you will find all the .caf audio files that GarageBand has mysteriously been unable to locate on its own.

Unfortunately, there is no way you can shake GarageBand and shout: “Here they are. Use them.” You also won’t have success with typical troubleshooting recommendations, such as redownloading the lessons or reinstalling GarageBand itself.

But don’t fret. Solving this matter is delightfully simple. The key is to pay a visit to a different Library, the one in your Home directory. Here, go to Application Support/GarageBand/Working Copies. In this folder, you should find one or more files with the same names as the problematic Learn to Play lessons. Delete these files (don’t worry, this won’t delete the actual lessons). Now, launch GarageBand, and try again to open a lesson. You should succeed without getting the audio errors.

Shop Tech Products at Amazon