VMware backtracks on OS X Client virtualization

On Friday, we reported that VMware Fusion 4.1 can run virtual versions of Leopard and Snow Leopard, a feature previously barred by Apple’s end-user license agreement. On Monday, the other shoe dropped: VMware posted a blog entry that seems to back away from that feature.

“When the license verification step was added in VMware Fusion 4.1 the server edition check was omitted,” the post says. “We are preparing an update.”

What’s not said in the blog post is more notable. The company doesn’t say whether or not the omission was intentional. (There’s nothing in the post that comes across as an apology or an admission that an error was made.) There’s a suggestion that an update is forthcoming, but while the post implies that the update will replace the server check, it doesn’t actually say it.

And the most obvious item left unsaid: Apple’s involvement. An Apple spokesperson told Macworld late Friday that the company’s licensing terms for Mac OS X haven’t changed. It seems likely that someone from Apple had a conversation with someone from VMware about the new feature in Fusion 4.1 and suggested that something be done about it.

What’s next for Fusion? It seems likely that the way the product handles previous versions of OS X will change in a forthcoming update. Presumably version 4.1 will continue working just fine for a while, if you’re inclined to keep running Leopard and Snow Leopard client editions in a virtual machine on your Mac. It’s unclear whether any update might break compatibility with existing virtual machines, or just prevent users from creating new virtual machines.

In the meantime, as of this writing Fusion 4.1.0 is still available for download from VMware’s website.

[Update, November 23: In a tech note posted Wednesday, VMware says that any Leopard or Snow Leopard client Virtual Machines will stop functioning when a forthcoming VMware Fusion 4.1.1 update is released.]

Subscribe to the Apple @ Work Newsletter

Comments