
<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="utf-8"/>
<title>Hackintosh: Build a DIY Mac for Gaming</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0"/>
<link rel="canonical" href="http://www.macworld.com/article/3199192/macs/how-to-build-a-hackintosh-high-performance.html"/>
<meta name="description" content="How to build your own Macintosh for gaming out of PC parts. Our guide shows how to pick and buy parts, assemble the computer, and install macOS."/>
<meta name="news_keywords" content="Hackintosh,How to build a Hackintosh,How to pick parts for a Hackintosh,How to instal macOS on a Hackintosh"/>
<meta itemprop="image" content="http://images.idgesg.net/images/article/2017/06/hackintosh_pro_innards-100724681-medium.jpg">
<meta name="DC.date.issued" content="2017-06-21"/>
<meta name="date" content="2017-06-21"/>
<link rel="amphtml" href="http://www.macworld.com/article/3199192/macs/how-to-build-a-hackintosh-high-performance.amp.html"/>
<script type="text/javascript" src="http://fonts.staticworld.net/lzq5miu.js"></script>
<script type="text/javascript">try{Typekit.load();}catch(e){}</script>
<meta property="twitter:account_id" content="611823"/>
<meta property="fb:app_id" content="865450560227169"/>
<meta property="og:type" content="article">
<meta property="og:url" content="http://www.macworld.com/article/3199192/macs/how-to-build-a-hackintosh-high-performance.html">
<meta property="og:site_name" content="Macworld">
<meta property="og:image" content="http://images.idgesg.net/images/article/2017/06/hackintosh_pro_innards-100724681-large.3x2.jpg">
<meta property="og:image:width" content="700">
<meta property="og:image:height" content="467">
<meta property="og:title" content="Hackintosh: Build a DIY Mac for gaming">
<meta property="og:description" content="How to build your own Macintosh for gaming out of PC parts. Our guide shows how to pick and buy parts, assemble the computer, and install macOS.">
<!-- Sailthru -->
<meta name="sailthru.tags" content="macs,software-games,computers,os-x,hardware,diy,macpro,rob-griffiths,howto,medium"/>
<meta name="sailthru.image.thumb" content="http://images.idgesg.net/images/article/2017/06/hackintosh_pro_innards-100724681-small.jpg"/>
<meta name="sailthru.image.full" content="http://images.idgesg.net/images/article/2017/06/hackintosh_pro_innards-100724681-large.3x2.jpg"/>
<meta name="displaytype" content="article"/>
<meta name="source" content="macworld"/>
<meta name="category" content="macs,games,pcs,macos,hardware"/>
<meta name="storytype" content="howto"/>
<meta name="tags" content="diy,mac pro"/>
<meta name="google-site-verification" content="1NJELq6F-S44I5ACepf9_rYYEBLuwwVjJUv5PrT91SA"/>
<meta name="msvalidate.01" content="05F49F041AAA61528A0A3329A6C0C02D"/>
<style>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</style>
<!-- this must be first -->
<link href="/www.idgcsmb/css/colorbox.css" rel="stylesheet"/>
<!-- <link href="/www.idgcsmb/css/equalizer.css" rel="stylesheet" /> -->
<link href="/www.idgcsmb/css/global-layout.css?v=20170619121402" rel="stylesheet"/>
<link href="/www.idgcsmb.mw/css/global-layout.css?v=20170619121402" rel="stylesheet"/>
<link href="/www.idgcsmb/css/global-colors.css?v=20170619121402" rel="stylesheet"/>
<link href="/www.idgcsmb.mw/css/global-colors.css?v=20170619121402" rel="stylesheet"/>
<link href="/www.idgcsmb/css/global-typography.css?v=20170619121402" rel="stylesheet"/>
<link href="/www.idgcsmb.mw/css/global-typography.css?v=20170619121402" rel="stylesheet"/>
<link href="/www/css/article.css?v=20170619121402" rel="stylesheet"/>
<link href="/www.idgcsmb.mw/css/article.css?v=20170619121402" rel="stylesheet"/>
<link href="/www.idgcsmb/css/video.player.css?v=20170619121402" rel="stylesheet" media="all"/>
<!-- this must be last -->
<link href="/www.idgcsmb/css/helpers.css?v=20170619121402" rel="stylesheet"/>
<!--  fav and touch icons -->
<link rel="shortcut icon" href="/www.idgcsmb.mw/favicon.ico"/>
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="http://csmb.staticworld.net/images/furniture/macworld/mw-apple-touch-icon-precomposed-144.png"/>
<link rel="apple-touch-icon-precomposed" sizes="129x129" href="http://csmb.staticworld.net/images/furniture/macworld/mw-apple-touch-icon-precomposed-129.png"/>
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="http://csmb.staticworld.net/images/furniture/macworld/mw-apple-touch-icon-precomposed-114.png"/>
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="http://csmb.staticworld.net/images/furniture/macworld/mw-apple-touch-icon-precomposed-72.png"/>
<link rel="apple-touch-icon" href="http://csmb.staticworld.net/images/furniture/macworld/mw-apple-touch-icon-precomposed.png"/>
<script type="text/javascript" src="/www.idgcsmb/js/jquery/jquery-modernizr.js?v=20170111"></script>
<script src="/www/js/init_device.js?v=20170619121402"></script>
<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20170619121402"></script>
<script type="text/javascript">if(adLayer==null||adLayer=='undefined'){var adLayer=[];}adLayer["itemType"]="article";</script>
<script src="/www/js/ads/narf_prebid.js?v=20170619121402"></script>
<!-- LiveRamp Sources -->
<script type="text/javascript" src="//storage.googleapis.com/cdn.pippio.com/sdk/pippio.min.js" async></script>
<script src="/www/js/utils/liveRamp.js?v=20170619121402"></script>
<!-- End of LiveRamp -->
<script type="text/javascript">try{IDG.GPT.unitName="/8456/IDG.US_CSMB_Macworld.com";}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.unitName=IDG.GPT.unitName+"/"+"macs_section";}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}var global_ShowSuper=true;var global_ShowHero=false;var url=window.location.href;if(url.indexOf("?")>1){url=url.split('?')[0];}try{IDG.GPT.addTarget("URL",encodeURIComponent(url));}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("zone",'article/macs');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("articleId",'3199192');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("type",'howto');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("typeId",'4');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("manufacturer",'lg');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("templateType",'article-default');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("categoryIds",[3800,3084,2101,3675,3020]);}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("categorySlugs",['macs','software-games','computers','os-x','hardware']);}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{if(null!=IDG.GPT.getQsVal("env")){IDG.GPT.addTarget("env",IDG.GPT.getQsVal("env").replace(/\W/g,""));}}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("author",'Rob Griffiths');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("page_type",'');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("tagNames",'DIY,Mac Pro');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("insiderContent",'false');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("video-autoplay","true");IDG.GPT.log("STICKY: added Target video-autoplay : true");}catch(exception){console.log("STICKY: google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("stickyLB","true");IDG.GPT.log("STICKY: added Target stickyLB : true");}catch(exception){console.log("STICKY: google_dfp can't use IDG.GPT "+exception);}</script>
<script type="text/javascript">console.log("PROXIMIC RESPONSE: PAGE-LEVEL");(function(){try{var proximic_data=;IDG.GPT.addTarget("proximic",proximic_data.data);}catch(e){console.log("Error: "+e);}})();</script>
<script type="text/javascript"></script>
<script src="/www.idgcsmb/js/thm_pre.js?v=20170619121402"></script>
<script type="text/javascript">$thm.useBusinessData=true;</script>
<script>var isMobile=(typeof IDG.DEVICE!=='undefined')?IDG.DEVICE.isMobile():false;try{IDG.GPT.addBiddingParams("yieldbotPsn",(isMobile?"b274":"5016"));IDG.GPT.addBiddingParams("appnexusPlacementId",(isMobile?"6451145":"6352551"));}catch(e){console.log("Error in adding bidding params: "+e);}</script>
<script type="text/javascript" src="/www/js/ads/prebid_gpt_launcher.js?v=20170619121402"></script>
<script type="text/javascript">g_arrModules=new Array();g_arrAds=new Array();</script>
<script type="text/javascript">var _sf_async_config={};_sf_async_config.uid=29363;_sf_async_config.useCanonical=true;_sf_async_config.authors="Rob Griffiths";_sf_async_config.sections="macs";_sf_async_config.domain="macworld.com";</script>
<!-- <link href="/www.idgcsmb/webfonts/ss-social.css" rel="stylesheet" />
	<link href="/www.idgcsmb/webfonts/ss-standard.css" rel="stylesheet" />  -->
<!--[if lte IE 8]>  
		<link href="/www.idgcsmb/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]-->
<!-- Add1/20/2015 IDGMPM-8088 -->
<!-- Add to article pages only -->
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@macworld">
<meta name="twitter:image" content="http://images.idgesg.net/images/article/2017/06/hackintosh_pro_innards-100724681-orig.jpg"/>
<meta name="twitter:description" content="How to build your own Macintosh for gaming out of PC parts. Our guide shows how to pick and buy parts, assemble the computer, and install macOS.">
<meta name="twitter:title" content="Hackintosh: Build a DIY Mac for Gaming">
<meta name="twitter:url" content="www.macworld.com/article/3199192/macs/how-to-build-a-hackintosh-high-performance.html">
<meta name="parsely-title" content="Hackintosh: Build a DIY Mac for gaming"/>
<meta name="parsely-link" content="http://www.macworld.com/article/3199192/macs/how-to-build-a-hackintosh-high-performance.html"/>
<meta name="parsely-type" content="NewsArticle"/>
<meta name="parsely-image-url" content="http://images.idgesg.net/images/article/2017/06/hackintosh_pro_innards-100724681-large.jpg"/>
<meta name="parsely-pub-date" content="2017-06-21T10:15:00Z"/>
<meta name="parsely-section" content="Macs"/>
<meta name="parsely-author" content="Rob Griffiths"/>
<meta name="parsely-tags" content="DIY,Mac Pro,type: howto,source: macworld,original"/>
<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "WebSite",
		"url": "http://www.macworld.com/ ",
		"potentialAction": {
		"@type": "SearchAction",
		"target": "http://www.macworld.com/search?query={search_term}",
		"query-input": "required name=search_term"
		}
	}
</script>
<script src="http://a.postrelease.com/serve/load.js?async=true"></script>
<script>dataLayer=[{'primaryCategory':'Macs','ga_enabled':'true','articleType':'How-To','articleId':'3199192','articleTitle':'Hackintosh: Build a DIY Mac for gaming','blogName':'','parselyEnabled':'true','parselyDomain':'macworld.com','viglinksId':'3398740902e69bebff28e573e9cf33ab','geolocEnabled':'true'}];</script>
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-WHLJC4" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-WHLJC4');</script>
<!-- End Google Tag Manager -->
</head>
<body id="article3199192" class="article macworld">
<div id="skinAdTarget"></div>
<div id="superadunit" class="hidden">
<div class="topbar">
<div class="brand"><a href="javascript:unhide('superadunit');"><img src="http://csmb.staticworld.net/images/ads/superstitial_mw_logo_125x4-100004106-orig.gif"></a></div>
<div class="skip"><a href="javascript:unhide('superadunit');"><img src="http://csmb.staticworld.net/images/ads/superstitial_mw_goto_152x4-100004104-orig.gif"></a></div>
</div><!-- / topbar -->
<div class="ad">
<div id="gpt-superstitial" class=" ad-container"></div>
<script type="text/javascript">try{IDG.GPT.addDisplayedAd("gpt-superstitial","true");$('#gpt-superstitial').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: gpt-superstitial [971 1115]");}catch(exception){console.log("Error with IDG.GPT: "+exception);}</script>
</div><!-- / ad -->
</div><!-- / super -->
<div id="page-top">
<div class="page-top-inner" itemscope itemtype="http://schema.org/Organization">
<link itemprop="url" href="http://www.macworld.com">
<div class="network-header">
<div class="network-header-inner">
<div id="network-tools">
<div id="saved-comparisons"></div>
<ul class="hmenu" id="heroLogin">
<li class="subscribeHeader"><a href="https://ssl.palmcoastd.com/31401/apps/MCWDIGITAL?ikey=I**A02">Subscribe</a><div class="subscribe-hover" style="">
<div class="pointer">&#9650;</div>
<span>Learn more about Macworld's Digital Edition</span>
<img alt="Macworld Magazine Cover" src="http://csmb.staticworld.net/images/furniture/macworld/footer-subscribe-mag-mw.png">
</div></li>
</ul>
</div><!-- /#network-tools -->
<div id="network-social">
<a href="http://www.facebook.com/Macworld" class="network-fb ss-icon ss-social-circle banner-social banner-fb" alt="Facebook" itemprop="sameAs" rel="nofollow">
&#xF610;
</a>
<a href="https://twitter.com/macworld" class="network-tw ss-icon ss-social-circle banner-social banner-tw" alt="Twitter" itemprop="sameAs" rel="nofollow">
&#xF611;
</a>
<a href="https://plus.google.com/+macworld/posts" class="network-google ss-icon ss-social-circle banner-social banner-google" alt="Google+" itemprop="sameAs" rel="publisher">
&#xF613;
</a>
<form id="search-form" action="/search">
<input type="search" name="query" id="banner-search-term" class="inactive searchbox-input-class" value="">
<input type="submit" name="submit" id="banner-search-submit" value="search"/>
<a id="magGlassClick" class="ss-icon ss-standard" type="submit">&#x1F50E;</a>
</form>
</div><!-- /#network-social -->
</div>
</div><!-- /.network-header -->
<header id="banner">
<a id="mobile-offscreen-toggle" class="ss-standard ss-rows" href="javascript://"></a>
<div id="logo">
<a href="/" class="ir banner-logo" id="logoImage">Home</a>
</div>
<div id="mobile-search-toggle" class="ss-standard ss-search"></div>
</header>
<div id="main-nav">
<div class="container clearfix">
<ul class="fmenu" id="panel-nav">
<li class="newsNav"><a href="/news/" id="whatsHotNav">News</a></li>
<li class="reviewsNav"><a href="/reviews/" id="reviewsNav">Reviews</a></li>
<li class="howtoNav"><a href="/howto/" id="howtoNav">How-To</a></li>
<li class="videoNav"><a href="/video/" id="videoNav">Video</a></li>
</ul>
<ul class="fmenu" id="site-nav">
<li class="selected"><a href="/category/macs/" class="active">Macs</a>
<ul>
<li><a href="/category/mac-desktop/">Mac Desktops</a></li>
<li><a href="/category/macbook/">MacBooks</a></li>
<li><a href="/category/displays/">Displays</a></li>
<li><a href="/category/networking/">Networking</a></li>
<li><a href="/category/storage/">Storage</a></li>
</ul>
</li>
<li><a href="/category/iphone-ipad/">iPhone/iPad</a>
</li>
<li><a href="/category/os-x/">OS X</a>
</li>
<li><a href="/category/ios-apps/">iOS</a>
</li>
<li><a href="/category/mac-apps/">Apps</a>
</li>
<li><a href="/category/computers-accessories/">Accessories</a>
</li>
<li><a href="/category/business/">Business</a>
</li>
<li><a href="/category/entertainment/">Entertainment</a>
</li>
<li class="displayMobileOnly"><a href="/subscribe/">Subscribe</a></li>
</ul>
<div id="extra-nav-toggle"><a href="#extra-nav" class="ss-dropdown"></a></div>
<div id="extra-nav">
<ul>
<li><a href="/resources/">Resources</a></li>
<li><a href="/category/macs/">Macs</a></li>
<li><a href="/category/macbook/">MacBooks</a></li>
<li><a href="/category/mac-desktop/">Mac Desktops</a></li>
<li><a href="/category/apple-phone/">iPhones</a></li>
<li><a href="/blogs">Blogs</a></li>
</ul>
<ul>
<li><a href="/category/ipad/">iPads</a></li>
<li><a href="/category/computers-accessories/">Accessories</a></li>
<li><a href="/category/mac-apps/">Apps</a></li>
<li><a href="/category/software-music/">Audio</a></li>
<li><a href="/category/business/">Business</a></li>
<li><a href="/category/cameras/">Cameras</a></li>
<li><a href="/category/components/">Components</a></li>
<li><a href="/category/software-development/">Development Software</a></li>
</ul>
<ul>
<li><a href="/category/displays/">Displays</a></li>
<li><a href="/category/e-readers/">E-readers</a></li>
<li><a href="/category/home-theater/">Home Theater</a></li>
<li><a href="/category/ios-apps/">iOS</a></li>
<li><a href="/category/phone-accessories/">iPhone Accessories</a></li>
<li><a href="/category/ipad-accessories/">iPad Accessories</a></li>
<li><a href="/category/ipods/">iPods</a></li>
<li><a href="/category/os-x/">OS X</a></li>
</ul>
<ul>
<li><a href="/category/printers/">Printers</a></li>
<li><a href="/category/networking/">Networking</a></li>
<li><a href="/category/software-productivity/">Productivity Software</a></li>
<li><a href="/category/smartwatches/">Smartwatches</a></li>
<li><a href="/category/storage/">Storage</a></li>
<li><a href="/category/input-stylus/">Styluses</a></li>
</ul>
</div>
</div>
</div>	<!--/#main-nav-->
<div id="section-nav">
<div class="container clearfix">
<ul class="fmenu">
<li>
<a href="/category/mac-desktop/">Mac Desktops</a>
</li>
<li>
<a href="/category/macbook/">MacBooks</a>
</li>
<li>
<a href="/category/displays/">Displays</a>
</li>
<li>
<a href="/category/networking/">Networking</a>
</li>
<li>
<a href="/category/storage/">Storage</a>
</li>
</ul>
</div>
</div><!--/#section-nav-->
</div>
</div>
<!-- Events Header -->
<script>$(document).ready(function(){$('.searchbox-input-class').each(function(){$(this).change(function(){var qStr=$(this).val();if($(this).val().indexOf('@')!=-1){qStr=qStr.replace(/@/g,' ');$(this).val(qStr);}});});});</script>
<div id="page-wrapper" class="page-wrapper">
<section role="main">
<article itemscope itemtype="http://schema.org/Article">
<header class='cat'>
<div class="placeholderLeaderboard"></div>
<div id="articleLeaderboardInner" class="leaderboard-inner">
<div id="gpt-leaderboard" class=" ad-container"></div>
<script type="text/javascript">try{IDG.GPT.addDisplayedAd("gpt-leaderboard","true");$('#gpt-leaderboard').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: gpt-leaderboard [971 1115]");}catch(exception){console.log("Error with IDG.GPT: "+exception);}</script>
</div>
<div id="mobile-leader" class="leaderboard-inner">
<div id="gpt-leaderboardmobile" class=" ad-container"></div>
<script type="text/javascript">try{IDG.GPT.addDisplayedAd("gpt-leaderboardmobile","true");$('#gpt-leaderboardmobile').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: gpt-leaderboardmobile [971 1115]");}catch(exception){console.log("Error with IDG.GPT: "+exception);}</script>
</div>
<script>var count=8;count='10';function debounce(func,wait,immediate){var timeout;return function(){var context=this,args=arguments;var later=function(){timeout=null;if(!immediate)func.apply(context,args);};var callNow=immediate&&!timeout;clearTimeout(timeout);timeout=setTimeout(later,wait);if(callNow)func.apply(context,args);};}$(window).load(function(){var leaderboardHeight=$('.leaderboard-inner').outerHeight(true);var scaleLeaderHeight=$('#articleLeaderboardInner.leaderboard-inner .ad-container').height();if(scaleLeaderHeight==null||scaleLeaderHeight==0){scaleLeaderHeight=0;}else{$('#mobile-leader').remove();if($(window).width()<768){$('.placeholderLeaderboard').appendTo($('header#banner'));}}var mobileLeaderHeight=$('#mobile-leader.leaderboard-inner .ad-container').height();if(mobileLeaderHeight==null||mobileLeaderHeight==0){mobileLeaderHeight=0;}else{$('#articleLeaderboardInner').remove();}var leaderboardOffsetTop=$('.leaderboard-inner').offset().top;$triggered_num_times=0;var timeleft;if(scaleLeaderHeight!=0||mobileLeaderHeight!=0){if(window.addEventListener){window.addEventListener('scroll',debounce(function(){var windowtop=(window.scrollY||window.pageYOffset);if($triggered_num_times==0){if(leaderboardOffsetTop==0){$('.leaderboard-inner').addClass('stick-leader');$('.placeholderLeaderboard').css('height',leaderboardHeight);}if(scaleLeaderHeight==50){$('.leaderboard-inner').addClass('top-layer');}var counter=setInterval(timer,1000);function timer(){count=count-1;if(count<=0){clearInterval(counter);timeLeft=false;if($('.leaderboard-inner').hasClass('stick-leader')){if(mobileLeaderHeight>0){leaderboardHeight=mobileLeaderHeight;}leaderboardHeight=leaderboardHeight+30;$('.leaderboard-inner').css({'top':-leaderboardHeight,'transition':'top 0.5s ease'});$('.howto-video-feature.stick-rr-vid').css({'margin-top':'0','transition':'margin-top 0.5s ease'});$('.items.right-rail').css({'padding-top':'0'});window.setTimeout(function(){$('.leaderboard-inner').removeClass('stick-leader cover top-layer');$('.placeholderLeaderboard').css('height','0');},800);}return;}timeLeft=true;}$triggered_num_times=1;}if(windowtop>=leaderboardOffsetTop&&timeLeft){if(mobileLeaderHeight==50){leaderboardHeight=mobileLeaderHeight+20;}$('.leaderboard-inner').removeClass('top-layer');$('.leaderboard-inner').addClass('stick-leader cover');$('.placeholderLeaderboard').css('height',leaderboardHeight);if($('.howto-video-feature').hasClass('stick-rr-vid')){$('.howto-video-feature.stick-rr-vid').css({'margin-top':leaderboardHeight+10,'transition':'margin-top 0.2s ease'});}else{$('.howto-video-feature').css({'margin-top':'0','transition':'margin-top 0.5s ease'});}if($('.thm-gallery').hasClass('rr-gallery-vid')){$('.thm-gallery .items.right-rail').css({'padding-top':leaderboardHeight+10});}else{$('.thm-gallery .items').css({'padding-top':'0'});}}},5));}}});</script>
<nav class="breadcrumbs horiz">
<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
<li><a href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
<li><a href="/category/macs/" itemprop="url"><span itemprop="title">Macs</span></a></li>
</ul>
</nav>
<div class="category"><a href="/howto" itemprop="genre">How-To</a></div>
<h1 itemprop="headline">Hackintosh: Build a DIY Mac for gaming</h1>
<section class="deck viewability">
<h2 itemprop="description">Rob Griffiths decides to replace his nine-year-old Hackintosh (dubbed Frankenmac) with a new DIY Mac.</h2>
</section>
<div class="cat-social">
<div id="sharer" class="cat sidecar show">
<ul id="share-tool" class="expand">
<li class="sosh">
<a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.macworld.com%2Farticle%2F3199192%2Fmacs%2Fhow-to-build-a-hackintosh-high-performance.html" target="_blank" onclick="sharingTrack('Facebook-vert', 'fblike')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/facebook.svg"/>
</a>
</li>
<li class="sosh">
<a href="https://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.macworld.com%2Farticle%2F3199192%2Fmacs%2Fhow-to-build-a-hackintosh-high-performance.html&via=macworld&text=Hackintosh%3A+Build+a+DIY+Mac+for+gaming" target="_blank" onclick="sharingTrack('Twitter-vert', 'twshare')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/twitter.svg"/>
</a>
</li>
<li class="sosh">
<a href="https://plus.google.com/share?url=http%3A%2F%2Fwww.macworld.com%2Farticle%2F3199192%2Fmacs%2Fhow-to-build-a-hackintosh-high-performance.html" target="_blank" onclick="sharingTrack('GooglePlus-vert', 'googplus')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/gplus.svg"/>
</a>
</li>
<li class="sosh">
<a class="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?url=http%3A%2F%2Fwww.macworld.com%2Farticle%2F3199192%2Fmacs%2Fhow-to-build-a-hackintosh-high-performance.html&description=Hackintosh%3A+Build+a+DIY+Mac+for+gaming" target="_blank" onclick="sharingTrack('Pinterest-vert')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/pinterest.svg"/>
</a>
</li>
<li class="sosh">
<a href="http://reddit.com/submit?url=http%3A%2F%2Fwww.macworld.com%2Farticle%2F3199192%2Fmacs%2Fhow-to-build-a-hackintosh-high-performance.html&title=Hackintosh%3A+Build+a+DIY+Mac+for+gaming" target="_blank" onclick="sharingTrack('Reddit-vert')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/reddit.svg"/>
</a>
</li>
<li class="sosh cat">
<a href="#email" id="email-icon">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/mail.svg"/>
</a>
</li>
<li class="sosh hide cat print">
<a href="javascript:window.print();">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/print.svg"/>
</a>
</li>
</ul>
</div>
<script type="text/javascript">var isValidEmailAddress=isValidEmailAddress||function(emailAddress){var pattern=new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);return pattern.test(emailAddress);};function encodeQueryData(params){var ret=[];for(var paramKey in params){ret.push(encodeURIComponent(paramKey)+"="+encodeURIComponent(params[paramKey]));}return ret.join("&");}function bindEmailModal(){$('#emailModal').on("click",".close-btn",function(event){event.preventDefault();$('#emailModal').hide();$("#emailModal .eml-friend").show();$(".eml-friend-success").hide();$(".eml-friend-error").hide();$('#emailModal').fadeOut(200);$('#email-to').val('');$('#email-from').val('');$('#name').val('');$('#personalization').val('');$('#eml-from-address-message').html("");$('#eml-to-address-message').html("");$('#eml-friend-captcha-message').html("");});$('#emailModal').on("submit","form",function(event){event.preventDefault();var $form=$(this);var action=$form.attr('action');var formData=$form.serialize();var emailFrom=$('#email-from').val();var emailTo=$('#email-to').val();var uresponse=$('#g-recaptcha-response').val();$('#eml-from-address-message').html("");$('#eml-to-address-message').html("");$('#eml-friend-captcha-message').html("");if(isValidEmailAddress(emailFrom)&&isValidEmailAddress(emailTo)&&uresponse!=""){$.ajax(action,{type:'POST',data:formData,success:function(data,textStatus,xhr){$("#emailModal .eml-friend").hide();$(".eml-friend-success").fadeIn(800);},error:function(xhr,textStatus,errorThrown){$("#emailModal .eml-friend").hide();$(".eml-friend-error").fadeIn(800);}});}else{if(uresponse==""){$('#eml-friend-captcha-message').html("Please verify you're not a robot!");}if(!isValidEmailAddress(emailTo)){$('#eml-to-address-message').html("Please enter a valid email address.");}if(!isValidEmailAddress(emailFrom)){$('#eml-from-address-message').html("Please enter a valid email address.");}}});}$(document).ready(function(){$(document).on("click","#email-icon",function(event){event.preventDefault();bindEmailModal();sharingTrack('Email-vert');$('#emailModal').fadeIn(800);});});</script>
<div class="modal eml-friend-wrapper" id="emailModal" style="display:none;">
<form class="eml-friend" action="/eloquaemail/article?eloqua=false&id=3199192">
<input type="hidden" name="title" value="Hackintosh: Build a DIY Mac for gaming"/>
<input type="hidden" name="url" value="http://www.macworld.com/article/3199192/macs/how-to-build-a-hackintosh-high-performance.html"/>
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Email a friend</h3>
<div class="input-row">
<div id="eml-to-address-message" class="error-msg"></div>
<h4 class="input-label">To</h4>
<input id="email-to" value="" placeholder="Email address (required)" type="email" name="recipients" tabindex="1">
<p class="addl-text">Use commas to separate multiple email addresses</p>
</div>
<hr/>
<div class="input-row">
<div id="eml-from-address-message" class="error-msg"></div>
<h4 class="input-label">From</h4>
<input id="name" value="" placeholder="Name (optional)" type="text" name="name" tabindex="2">
</div>
<div class="input-row">
<input id="email-from" value="" placeholder="Email address (required)" type="email" name="sender" tabindex="3">
</div>
<div class="input-row">
<textarea name="message" placeholder="Check out this article I found on Macworld." id="personalization" tabindex="4"></textarea>
</div>
<hr/>
<div class="input-row">
<div id="eml-friend-captcha-message" class="error-msg"></div>
<script src="https://www.google.com/recaptcha/api.js" async defer></script>
<div class="g-recaptcha" data-sitekey="6Lew1fwSAAAAANp38ScDcwtgHsGa7fj9ofV6OiAF"></div>
</div>
<hr/>
<div class="submit">
<input type="submit" value="Send" class="input-submit" tabindex="5">
<a href="/about/privacy.html" class="submit-privacy" target="_blank">Privacy Policy</a>
</div>
</form>
<div class="eml-ty eml-friend-success" style="display:none;">
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Thank you</h3>
<p class="msg-sent">Your message has been sent.</p>
</div>
<div class="eml-friend-error" style="display:none;">
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Sorry</h3>
<p class="msg-sent">There was an error emailing this page.</p>
</div>
</div>
</div>
<div class="cat byline vcard author with-image">
<div class="byline-wrapper">
<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
<a href="/author/Rob-Griffiths/" rel="author" title="Rob Griffiths"><img class="bylineImage  imgId100001705 " src="http://core1.staticworld.net/images/article/2012/09/rob-100001705-byline.png" width="34" width="34" alt="Rob Griffiths" itemprop="image"/></a>
<span class="by">By </span><span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/Rob-Griffiths/"><span itemprop="name">Rob Griffiths</span></a></span>
</p>
<p class="dateline">
Senior Contributor,
<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name">Macworld</span></span> <span class="divider break">|</span>
<span class="pub-date" class='break-date' itemprop="datePublished" content="2017-06-21T03:15-0700">Jun 21, 2017 3:15 AM
PT
</span>
</p>
</div>
</div>
</header>
<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
<meta itemprop="representativeOfPage" content="1">
<img src="http://images.idgesg.net/images/article/2017/06/hackintosh_pro_innards-100724681-large.jpg" alt="hackintosh pro innards" itemprop="contentUrl"/>
<figcaption>
Credit:<span itemprop="copyrightHolder">
Rob Griffiths/IDG
</span>
</figcaption>
</figure>
<div id="video-howto-wrapper"></div>
<script>if($(window).width()>=930){$(document).ready(function(){$.get("/napi/tile",{"def":"video.howto","aid":"3199192","isAjax":"true","trackImpression":"Article Detail:Right:Howto Video"},function(data){$("#video-howto-wrapper").html(data);});});}if($(window).width()>=930){function debounce(func,wait,immediate){var timeout;return function(){var context=this,args=arguments;var later=function(){timeout=null;if(!immediate)func.apply(context,args);};var callNow=immediate&&!timeout;clearTimeout(timeout);timeout=setTimeout(later,wait);if(callNow)func.apply(context,args);};}$(window).load(function(){var videohowtoOffsetTop=$('#video-howto-wrapper').offset().top;var videoWrapperHeight=$('div.howto-video-feature').outerHeight(true);videoWrapperHeight=videoWrapperHeight+20;$('div.howto-video-feature').css('height',videoWrapperHeight);var heroImageHeight=$('figure.hero-img').outerHeight(true);if(heroImageHeight===null){heroImageHeight=0;}var galleryHeight=$('figure.thm-gallery').outerHeight(true);if(galleryHeight===null){galleryHeight=0;}var bodeeHeight=($('div#drr-container').outerHeight(true)+heroImageHeight+galleryHeight);videohowtoOffsetTop=videohowtoOffsetTop;if(window.addEventListener){window.addEventListener('scroll',debounce(function(){var windowtop=(window.scrollY||window.pageYOffset);windowtop=windowtop-5;if(windowtop>=videohowtoOffsetTop){$('#video-howto-wrapper').css('z-index','2');$('#drr-top-ad.epo.cat-narrow').css('margin-top',videoWrapperHeight);$('#video-howto-wrapper .howto-video').addClass('stick-vid');$('#video-howto-wrapper .howto-video .howto-video-feature').addClass('stick-rr-vid');}else{$('#video-howto-wrapper').css('z-index','1');$('#drr-top-ad.epo.cat-narrow').css('margin-top','0');$('#video-howto-wrapper .howto-video').removeClass('stick-vid');$('#video-howto-wrapper .howto-video .howto-video-feature').removeClass('stick-rr-vid');}if((windowtop-videohowtoOffsetTop)>(bodeeHeight-150)){$('#video-howto-wrapper .howto-video .howto-video-feature').addClass('unstick-rr-vid').css('top',(bodeeHeight-150));}else{$('#video-howto-wrapper .howto-video .howto-video-feature').removeClass('unstick-rr-vid').css('top','0');}},5));}});}</script>
<section class="epo cat-narrow" id="drr-top-ad">
<!-- Related -->
<div class="related-promo-wrapper">
<div class="promo apart">
<div class="hed">More like this</div>
<ul class="">
<li class="clearfix with-image">
<a href="/article/3196994/macs/how-to-build-a-hackintosh.html"><img class="small.3x2Image  imgId100722863 " src="http://core0.staticworld.net/images/article/2017/05/hackintosh-2017-100722863-small.3x2.jpg" alt="hackintosh 2017" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3196994/macs/how-to-build-a-hackintosh.html">Hackintosh: Build a DIY Mac mini</a></div>
</div>
</li>
<li class="clearfix ">
<div class="item">
<div class="title"><a href="/article/1053934/handsonmp2.html">Hands on with the Mac Pro: Putting it to work</a></div>
</div>
</li>
<li class="clearfix ">
<div class="item">
<div class="title"><a href="/article/1050027/xpmini.html">First Look: The XP experiment: Running Windows on a Mac</a></div>
</div>
</li>
<li class="clearfix with-image">
<a class="play" href="/video/78737/macbook-pro-kaby-lake-first-look"><i class="ss-play"></i></a>
<a href="/video/78737/macbook-pro-kaby-lake-first-look"><img class="small.3x2Image  imgId100725726 " src="http://images.idgesg.net/images/article/2017/06/mfl_004-macbookprokabylake-100725726-small.3x2.jpg" alt="mfl 004 macbookprokabylake" itemprop="image"/></a>
<div class="item">
<div class="item-eyebrow">Video</div>
<div class="title"><a href="/video/78737/macbook-pro-kaby-lake-first-look">MacBook Pro Kaby Lake first look</a></div>
</div>
</li>
</ul>
</div>
</div>
<div class="ad top-ad">
<div id="gpt-showcase" class="adunit ad-container">
</div>
<script type="text/javascript">if($(window).width()>=930){IDG.GPT.addDisplayedAd("gpt-showcase","true");$('#gpt-showcase').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: gpt-showcase - [971 1115]");}</script>
</div>
</section>
<section class="bodee">
<div class="ad placement">
<!--  Begin gpt-skin/inread -->
<div id="inread" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("inread","true");IDG.GPT.displayGoogleTagSlot('inread');</script>
<!--  End gpt-skin/inread -->
</div>
<div class="tocWrapper scaleArticleToc some-toc">
<legend>Table of Contents <i class="ss-navigatedown"></i></legend>
<ul class="articleToc">
<li data-pagenum="1" data-tocnum="1"><a href="#toc-1">Why build a Hackintosh?</a></li>
<li data-pagenum="1" data-tocnum="2"><a href="#toc-2">Motherboard</a></li>
<li data-pagenum="1" data-tocnum="3"><a href="#toc-3">Processor</a></li>
<li data-pagenum="1" data-tocnum="4"><a href="#toc-4">Memory</a></li>
<li data-pagenum="1" data-tocnum="5"><a href="#toc-5">Graphics</a></li>
<li data-pagenum="1" data-tocnum="6"><a href="#toc-6">Networking</a></li>
<li data-pagenum="1" data-tocnum="7"><a href="#toc-7">Case</a></li>
<li data-pagenum="1" data-tocnum="8"><a href="#toc-8">Building the Hackintosh</a></li>
<li data-pagenum="1" data-tocnum="9"><a href="#toc-9">Installing macOS</a></li>
<li data-pagenum="1" data-tocnum="10"><a href="#toc-10">Better framerates</a></li>
</ul>
<div class="toc-show-more">Show More <i class="ss-navigatedown"></i></div>
</div>
<script type="text/javascript">$(document).ready(function(){$('.articleBloxAd').filter(":visible").each(function(index,item){var id=$(item).attr('id');var divClass=$(item).attr('class');var adString=IDG.GPT.getLazyAdCode();$(item).replaceWith("<div id=\""+id+"\" class=\"lazyload_blox_ad "+divClass+"\">"+adString+"</div>");});try{$("div.lazyload_blox_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});}catch(exception){console.log("error loading lazyload_ad "+exception);}});</script>
<script type="text/javascript">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</script>
<div id="drr-container" class='cat ' itemprop="articleBody">
<p>Fellow Macworld contributor Kirk McElhearn recently built a <a href="http://www.macworld.com/article/3196994/how-to-build-a-hackintosh.html">mini Hackintosh</a>; that is, a generic PC styled like a Mac mini, on which he installed and ran macOS. This is a road I’ve gone down myself, way back in 2008, when I <a href="http://www.macworld.com/article/1133028/building_mac_clone.html">built my Frankenmac</a>. As Kirk was building a relatively low-end Mac clone, and as Apple has <a href="http://www.macworld.com/article/3187450/os-x/apple-finally-refreshes-the-mac-pro-but-the-model-you-want-isnt-coming-this-year.html">ignored the high-end Mac Pro</a> for so many years, I thought it’d be interesting to build a new high-end Frankenmac.</p><h3 class="toc" id="toc-1">Why build a Hackintosh?</h3><p>My current machine is a late 2014 5K iMac, and while it works well for most tasks, it really suffers when I pursue my avocation: Flying the <a href="http://www.x-plane.com">X-Plane flight simulator</a>. Frame rates can vary from decent to slow, and the iMac’s fan ramps up nearly as soon as I launch the simulator. In the end, the simulator is what really drove my desire to build a new Frankenmac: I wanted a machine that could run X-Plane really well, without a screaming loud fan, and hopefully be used as my iMac replacement (at least until the “new new” Mac Pro is <a href="http://www.macworld.com/article/3187450/os-x/apple-finally-refreshes-the-mac-pro-but-the-model-you-want-isnt-coming-this-year.html">released</a>).</p><p>The key to this project was Nvidia’s announcement of <a href="http://www.macworld.com/article/3189405/macs/nvidia-releases-mac-driver-with-support-for-titan-xp-and-geforce-gtx-1000-series.html">Pascal drivers for the Mac</a>. This meant that I could put in a leading-edge video card—one of the <a href="https://www.nvidia.com/en-us/geforce/products/10series/">GeForce GTX 10 series</a> cards. These cards will easily outperform (in games, at least) anything in any Mac that Apple currently ships.</p><p>I won’t provide as much detail as did Kirk, but here are the components I used.</p><h3 class="toc" id="toc-2">Motherboard</h3><figure class="large "><img src="http://images.idgesg.net/images/article/2017/06/ga-z170x-ud3-100726180-large.jpg" border="0" alt="ga z170x ud3" width="700" height="467" data-imageid="100726180"/> <small class="credit">Gigabyte</small> <figcaption>
<p>Gigabyte GA-Z170X-UD3 motherboard</p>
</figcaption></figure><p>Like Kirk, I went with Gigabyte for the motherboard; for me, a <a href="https://www.gigabyte.com/Motherboard/GA-Z170X-UD3-Ultra-rev-10#ov">GA-Z170X-UD3</a> ($130 on <a href="https://www.amazon.com/gp/product/B012N6ESTC">Amazon</a>). My motherboard doesn’t have Wi-Fi, but I added it with the Fenvi <a href="http://en.fenvi.com/en/brand_view.php?id=366">802.11AC Desktop Wifi Card</a> ($70 on <a href="https://www.amazon.com/gp/product/B01MDLG51U">Amazon</a>). This card is favored with Hackintosh builders, as it supposedly supports Handoff and Continuity without any troubles.</p><h3 class="toc" id="toc-3">Processor</h3><p>I chose an Intel Core i7 6700K 4.0GHZ CPU ($300 on <a href="https://www.amazon.com/gp/product/B012M8LXQW">Amazon</a>). This is basically the fastest desktop-class CPU that’s fully supported in a Hackintosh.</p><h3 class="toc" id="toc-4">Memory</h3><p>I ordered 32GB of RAM, given it’s relatively inexpensive and I didn’t want to worry about swap files.</p><h3 class="toc" id="toc-5">Graphics</h3><p>Kirk used onboard video, but in my case, that wouldn’t cut it for X-Plane. I chose the Gigabyte <a href="http://www.gigabyte.us/Graphics-Card/GV-N108TGAMING-OC-11G#kf">GeForce GTX GV-N1080</a> ($550 on <a href="https://www.amazon.com/gp/product/B01GJEE9BG">Amazon</a>). This was the most expensive single item in my build, surpassing even the CPU in cost. But it’s a wicked-fast card that will run circles (in gaming) around anything Apple ships.</p><aside class="nativo-promo smartphone tablet desktop" id=""> </aside><figure class="large "><img src="http://images.idgesg.net/images/article/2017/06/geforce-gtx-gv-n1080-100726181-large.jpg" border="0" alt="geforce gtx gv n1080" width="700" height="467" data-imageid="100726181"/> <small class="credit">Gigabyte</small> <figcaption>
<p>Gugabyte GeForce GTX GV-N1080 graphics card</p>
</figcaption></figure><h3 class="toc" id="toc-6">Networking</h3><p>I’m using the on-board ethernet for connecting to my home network; the Wi-Fi card works, but I use it only for Handoff and Continuity, as this is a desktop machine that sits a few feet from my router.</p><h3 class="toc" id="toc-7">Case</h3><figure class="medium right"><a class="zoom" href="http://images.idgesg.net/images/article/2017/06/antec-p-100-case-100726179-large.jpg"><img src="http://images.idgesg.net/images/article/2017/06/antec-p-100-case-100726179-medium.jpg" border="0" alt="antec p 100 case" width="300" height="200" data-imageid="100726179"/></a> <small class="credit">Antec</small> <figcaption>
<p>Antec Performance Series Case P-100</p>
</figcaption></figure><p>Because I wanted room for more hard drives (so I could install an internal Time Machine drive, along with separate drives for Linux and Windows 10), I bought an Antec <a href="https://www.amazon.com/Antec-Performance-Case-P-100-Black/dp/B00FGHHQO0">Performance Series Case P-100</a> which features seven internal drive bays, quiet design, and a very reasonable $80 price tag.</p><p>In total—excluding keyboard, mouse, and monitor—I spent $1,567 on parts. There’s not really a comparison to this machine in Apple’s lineup, thanks to the video card.</p><h3 class="toc" id="toc-8">Building the Hackintosh</h3><p>Kirk <a href="http://www.macworld.com/article/3196994/macs/how-to-build-a-hackintosh.html">describes the process well</a>, so I’ll just add that if you don’t enjoy working with small parts in tight, enclosed spaces, you probably won’t enjoy building a PC. But if you do like such things, building a PC is a rewarding experience: There’s nothing like that first boot to BIOS (a configuration system built into the motherboard) after powering on for the first time.</p><h3 class="toc" id="toc-9">Installing macOS</h3><p>Kirk’s summary of the OS install is spot-on: It’s not plug and play, but getting macOS running isn’t overly difficult, to a point. That point is “macOS is installed and it works.” You’ll probably have networking and onboard video and maybe you’ll get lucky and have sound, too. And if your machine is a network server, like Kirk’s, that’s probably all you need.</p><p>But as I was trying to make my Hackintosh my every day Mac, I needed more. I needed Handoff and Continuity. I needed Apple’s native Messages support. I needed audio to work. I needed to be able to play iTunes protected videos. I needed sleep and wake to work. And the list goes on.</p><p>In the end, it’s these additional steps that will try your patience if you’re building a Hackinotsh that you want to be your do-everything Mac. Sure, there are theoretically solutions to all of these (and other) issues. The challenge lies in finding the right solution for your chosen hardware, then hopefully implementing it properly. If you do it right, you gain functionality. If you do it wrong, you probably boot to a black screen and may have to start all over. That happened to me three times.</p><h3 class="toc" id="toc-10">Better framerates</h3><p>While there were (and still are) many challenges with my Hackintosh, I did manage to create a very nice gaming Mac. First off, the machine is notably quieter than my iMac—none of my testing drove the fan noise higher than the background level, unlike my iMac. That may seem a minor thing, but fan noise is incredibly irritating.</p><p>Second, the performance is simply night-and-day better than that of my iMac. I used the <a href="http://www.xonotic.org">Xonotic</a> first-person-shooter game to test each Mac, using the game’s built-in “the-big-keybench” benchmark. I set each to run at 2560 x 1440 (via Retina displays), with identical settings for all graphics items. The iMac’s final score was 38.2 frames per second (fps), with a low of 12 fps and a high of 129 fps. The Hackintosh crushed those figures, returning 95.4 fps, with a low of 25 fps and a high of 688 fps.</p><p>And what about X-Plane? It doesn’t have a built-in benchmark, but it’s possible to display fps rates and output them to a data file. Doing that, and flying similar profiles with identically configured simulators, the iMac returns roughly 23 fps, against 39 fps on the Hackintosh.</p><p>That’s an improvement of about 70 percent, and it makes a ton of difference in the feel of the simulator.</p><figure class="large "><a class="zoom" href="http://images.idgesg.net/images/article/2017/06/xplane_fps-100724682-orig.jpg"><img src="http://images.idgesg.net/images/article/2017/06/xplane_fps-100724682-large.jpg" border="0" alt="xplane fps" width="700" height="454" data-imageid="100724682" data-license="IDG"/></a> <small class="credit">Rob Griffiths/IDG</small> <figcaption>
<p>The Hackintosh’ frames per second (orange line) easily outpaces that of the iMac (gray line) in X-Plane. The occasional drops to 20 fps may be due to the beta release of X-Plane, or the beta video card drivers in the Hackintosh.</p>
</figcaption></figure><h3 class="toc" id="toc-11">Summing up</h3><p>After way too many hours of effort, I have given up on making my Hackintosh my every day Mac. I never got Messages working. My audio works until the machine sleeps, then it won’t work until I reboot. Sometimes the machine won’t even wake from sleep. Handoff and Continuity do work…sometimes (but hey, that’s no different than a “real” Mac!). I never got iTunes protected video to play. And on and on goes the list of “little things.”</p><p>Was the project a total failure? Not really—my Hackintosh is an excellent gaming Mac that runs X-Plane incredibly well. And because I bought a multi-drive case, it’s now capable of also booting (via separate hard drives) into two different flavors of Linux along with Windows 10. I’ve sold my old Windows machine, and when the Hackintosh isn’t X-Planing, it’s my Windows machine.</p><p>But it’s never going to be my everyday Mac. Come on, Apple, hurry up with those new Mac Pros!</p>
<div class="end-note">
<!-- blx4 #2007 blox4.html  -->
<div id="" class="blx blxParticleendnote blxM2007  blox4_html  blxC24067">To comment on this article and other Macworld content, visit our <a href="https://www.facebook.com/Macworld/" target="_blank">Facebook</a> page or our <a href="https://twitter.com/macworld" target="_blank">Twitter</a> feed. </div>
</div>
</div>
<div class="apart-alt tags">
<span class="related">Related: </span>
<ul>
<li><a href="/category/macs">Macs</a></li>
<li><a href="/category/software-games">Games</a></li>
<li><a href="/category/computers">PCs</a></li>
<li><a href="/category/os-x">OS X</a></li>
<li><a href="/category/hardware">Hardware</a></li>
<li><a href="/tag/diy/" rel="nofollow">DIY</a></li>
<li><a href="/tag/macpro/" rel="nofollow">Mac Pro</a></li>
</ul>
</div>
<div class="byline vcard author end-byline">
<div class="author-info" id="robgriffiths">
<p>Former Macworld Senior Editor Rob Griffiths founded Mac OS X Hints. He's now master of ceremonies at <a href="http://manytricks.com/">Many Tricks Software</a>.</p>
<div class="brand-social">
<div class="follow-text">Follow</div>
<ul class="social-links">
<li>
<a href="/author/Rob-Griffiths/">
<i class="ss-icon ss-user"></i>
</a>
</li>
<li>
<a href="https://twitter.com/rgriff" class="twitter-follow" target="_blank">
<i class="ss-icon ss-social ss-twitter"></i>
</a>
</li>
</ul>
</div>
</div><!-- end .author-info -->
</div>
<script src="/www/js/video/embedder.js?v=20170619121402"></script>
</section><!-- /.bodee -->
<div id="content-recommender" class="nolinks norewrite">
<div class="head">You Might Like</div>
<div id="rcjsload_d0e914"></div>
</div>
<script type="text/javascript">(function(){function ad_block_test(e,o){if("undefined"!=typeof document.body){var t="0.1.2-dev",o=o?o:"sponsorText",n=document.createElement("DIV");n.id=o,n.style.position="absolute",n.style.left="-999px",n.appendChild(document.createTextNode("&nbsp;")),document.body.appendChild(n),setTimeout(function(){if(n){var o=0==n.clientHeight;try{}catch(d){console&&console.log&&console.log("ad-block-test error",d)}e(o,t),document.body.removeChild(n)}},175)}}ad_block_test(function(is_blocked){var widget_id=30198;if(is_blocked===true){widget_id=30272;}var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);var rcel=document.createElement("script");rcel.id='rc_'+Math.floor(Math.random()*1000);rcel.type='text/javascript';rcel.src="http://trends.revcontent.com/serve.js.php?w="+widget_id+"&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth||document.documentElement.clientWidth)+"&referer="+referer+'&is_blocked='+is_blocked;rcel.async=true;var rcds=document.getElementById("rcjsload_d0e914");rcds.appendChild(rcel);});})();</script>
<div id="amazon-bottom-widget">
<div class="amzn-custom-header">Shop Tech Products at Amazon</div>
<script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&storeId=httpwwwidgcsm-20&adInstanceId=f28f8449-ab80-4ceb-941b-6f3ebf8ef345"></script>
</div>
</article>
</section><!-- /role=main -->
</div><!-- /#page-wrapper -->
<div id="panel-loader"></div>
<!-- IDGMPM-11812, category.getCategoryType() returns an integer, and 9 stands for tentpole-->
<div id="tso-wrapper"><div id="tso" style="display:none"></div></div>
<script type="text/javascript">function renderTSO(ads){$thm.debug("renderTSO:"+ads.length);if(ads&&ads.length>0){var selectedAds=selectTSOAds(ads,6);if(null!=selectedAds&&selectedAds.length>0){var html="<h3>Today's Special Offers</h3>";html+="<ul>";for(var i=0;i<selectedAds.length;i++){html+="<li>";html+="<a href='"+selectedAds[i].url+"' onclick='oClickTrack(\"Article Detail:Funnel:TSO\")'>"+selectedAds[i].title+"</a>";html+="<span>"+selectedAds[i].body+"</span>";if(null!=selectedAds[i].pixel&&selectedAds[i].pixel.length>0){html+="<img src='"+selectedAds[i].pixel+"' style='height:0;width:0;'/>";}html+="</li>";}html+="</ul>";$("#tso").html(html).show();}}}function selectTSOAds(ads,max){if(ads.length<=max){return ads;}else{var uniq={};var found=0;var selectedAds=[];while(found<max){var ad=ads[Math.floor(Math.random()*ads.length)];if(uniq[ad.id]!=null){continue;}else{uniq[ad.id]=true;found++;selectedAds.push(ad);}}return selectedAds;}return null;}</script>
<div id="network"></div>
<footer id="footer" class="clearfix">
<div class="container clearfix">
<div class="footer-col">
<a href="http://macworld.com" id="footer-logo-mw" class="ir">Macworld</a>
<p>Macworld is your best source for all things Apple. We give you the scoop on what's new, what's best and how to make the most out of the products you love.</p>
<ul>
<li><a href="http://www.idgcsmb.com" rel="nofollow">About Us</a></li>
<li><a href="http://www.idgcsmb.com/contact" rel="nofollow">Contact Us</a></li>
<li><a href="http://hints.macworld.com/" rel="nofollow">Mac OS X Hints</a></li>
<li><a href="http://idgcsmb.com/about-adchoices-macworld/" rel="nofollow">Ad Choices</a></li>
<li><a href="/directions" rel="nofollow">Digital Magazines</a></li>
<li><a href="/newsletters/signup.html">Newsletters</a></li>
</ul>
<ul class="right">
<li><a href="http://www.idgcsmb.com/macworld-privacy-policy/" rel="nofollow">Privacy Policy</a></li>
<li><a href="/about/RSS.html">RSS</a></li>
<li><a href="http://idgcsmb.com/terms-of-service-agreement/" rel="nofollow">Terms of Service Agreement</a></li>
<li><a href="/about/affiliates.html">E-commerce Affiliate Relationships</a></li>
</ul>
</div>
<div class="footer-col">
<h2>Macworld CATEGORIES</h2>
<ul>
<li><a href="/category/business/">Business</a></li>
<li><a href="/category/creative/">Creative</a></li>
<li><a href="/category/entertainment/">Entertainment</a></li>
<li><a href="/category/ios-apps/">iOS Apps</a></li>
<li><a href="/category/mac-apps/">Mac Apps</a></li>
</ul>
<ul class="right">
<li><a href="/category/macs/">MacCentral</a></li>
<li><a href="/category/iphone-ipad/">iPhone/iPad</a></li>
<li><a href="/category/os-x/">OS X</a></li>
<li><a href="/column/mwpodcast">Podcasts</a></li>
<li><a href="/video/">Video</a></li>
</ul>
<h3>IDG Network Sites</h3>
<ul>
<li><a href="http://www.idgcsmb.com/advertisewithus/" rel="nofollow">Advertise</a></li>
<li><a href="http://careers.idg.com/" rel="nofollow">Careers at IDG</a></li>
<li><a href="http://www.idgcreativelab.com/" rel="nofollow">Creative Lab</a></li>
<li><a href="http://idg.com/www/home.nsf/home?readform" rel="nofollow">IDG</a></li>
<li><a href="http://www.idgcsmb.com/" rel="nofollow">IDG Consumer &amp; SMB</a></li>
</ul>
<ul class="right">
<li><a href="http://idgknowledgehub.com/" rel="nofollow">Knowledge Hub</a></li>
<li><a href="http://www.macworldiworld.com/" rel="nofollow">Macworld|iWorld</a></li>
<li><a href="http://www.pcworld.com/" rel="nofollow">PCWorld</a></li>
<li><a href="http://www.techhive.com/" rel="nofollow">TechHive</a></li>
<li><a href="http://www.idgcsmb.com/contact/permissions/" rel="nofollow">Permissions</a></li>
</ul>
</div>
<div class="footer-col">
<div id="footer-subscribe" class="clearfix">
<a href="https://ssl.palmcoastd.com/31401/apps/MCWDIGITAL?ikey=I**A03" rel="nofollow">
<img src="http://csmb.staticworld.net/images/furniture/macworld/footer-subscribe-mag-mw.png" alt="Macworld Magazine Cover">
<h2>Try Macworld <span>Risk-Free</span></h2>
<span class="btn-link">Subscribe Now</span>
</a>
</div>
<div id="footer-social">
<span>Follow us</span> <a href="http://www.facebook.com/Macworld" class="network-fb ss-icon ss-social-circle banner-social banner-fb" alt="Facebook" itemprop="sameAs" rel="nofollow">
&#xF610;
</a>
<a href="https://twitter.com/macworld" class="network-tw ss-icon ss-social-circle banner-social banner-tw" alt="Twitter" itemprop="sameAs" rel="nofollow">
&#xF611;
</a>
<a href="https://plus.google.com/+macworld/posts" class="network-google ss-icon ss-social-circle banner-social banner-google" alt="Google+" itemprop="sameAs" rel="publisher">
&#xF613;
</a>
</div>
<p>Visit other IDG sites:</p>
<div id="idgInfo" class="styled-select">
<select onchange="location = this.options[this.selectedIndex].value;" id="jumpMenu" name="jumpMenu" d30tagged="1" style="visibility: visible;">
<option value="">Select One</option>
<option value="http://www.cio.com">CIO</option>
<option value="http://www.computerworld.com">Computerworld</option>
<option value="http://www.csoonline.com">CSO</option>
<option value="http://www.greenbot.com">Greenbot</option>
<option value="http://www.idgconnect.com">IDG Connect</option>
<option value="http://www.idgtechnetwork.com">IDG TechNetwork</option>
<option value="http://www.idg.tv">IDG.tv</option>
<option value="http://www.infoworld.com">InfoWorld</option>
<option value="http://www.itnews.com">IT News</option>
<option value="http://www.itworld.com">ITworld</option>
<option value="http://www.javaworld.com">JavaWorld</option>
<option value="http://www.networkworld.com">Network World</option>
<option value="http://www.pcworld.com">PC World</option>
<option value="http://www.techhive.com">TechHive</option>
<option value="http://www.thestandard.com">The Industry Standard</option>
</select>
</div>
<p><small><a href="http://idgcsmb.com/terms-of-service-agreement/">Copyright</a> &copy; 2017 IDG Communications, Inc.</small></p>
</div>
</div>
</footer>
<div id="gpt-infunnel" class=" ad-container"></div>
<script type="text/javascript">try{IDG.GPT.addDisplayedAd("gpt-infunnel","true");$('#gpt-infunnel').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: gpt-infunnel [971 1115]");}catch(exception){console.log("Error with IDG.GPT: "+exception);}</script>
<script src="/www/js/analytics/mouse_down.js?v=20170619121402"></script>
<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
<script src="/www.idgcsmb/js/jquery/jquery-ui-tools.js?v=20170111"></script>
<script src="/www.idgcsmb/js/thm_post.js?v=20170619121402"></script>
<script src="/www/js/product-toc.js?v=20170619121402"></script>
<script src="/www.idgcsmb/js/jquery/plug-ins/jquery.md5.js"></script>
<script src="/www/js/carousel-extend.js?v=20170619121402"></script>
<script src="/www.idgcsmb/js/jquery/plug-ins/jquery.colorbox-min.js"></script>
<script src="/www.idgcsmb/js/autocomplete.js?v=20170619121402"></script>
<script src="/www/js/jquery/jquery.lazyload.min.js?v=20170619121402"></script>
<script>$(function(){$("img.lazy").lazyload({effect:"fadeIn",threshold:200,failure_limit:25});});</script>
<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js?v=20170619121402"></script>
<script type="text/javascript">$(document).ready(function(){$('.articleBloxAd').filter(":visible").each(function(index,item){var id=$(item).attr('id');var divClass=$(item).attr('class');var adString=IDG.GPT.getLazyAdCode();$(item).replaceWith("<div id=\""+id+"\" class=\"lazyload_blox_ad "+divClass+"\">"+adString+"</div>");});try{$("div.lazyload_blox_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});}catch(exception){console.log("error loading lazyload_ad "+exception);}});</script>
<script type="text/javascript">try{$("div.lazyload_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});}catch(exception){console.log("Error with lazyLoadAd: "+exception);}</script>
<script src="/www.idge/js/jquery/jquery.tablesorter.min.js?v="></script>
<script>$(document).ready(function(){$("table.tablesorter").tablesorter({widgets:['zebra']});$("table.tablesorter tbody tr").hover(function(){$(this).toggleClass("selected");});$("table.tablesorter thead tr th").each(function(){if($(this).find('.ss-icon').length<1){$(this).append('<i class="ss-icon"></i>');}});});</script>
<script>$(".learn-more").click(function(event){var brandpost_txt="<div class=\"about-brandposts\"><p>BrandPosts are written and edited by members of our sponsor community. BrandPosts create an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of BrandPosts.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";if($(".blog-byline.sponsored-post").length>0){brandpost_txt="<div class=\"about-brandposts\"><p>SponsoredPosts are written and edited by members of our sponsor community. SponsoredPosts create an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of SponsoredPosts.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";}$("body").append(brandpost_txt);$(".about-brandposts").css("top",event.pageY);if($("body").width()>=955){var xpos=$("body").width()-event.pageX;$(".about-brandposts").css({"right":xpos,"margin-right":"0"});}$(".about-brandposts .close-bar").click(function(){$(".about-brandposts").remove();return false;});return false;});</script>
<script type="text/javascript">(function(){function loadHorizon(){var s=document.createElement('script');s.type='text/javascript';s.async=true;s.src=location.protocol+'//ak.sail-horizon.com/horizon/v1.js';var x=document.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);}loadHorizon();var oldOnLoad=window.onload;window.onload=function(){if(typeof oldOnLoad==='function'){oldOnLoad();}Sailthru.setup({domain:'horizon.macworld.com',useStoredTags:false});};if(console!=undefined){console.log('SAIL-23 fired Horizon');}})();</script>
<script type='text/javascript'>$(document).ready(function(){$('#extra-nav-toggle a').click(function(){if($(this).hasClass('open')){$('#extra-nav').hide();$(this).removeClass('open');$('#extra-nav-toggle a').removeClass('ss-delete');$('#extra-nav-toggle a').addClass('ss-dropdown');}else{$('#extra-nav').show();$(this).addClass('open');$('#extra-nav-toggle a').removeClass('ss-dropdown');$('#extra-nav-toggle a').addClass('ss-delete');}return false;});});g_arrModules['Article Detail:Top:Breadcrumb']=true;g_arrModules['Article Detail:Social Sharing Vertical']=true;$(document).ready(function(){var tocTopper=10;if($('body').hasClass('macworld')||$('body').hasClass('pcworld')||$('body').hasClass('techhive')){tocTopper=0;}$(window).resize(function(){var scaleTocFixBegin=$("#drr-container.cat").offset().top-tocTopper;var scaleTocFixEnd=$(".bodee").offset().top+$(".bodee").height();var scaleTocStartOffsetTop=5;doProductToc(true,false,scaleTocFixBegin,scaleTocFixEnd,scaleTocStartOffsetTop);}).resize();});g_arrModules['']=true;g_arrModules['Article Detail:Funnel:TSO']=true;$.ajax('/ads/tso',{dataType:'json',success:function(data){renderTSO(data.tsoLinks);},error:function(jqXHR,error,thrown){$thm.debug("TSO AJAX Status: "+error+": "+thrown,true);}});</script>
<script type="text/javascript">a=top;f=self;if(a!=f){a.location=f.location;}</script>
<!-- Begin BlueKai Tag-->
<iframe name="__bkframe" height="0" width="0" frameborder="0" src="javascript:void(0)"></iframe>
<script type="text/javascript" src="http://tags.bkrtx.com/js/bk-coretag.js"></script>
<!-- CryptoJS -->
<script src="/www/js/utils/md5.js"></script>
<script type="text/javascript" src="/www/js/analytics/idg_bk_coreapi.js?v=20170619121402"></script>
<script type="text/javascript">bk_allow_multiple_calls=true;var blueKaiId=13977;var blueKaiPort=10;var brandCode="mw";var regUrl="http://regdev.idge.int/api/"
var daysToRefresh=30;var bk_debug_log=false;regUrl="http://reg.idgenterprise.com/api/";daysToRefresh=30;if(typeof(s)!=='undefined'){bk_addPageCtx("p2",(typeof(s.prop2)!='undefined')?s.prop2:'');bk_addPageCtx("p9",(typeof(s.prop9)!='undefined')?s.prop9:'');bk_addPageCtx("p18",(typeof(s.prop18)!='undefined')?s.prop18:'');bk_addPageCtx("p54",(typeof(s.prop54)!='undefined')?s.prop54:'');bk_addPageCtx("p56",(typeof(s.prop56)!='undefined')?s.prop56:'');bk_addPageCtx("p59",(typeof(s.prop59)!='undefined')?s.prop59:'');bk_addPageCtx("p60",(typeof(s.prop60)!='undefined')?s.prop60:'');}bk_addPageCtx("cmscatids","[3800,3084,2101,3675,3020]");bk_addPageCtx("cmpy","[]");bk_addPageCtx('tid','4');try{IDG.bkCoreApi.start();}catch(e){bk_doJSTag(blueKaiId,blueKaiPort);if(window.console&&window.console.log){window.console.log("Error Occured While Processing Profile Siubmission")}}$('article, #slideshowCarousel').on('click','.product-list-price, .btn-amazon, .productLink',function(e){var $linkEl=$(e.target);var po=$linkEl.data('po');if($.inArray(po,['amazon','vendor','other'])>=0){if(po=='amazon'){var prCat=$linkEl.data('bkc');if(typeof prCat!='undefined'){bk_addPageCtx('event','AmazonClick'+prCat);}bk_addPageCtx('event','AmazonClickMacs');bk_addPageCtx('event','AmazonClickGames');bk_addPageCtx('event','AmazonClickPCs');bk_addPageCtx('event','AmazonClickOSX');bk_addPageCtx('event','AmazonClickHardware');}var prMfr=$linkEl.data('bkmfr');if(typeof prMfr!='undefined'){bk_addPageCtx('event','eCommerceMFR'+prMfr);}var prVndr=$linkEl.data('bkvndr');if(typeof prVndr!='undefined'){bk_addPageCtx('event','eCommerceClickVendor'+prVndr);}bk_doJSTag(34202,1);}});</script>
<!-- End BlueKai Tag -->
<script type="text/javascript">$thm.logPlEvent({"b":"mw","e":"view","t":"article","id":"3199192"});</script>
<script type="text/javascript">$(document).ready(function(){$('a.pinterest-pinit').click(function(e){socialTrack('Article','Pinterest','share');});$('li.redditShare').click(function(e){socialTrack('Article','Reddit','share');});$('a.shoppingExit').click(function(e){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event4";s.prop26='Merchant Exit';s.linkTrackVars="eVar30,prop26,prop54,events";s.tl(true,'o','Merchant Exit Link');});$('a.bingexit').click(function(e){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event6";s.prop35="text ad exit";s.linkTrackVars="eVar35,prop35,events";s.tl(true,'o','Text Ad Exit');});$('a.itclick').click(function(e){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event5";s.prop36="itunes exit";s.linkTrackVars="eVar36,prop36,events";s.tl(true,'o','iTunes Exit');});$('a.signinclick').click(function(e){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event32";s.prop19="Internal Login";s.linkTrackVars="prop19,events";s.tl(true,'o','Login');});$('a.regclick').click(function(e){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event7,event18,prop20,prop22";s.prop20="new registered user";s.prop22="Internal Reg";s.linkTrackVars="events";s.tl(true,'o','Register');});$('.banner-tw').click(function(e){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event37";s.prop49="twitter follow";s.linkTrackVars="prop49,events";s.tl(true,'o','Social Media Follow');});$('.banner-fb').click(function(e){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event37";s.prop49="facebook follow";s.linkTrackVars="prop49,events";s.tl(true,'o','Social Media Follow');});$('a.item-link-container').click(function(e){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event45";s.prop16=$(this).attr("href");s.evar45=s.prop16;s.linkTrackVars="eVar32,prop16,events";s.tl(true,'o','Outbrain Click');});if(typeof(FB)!='undefined'){FB.Event.subscribe('edge.create',function(response){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event36";s.prop48="facebook share";s.linkTrackVars="prop48,events";s.tl(true,'o','Social Media share');});}if(typeof(digMag)!='undefined'){if(typeof(digLogin)!='undefined'){DigAnalytics.logSignIn(digLogin);}}});var Analytics=new Object();Analytics.logArticleComment=function(){s=s_gi(g_sOmnitureReportSuite);s.linkTrackVars="prop25,eVar25,events";s.linkTrackEvents="event19";s.events="event19";s.prop25='Article Comment';s.tl(this,'o','Article Comments');};Analytics.logSocialSignin=function(provider){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event32";s.prop19=provider;s.linkTrackVars="prop19,events";s.tl(true,'o',provider);};Analytics.logInternalSignin=function(){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event32";s.prop19="Internal Login";s.linkTrackVars="prop19,events";s.tl(true,'o','Login');};function sharingTrack(type,pixelLogString){s=s_gi(g_sOmnitureReportSuite);s.eVar16="Sharing on: "+type;s.linkTrackEvents=s.events="event37";s.prop49="social media sharing";s.linkTrackVars="prop49,eVar16,events";s.tl(true,'o','Social Media Sharing');if(typeof IDG.Eloqua!="undefined"){IDG.Eloqua.invoke_flash("social-"+type);}if(pixelLogString!==undefined){$thm.logPlEvent({"b":"mw","e":pixelLogString,"t":"article","id":"3199192"});}}function oClickTrack(key){if(typeof(key)!='undefined'&&key.length>0){s=s_gi(g_sOmnitureReportSuite);s.linkTrackVars="eVar42,events";s.events="event49";s.linkTrackEvents="event49";s.eVar42=key;s.tl(true,'o','module click');}};</script>
<!-- SiteCatalyst code version: H.25.
Copyright 1996-2012 Adobe, Inc. All Rights Reserved
More info available at http://www.omniture.com -->
<script language="JavaScript" type="text/javascript" src="/www.idgcsmb.mw/js/analytics/omniture/pcwmw-macworld/s_code.js"></script>
<script language="JavaScript" type="text/javascript" id="omniVars">g_sOmnitureReportSuite="pcwmw-macworld";s.pageName="Macworld:article:howto:Macs:3199192:Hackintosh: Build a DIY Mac for gaming";s.pageType="";if(typeof omnitureChannel!='undefined'){s.channel=omnitureChannel;}s.prop1="source:macworld";s.eVar1="D=c1";s.prop2="content type:howto";s.eVar2="D=c2";s.prop3="display type:article:howto";s.eVar3="D=c3";s.prop4="0 days";s.eVar4="D=c4";s.prop6="";s.prop7="";s.eVar7="D=c7";s.prop9="category:macs";s.eVar9="D=c9";s.prop11="published:21-Jun-17";s.eVar11="D=c11";s.prop12="aid:3199192";s.eVar12="D=c12";s.prop13="";s.eVar13="D=c13";s.prop14="author:rob griffiths";s.eVar14="D=c14";s.prop15="page number:1";s.eVar15="D=c15";s.prop17="uri:/article/3199192/macs/how-to-build-a-hackintosh-high-performance.html";s.eVar17="D=c17";s.prop18="";s.eVar18="D=c18";s.prop24=getLoginStatusForOmniture();s.eVar24="D=c24";s.prop28=getTrackingToken('tk')?"tokens:"+getTrackingToken('tk'):"";s.eVar28="D=c28";s.prop61="";s.eVar10="D=c61";s.prop37="rpn:mw:howto:macworld:article:howto:macs:3199192:hackintosh: build a diy mac for gaming";s.eVar37="D=c37";s.prop53="3800";s.eVar53="D=c53";s.prop54="macs,games,pcs,macos,hardware";s.eVar30="D=c54";s.eVar33=s.prop55="3800,3084,2101,3675,3020";s.eVar33="D=c55";s.prop39="";s.eVar39="D=c39";s.prop56="diy,mac pro";s.eVar40="D=c56";try{s.prop41=IDG.GPT.getDisplayedAds(',')+','+IDG.GPT.getOtherAds(',');}catch(exception){console.log("Error with IDG.GPT "+exception);}sModules='';for(var i in g_arrModules){if(g_arrModules[i]&&i!=''){sModules+=i+',';}}sModules=sModules.replace(/,$/,'');s.prop42=sModules;s.eVar42="D=c42";s.list3=s.prop42+","+s.eVar42;s.events="";for(var p in s){if(s[p]&&p.match(/^(prop|ceVar)\d+$/)){s[p]=s[p].toLowerCase();}}s.campaign=s.getQueryParam('cid');s.useForcedLinkTracking=false;var s_code=s.t();if(s_code)document.write(s_code)</script>
<script language="JavaScript" type="text/javascript">if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')</script><noscript><img src="http://pcworldcommunication.d2.sc.omtrdc.net/b/ss/pcwmw-macworld/1/H.25--NS/0" height="1" width="1" border="0" alt=""/></noscript><!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: H.25. -->
<!-- START Parse.ly Include: Standard -->
<div id="parsely-root" style="display: none">
<span id="parsely-cfg" data-parsely-site="macworld.com"></span>
</div>
<script>(function(s,p,d){var h=d.location.protocol,i=p+"-"+s,e=d.getElementById(i),r=d.getElementById(p+"-root"),u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net":"static."+p+".com";if(e)return;e=d.createElement(s);e.id=i;e.async=true;e.src=h+"//"+u+"/p.js";r.appendChild(e);})("script","parsely",document);</script>
<!-- END Parse.ly Include: Standard -->
<div id="loginModal"></div>
<div id="logoffModal"></div>
<div id="abuseModal"></div>
<!-- rev: 20170619121402  -->
<div id="gpt-skin" class=" ad-container"></div>
<script type="text/javascript">try{IDG.GPT.addDisplayedAd("gpt-skin","true");IDG.GPT.displayGoogleTagSlot('gpt-skin');}catch(exception){console.log("Error with IDG.GPT: "+exception);}</script>
</body>
</html>
