Fix iWeb photo pages in Firefox 3

Reader Walter Orlandini finds that iWeb and Firefox 3 don’t see eye-to-eye in regard to photo pages. He writes:

I am having problems with Firefox 3 not rendering photos I put into iWeb “Photo” and “My Album” pages. I set up a web site to share family photos, but everytime I try to publish a “Photo” or “My Album” page, no photos are loaded in the published web page by Firefox. Photos placed on “Welcome,” “Blog,” or “blank” pages load just fine. Any idea what’s going on?

According to those who know these sorts of things, this came about because of a Javascript library called Prototype—used by iWeb along with some other sites—that was extended in ways that conflict with the implementation used by Firefox 3. The result in iWeb is what you see—or, rather, don’t see. And that would be the missing images on your Photo pages.

Fortunately, there’s a fix. Daniel Furrer submitted some patches for the issue to Firefox’s Bugzilla entry and Daryl Grunau offered a Comments patch in his blog. A helpful fellow named Josh took this work and wrapped it in an AppleScript, which you can download from MacUpdate. If you’d like more details on the issue’s background, check out Josh’ blog.

The basics are this: Run the Fix iWeb and Firefox 3.1.3 AppleScript to patch iWeb. Then republish the problem pages (you’ll need to make a small change to them for the Publish button to activate). Launch Firefox and clear its cache (do this in the Network tab of the Advanced preference) and then visit your pages. If it doesn’t appear to work, return to your page in iWeb and try deleting any shadows from objects on the page.

Related:
  
Shop Tech Products at Amazon