










<!DOCTYPE html>


	
	
		
	
		
	
	
	
	

<html lang="en">
	












<head>
	
	<meta charset="utf-8" />
	<title>Macworld's August Digital Magazine: First look at iOS 12 and macOS Mojave | Macworld</title>
	<meta name="viewport" content="width=device-width, initial-scale=1.0" />
	
	
	<script>
	function getQueryVariable(variable) {
		var query = window.location.search.substring(1);
		var vars = query.split("&");
		for (var i=0;i<vars.length;i++) {
			var pair = vars[i].split("=");
			if(pair[0] == variable){return pair[1];}
		}
		return(false);
	}
	</script>
	
	<!-- ad-related js -->
	
	<script src="/www/js/jquery/jquery-1.10.2.min.js"></script>
	
	<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
	
	
	












<script>
!function(t,o,e){e=t.createElement(o),t=t.getElementsByTagName(o)[0],e.async=1,e.src="https://spiffymachine.com/v2/0/soz43Z90Ya301tyXyaiysf_JwIN8WL9UxveYtEOn-A78Mt4sBMUH2bEz8dxDyNRTgqcdA",t.parentNode.insertBefore(e,t)}(document,"script"),function(t,o){t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)}}(document,window,"script","admiral");!function(t,e,a,n){function o(t){try{return t=localStorage.getItem("v4ac1eiZr0"),t&&t.split(",")[4]>0}catch(e){}return!1}function r(){var n=o();if(n){var r=t[e].pubads();typeof r.setTargeting===a&&r.setTargeting("admiral-engaged","true")}}n=t[e]=t[e]||{},n.cmd=n.cmd||[],typeof n.pubads===a?r():typeof n.cmd.unshift===a?n.cmd.unshift(r):n.cmd.push(r)}(window,"googletag","function");;;;!function(t,e,a,n){function o(){if(!window.frames[n]){var e=t.body;if(e){var a=t.createElement("iframe");a.style="display:none",a.name=n,e.appendChild(a)}else setTimeout(o,5)}}function r(){for(var t=[],a=0;a<arguments.length;a++)t.push(arguments[a]);i.q=i.q||[],"ping"===t[0]?t[2]({gdprAppliesGlobally:e.__cmpGdprAppliesGlobally||!1,cmpLoaded:!1},!0):t.length&&i.q.push(t)}function c(t){try{return JSON.parse(t)}catch(e){}}function s(t){if(t){var e,a="__cmpCall",n="string"==typeof t.data&&t.data.indexOf(a)>=0;e=n?(c(t.data)||{})[a]:(t.data||{})[a],e&&i(e.command,e.parameter,function(a,o){var r={__cmpReturn:{returnValue:a,success:o,callId:e.callId}};t.source.postMessage(n?JSON.stringify(r):r,"*")})}}var i=e[a];o(),"function"!=typeof i&&(i=e[a]=r,e.addEventListener?e.addEventListener("message",s,!1):e.attachEvent&&e.attachEvent("onmessage",s))}(document,window,"__cmp","__cmpLocator");;
</script>

<script>
window.admiral = window.admiral || function() {(admiral.q = admiral.q || []).push(arguments)};
/*
var checkIfInEU = new Promise((resolve, reject) => {
    var promiseResolved = false;
    setTimeout(function(){
        console.log('GDPR checkIfInEU timeout reached promiseResolved',promiseResolved);
        if (!promiseResolved){
            promiseResolved=true;
            resolve();//in eu
            console.log('too slow; assuming you are EU');
        }
    },10000);

    window.admiral('after', 'cmp.loaded', function(e){
        if(promiseResolved)return;//timeout reached            
        promiseResolved = true;
        
        console.log('GDPR checkIfInEU - cmp.loaded',e);
        var isEuVisitor = e.euVisitor || false;             
        if (isEuVisitor)resolve();
        else reject();    
    });
});
*/

var consent = consent || {};
consent.isEU = consent.isEU || null;
consent.personalization = consent.personalization || null;
consent.ads = consent.ads || {};
consent.ads.queue = consent.ads.queue || [];

window.admiral('addEventListener', 'cmp.loaded', function(e){
	console.log('*****GDPR: EU user?', e);
	consent.isEU = e.euVisitor;
	if (!consent.isEU) {
		console.log('*****GDPR: not EU, run that queue!');
		consent.personalization=true;
		$(window).trigger("runConsent", [consent.ads.queue]);
	}	
	else if (e.consentKnown == true) {
		window.admiral('get', 'cmp.consent', function(e) {
			console.log('*****GDPR: we know your personalization setting (' + e.publisherPurposes['2'] + '), running queue.');
			consent.personalization = e.publisherPurposes['2'];
			$(window).trigger("runConsent", [consent.ads.queue]);
			bindReshowCmp();
		});
	}
	else {
		try {
	    	__cmp('getPublisherConsents',[],function(publisherConsents,success){
	    		if (typeof publisherConsents.standardPurposes['2'] !== 'undefined' && publisherConsents.standardPurposes['2']) {
	    			console.log('*****GDPR: personalization allowed, start running personalized ads');	
	    		}
	    		else if (typeof publisherConsents.standardPurposes['2'] !== 'undefined' && !publisherConsents.standardPurposes['2']) {
	    			console.log('*****GDPR: personalization not allowed, start running non-personalized ads');
	    		}
	    		consent.personalization = publisherConsents.standardPurposes['2'];
	    		$(window).trigger("runConsent", [consent.ads.queue]);
			});
	    		bindReshowCmp();
	    }
	    catch (e) {
	    	console.log(e);
	    }
	}
});

window.admiral('addEventListener', 'cmp.updated', function(e){
	__cmp('getPublisherConsents',[],function(publisherConsents,success){	
		console.log('*****GDPR: Consent updated (cmp.updated fired). personalization ok? ',typeof publisherConsents.standardPurposes['2'] !== 'undefined' && publisherConsents.standardPurposes['2'])
	});	
	$(window).trigger("runConsent", [consent.ads.queue]);
	
});

$(window).on("runConsent", function(event, queueToRun) {
		watchConsentQueue(queueToRun)
});

function runQueue(queue){
	for (var x=0;x<queue.length;x++) {
		var nextFn = queue.shift();
		nextFn();
		console.log('*****GDPR: running queue');
	}	
}

function watchConsentQueue(queue){
	setInterval(function() { runQueue(queue); },100);
}
function bindReshowCmp() {
	var url = document.location.pathname;
	if (url.indexOf("/about/member-preferences") > -1) {
		$(".cmpSettings").show();
		$(".reshowLink").on("click", function(e) {
			e.preventDefault();
			window.admiral('show','cmp.settings');
		});
	}
}
</script>




	
    <script src="/www/js/init_device.js"></script>    
    
    
    
		














<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20180712120429"></script>

<script type="text/javascript">
	if (adLayer==null || adLayer=='undefined') {
		var adLayer=[];
	}
	
		
			adLayer["itemType"]="article";
		
		
	
</script>
	
<script type="text/javascript">
	// Set up ad related variables
	try {
		IDG.GPT.unitName = "/8456/IDG.US_CSMB_Macworld.com";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}

	try {
		IDG.GPT.unitName = IDG.GPT.unitName + "/" + "ios_section";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	// global variables
	var global_ShowSuper = true;
	var global_ShowHero = false;
	
	//XFP global targeting, more targeting thm_pre
	var url = window.location.href;
	if(url.indexOf("?")>1){
		url=url.split('?')[0];
	}
	

	try {
		IDG.GPT.addTarget("URL", encodeURIComponent(url));
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	try {IDG.GPT.addTarget("zone", 'article/ios');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("channel", 'mobile,macs');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("articleId", '3290359');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("type", 'news');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("typeId", '2');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("manufacturer", 'hp');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("templateType", 'article-default');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	
	try {IDG.GPT.addTarget("categoryIds", [3144,3800,3028,3706,3183]);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("categorySlugs", ['ios','macs','iphone-ipad','macbook','apple-phone']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {IDG.GPT.addTarget("goldenIds", [230,740,931,741,746]);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {
		if (null != IDG.GPT.getQsVal("env")) {		
			IDG.GPT.addTarget("env", IDG.GPT.getQsVal("env").replace(/\W/g, "") );
		}
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	
	
		try {
			IDG.GPT.addTarget("author", 'Macworld Staff');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
		

	try {
		IDG.GPT.addTarget("page_type", '');
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	

	
	
	
	
		try {
			IDG.GPT.addTarget("insiderContent", 'false');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
	
	
	try {
		IDG.GPT.welcomeFreqCap = true;
	}
	catch (exception) {
        console.log("Welcome Ad Frequency Cap: google_dfp can't use IDG.GPT " + exception);
	}
	
</script>



<script type="text/javascript">
	
	
	
	
		
		
		
		
		
		
		
		
	
</script>
  
<script src="/www.idgcsmb/js/thm_pre.js?v=20180712120429"></script>















	
		
	
	
	



	
		<script type="text/javascript">
			//console.log("PROXIMIC RESPONSE: PAGE-LEVEL");
			(function () {
			    try {
                    var proximic_data = {"data":["300003","121100","131100","131123","131124","131129","240000","240002","240003","240004","240001","240005","240006","240007","240008","240009","240011","240012","240013","240014","240017","240015","240016","20f4sh","bkwp85","enwcef","bsuu95","cc8l98","kfzmve","x8eev1","bhcwri","9v0tiu","s9o5po","qh9ovz","6bjlg5","e2co9k","r03wnl","folvaf","vbhuy4","pytywb","44ywyv","9vsomj","xks7sj","ejqk9n","fxbc1d","njkqk2","agtqg7","7grvv1","ge44pq","agt9m3","240saz","pcz604","itgwkk","le330e","500247"]};
                    IDG.GPT.addTarget("proximic", proximic_data.data);
                }
                catch (e){
			        console.log("Error: " + e);
                }
			})();
		</script>
	
	



	
	



	<script>
		var isMobile = (typeof IDG.DEVICE !== 'undefined') ? IDG.DEVICE.isMobile() : false;
		
		
		
		
		
		
		


		
		try {
			// !!!Needed to disable this functionality to fix IDGMPM-15950!!!
			//IDG.GPT.disableInitialLoad = true;
			IDG.GPT.addBiddingParams("yieldbotPsn", (isMobile ? "b274" : "5016"));
			IDG.GPT.addBiddingParams("appnexusPlacementId", (isMobile ? "6451145" : "6352551"));
			
			
				IDG.GPT.addBiddingParams("TriLiftPrefix", "macworld_ros_");
			
		}
		catch(e) {
			console.log("Error in adding bidding params: "+e);
		}
	</script>
	<script src="/www/js/ads/narf_prebid.js?v=20180712120429"></script>	


<script type="text/javascript" src="/www/js/ads/gpt_starter.js?1234"></script>

<script type="text/javascript" src="/www/js/ads/gpt_launcher.js"></script>

	

	

    <link rel="canonical" href="https://www.macworld.com/article/3290359/ios/macworlds-august-digital-magazine-first-look-at-ios-12-and-macos-mojave.html" />
	
	
	
	
	
	<meta name="description" content="Macworld&#039;s latest digital magazine." />
	
	<meta itemprop="image" content="https://images.idgesg.net/images/article/2018/07/mwdigitaledition_primary-aug18-100764619-medium.jpg">
	
	
		
			<meta name="DC.date.issued" content="2018-07-17" />
			<meta name="date" content="2018-07-17" />
			
		
		
		 
	
	
	<link rel="amphtml" href="https://www.macworld.com/article/3290359/ios/macworlds-august-digital-magazine-first-look-at-ios-12-and-macos-mojave.amp.html" />

	
		<script type="text/javascript" src="//fonts.staticworld.net/lzq5miu.js"></script>
		<script type="text/javascript">try{Typekit.load();}catch(e){}</script>
	
	
	<meta property="twitter:account_id" content="611823" />
	<meta property="fb:app_id" content="865450560227169" />
	
		
		
		
			
			
				
			
			
			
		
		
	<meta property="og:type" content="article">	
	<meta property="og:url" content="https://www.macworld.com/article/3290359/ios/macworlds-august-digital-magazine-first-look-at-ios-12-and-macos-mojave.html">
    <meta property="og:site_name" content="Macworld">   
    
    
    	<meta property="og:image" content="https://images.idgesg.net/images/article/2018/07/mwdigitaledition_primary-aug18-100764619-large.3x2.jpg">
    	<meta property="og:image:width" content="700">
    	<meta property="og:image:height" content="467">
    
    
    
    
    
    
    	<meta property="og:title" content="Macworld's August Digital Magazine: First look at iOS 12 and macOS Mojave"> 
    
    
    <meta property="og:description" content="Macworld&#039;s latest digital magazine.">
    
    
    
    













	<!-- Sailthru -->
	
		<meta name="sailthru.tags" content="ios,macs,iphone-ipad,macbook,apple-phone,macworld-staff,news,medium"/>
	
		<meta name="sailthru.image.thumb" content="https://images.idgesg.net/images/article/2018/07/mwdigitaledition_primary-aug18-100764619-small.jpg"/>
	
		<meta name="sailthru.image.full" content="https://images.idgesg.net/images/article/2018/07/mwdigitaledition_primary-aug18-100764619-large.3x2.jpg"/>
	

    
    	<meta name="sailthru.title" content="Macworld&#039;s August Digital Magazine: First look at iOS 12 and macOS Mojave" />
    
    
    	<meta name="sailthru.description" content="Macworld&#039;s latest digital magazine." />
    

	
	<meta name="displaytype" content="article" />
	
	<meta name="source" content="macworld" />
	
	<meta name="category" content="ios,macs,mobile,macbooks,iphone" />
	
	<meta name="storytype" content="news" />
	
	
	
		<meta name="google-site-verification" content="1NJELq6F-S44I5ACepf9_rYYEBLuwwVjJUv5PrT91SA" />
	
	
	
		<meta name="msvalidate.01" content="05F49F041AAA61528A0A3329A6C0C02D" />
	
	
	
	
	
		<link id="mobile-size" rel="stylesheet" href="/www.idgcsmb/css/inline-header-mobile.css?v=20180712120429" />
		<script>
			if (window.matchMedia("(min-width: 768px)").matches) {
				document.getElementById('mobile-size').insertAdjacentHTML('afterend', '<link id="desktop-size" rel="stylesheet" href="/www.idgcsmb/css/inline-header.css?v=20180712120429" />');
			}
		</script>
		<link rel="stylesheet" href="/www.idgcsmb.mw/css/inline-header.css?v=20180712120429" />
	 
	
	
	    
	
	<link rel="stylesheet" href="/www.idgcsmb/css/print.css" media="print" />
	
	<!-- this must be first -->
	<link href="/www.idgcsmb/css/colorbox.css" rel="stylesheet" />
	<!-- <link href="/www.idgcsmb/css/equalizer.css" rel="stylesheet" /> -->
	<link href="/www.idgcsmb/css/global-layout.css?v=20180712120429" rel="stylesheet" />
	<link href="/www.idgcsmb.mw/css/global-layout.css?v=20180712120429" rel="stylesheet" />
	<link href="/www.idgcsmb/css/global-colors.css?v=20180712120429" rel="stylesheet" />
	<link href="/www.idgcsmb.mw/css/global-colors.css?v=20180712120429" rel="stylesheet" />
	<link href="/www.idgcsmb/css/global-typography.css?v=20180712120429" rel="stylesheet" />
	<link href="/www.idgcsmb.mw/css/global-typography.css?v=20180712120429" rel="stylesheet" />
	
	
	
	
		
		
			
			
			
				<link rel="stylesheet" href="/www/css/article.css?v=20180712120429" />	
			
			
		<link href="/www.idgcsmb.mw/css/article.css?v=20180712120429" rel="stylesheet" />
	
	
	<link href="/www.idgcsmb/css/video.player.css?v=20180712120429" rel="stylesheet" media="all" />
	
	
	
	
	
	
	
	
	
	
	
	  
	<!-- this must be last -->
	<link href="/www.idgcsmb/css/helpers.css" rel="stylesheet" />
	
	
	<!--  fav and touch icons -->
	<link rel="shortcut icon" href="/www.idgcsmb.mw/favicon.ico"/>
	<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://csmb.staticworld.net/images/furniture/macworld/mw-apple-touch-icon-precomposed-144.png" />
	<link rel="apple-touch-icon-precomposed" sizes="129x129" href="https://csmb.staticworld.net/images/furniture/macworld/mw-apple-touch-icon-precomposed-129.png" />
	<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://csmb.staticworld.net/images/furniture/macworld/mw-apple-touch-icon-precomposed-114.png" />
	<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://csmb.staticworld.net/images/furniture/macworld/mw-apple-touch-icon-precomposed-72.png" />
	<link rel="apple-touch-icon" href="https://csmb.staticworld.net/images/furniture/macworld/mw-apple-touch-icon-precomposed.png" />
	
	

	
		
	
	
	
	
	<script type="text/javascript">
	var _sf_async_config={};
	_sf_async_config.uid = 29363;
	
	
	
		_sf_async_config.useCanonical = true;
	
	
	
		
						
	_sf_async_config.authors="Macworld Staff";
			
		
			
			
	_sf_async_config.sections="ios";	
		
		
		
		
	_sf_async_config.domain = "macworld.com";
	</script>
	
	
	
	
	
	<!-- <link href="/www.idgcsmb/webfonts/ss-social.css" rel="stylesheet" />
	<link href="/www.idgcsmb/webfonts/ss-standard.css" rel="stylesheet" />  -->
	<!--[if lte IE 8]>  
		<link href="/www.idgcsmb/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]-->


	
	<!-- Use Twitter Summary Card with Large Image for articles and videos; summary otherwise -->
	
		
				<meta name="twitter:card" content="summary_large_image">
		
		
	
	<meta property="twitter:description" content="Macworld&#039;s latest digital magazine.">
	
	
		
			<meta name="twitter:site" content="@macworld">
			
			
				
					<meta name="twitter:image" content="https://images.idgesg.net/images/article/2018/07/mwdigitaledition_primary-aug18-100764619-orig.jpg" />
				
				
						
			
				
				
					<meta name="twitter:title" content="Macworld&#039;s August Digital Magazine: First look at iOS 12 and macOS Mojave">
				
				
			
			
				
				
					<meta name="twitter:url" content="www.macworld.com">
				
			
		
		
		
		
		
	
	
	
	
	












<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "WebSite",
		"url": "https://www.macworld.com/ ",
		"potentialAction": {
		"@type": "SearchAction",
		"target": "https://www.macworld.com/search?query={search_term}",
		"query-input": "required name=search_term"
		}
	}
</script>
	
	
	<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
	
	
	<script src="/www/js/ads/ads.js"></script>
	
	<script>var oneRegPlacementID = "";</script>
	
	
	
	
	
		
			
				
			
			
			
			
			
		
		
		
	
	
	
		
		
		
		
		  
		
	
	
	
	
	
	  	 
	    
	    
	 
	 
	
	
	
	
	
	
	
	
	
	




	
		
	
		
	
	



	
	
	
	
	
		
			
				
				
				
					
				
			
			
			
			
		
		
		
	
	
	
	
	
	
	
	<script>
	var sincePublished = '0 days';
	sincePublished = sincePublished.split(" ")[0];
	var idg_uuid = $.cookie('idg_uuid') || "";
	
	dataLayer=[{
		'articleId': '3290359',
		'articleDisplayId':'1',
		'articleTitle': 'Macworld\'s August Digital Magazine: First look at iOS 12 and macOS Mojave',
		'articleType': 'News',
		'audience':'consumer',
		'author':'Macworld Staff',
		'blogName':'',
		'brandpost': '',
		'categoryIdList':'3144,3800,3028,3706,3183',
		'categoryIdPrimary': '3144',
		'contentStrategy': '',
		'contentType':'news',
		'datePublished':'2018-07-17',
		'dateUpdated':'',
		'daysSincePublished':sincePublished,
		'daysSinceUpdated':'',
		'displayType':'article',
		'environment':'production',
		'ga_enabled':'true',
		'gaTrackingId':'UA-870741-1',
		'geolocEnabled':'true',
		'goldenTaxonomyIdPrimary': '230',
		'goldenTaxonomyIdList': '230,740,931,741,746',
		'isBlog':'false',
		'isInsiderContent':'',
		'isICN': 'false',
		'oneRegPlacementID':oneRegPlacementID,
		'pageNumber':'1',
		'platform':'Web',
		'podcastSponsored': 'false',
		'primaryCategory': 'ios',
		'primaryCategoryList': 'ios,macs,mobile,macbooks,iphones',
		'property': 'macworld',
		'propertyCountry':'US',
		'purchaseIntent':'',
		'sailthruCustomerId':'9de878b098a17dda2203b4d71c6eeac1',
		'skimlinksId':'111346X1569486',
		'source':'macworld',
		'sponsorName':'',
		'tags': '',
		'userId':idg_uuid,
		'videoAutoplay':'false',
		'articleHasVideo':'false'	
	}];
	</script>
	 
	
	
	
	
	










<script>
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var adBlockStatus = 'false';
	
	function AdBlockEnabled() {
		var ad = document.createElement('ins');
		ad.className = 'AdSense';
		ad.style.display = 'block';
		ad.style.position = 'absolute';
		ad.style.top = '-1px';
		ad.style.height = '1px';

		if (document.body != null) {
			document.body.appendChild(ad);
			var isAdBlockEnabled = !ad.clientHeight;
			document.body.removeChild(ad);
		}

		return isAdBlockEnabled; 
	}
	// AdBlockEnabled() was successful document.body not null
	if (AdBlockEnabled() != undefined) {
		adBlockStatus = AdBlockEnabled().toString();
	}
	// not successful - look for ads.js
	if (document.body == null) {
		if (window.canRunAds === undefined) {
			adBlockStatus = 'true';
		} else {
			adBlockStatus = 'false';
		}
	}
	
	dataLayer.push({
		'adBlockStatus': adBlockStatus
	});
</script>




	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-WHLJC4"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-WHLJC4');</script>
	<!-- End Google Tag Manager -->

	
	
	
	
	
	<script src="https://www.google.com/recaptcha/api.js" async defer></script>
	
	
	
		<script async src="//js-sec.indexww.com/ht/p/187051-274202188545692.js"></script>
	
	
	
	
	
</head>

	<body id="article3290359" class="article macworld">
		 
		
			<div id="skinAdTarget"></div>
		

		
			<div id="superadunit" class="hidden">
			    <div class="ad">
			    	<div class="ad-header">
						<div class="brand-logo"></div>
						<a href="javascript:unhide('superadunit');" id="superstitial-text">Close Ad</a>
					</div>
					
						
						
						
					




















	
		
		
		
		
			
		  		<script type="text/javascript">
		  		
		  		
				document.write('<div id="gpt-superstitial" class=" ad-container"></div>');
				consent.ads.queue.push(function(){
			  		try {			  			
			   			IDG.GPT.addDisplayedAd("gpt-superstitial", "true");
			   			$('#gpt-superstitial').responsiveAd({screenSize:'971 1115', scriptTags: []});
			   			IDG.GPT.log("Creating ad: gpt-superstitial [971 1115]");
			   		}
					catch (exception) {
						console.log("Error with IDG.GPT: " + exception);
					}
		  		});
				
				</script>
		
		
	
 
 
	
			    </div><!-- / ad -->
			</div><!-- / super -->		
		

		















	

		
			
		











	
	
	
	
	
	
	
	
	
	
	
	
	
	













<div id="page-top">
		<div class="page-top-inner" itemscope itemtype="http://schema.org/Organization">
		<link itemprop="url" href="http://www.macworld.com"> 
	    




<div class="network-header">
		<div class="network-header-inner">
			<div id="network-tools">

				<div id="saved-comparisons"></div>				
				<ul class="hmenu" id="heroLogin">				
					
					<li class="subscribeHeader"><a href="https://ssl.palmcoastd.com/31401/apps/MCWDIGITAL?ikey=I**A02">Subscribe</a><div class="subscribe-hover" style="">
                        <div class="pointer">&#9650;</div>
                        <span>Learn more about Macworld's Digital Edition</span>
                        <img alt="Macworld Magazine Cover" src="//alt.idgesg.net/images/furniture/macworld/footer-subscribe-mag-mw.png">
                      </div></li>
				</ul>
			</div><!-- /#network-tools -->

				<div id="network-social">					
                  
					
					<a href="http://www.facebook.com/Macworld" class="network-fb ss-icon ss-social-circle banner-social banner-fb" alt="Facebook" itemprop="sameAs" rel="nofollow">
						&#xF610;
					</a>
					<a href="https://twitter.com/macworld" class="network-tw ss-icon ss-social-circle banner-social banner-tw" alt="Twitter" itemprop="sameAs" rel="nofollow">
						&#xF611;
					</a>
					<a href="https://plus.google.com/+macworld/posts" class="network-google ss-icon ss-social-circle banner-social banner-google" alt="Google+" itemprop="sameAs" rel="publisher">
						&#xF613;
					</a>
					<a href="https://www.youtube.com/user/macworld" class="network-youtube ss-icon ss-social-circle banner-social banner-youtube" alt="YouTube">
						&#xF630;
					</a>

				<form id="search-form" action="/search">
					<input type="search" name="query" id="banner-search-term" class="inactive searchbox-input-class" value="">
					<input type="submit" name="submit" id="banner-search-submit" value="search" />
					<a id="magGlassClick" class="ss-icon ss-standard" type="submit">&#x1F50E;</a>
				</form>

				</div><!-- /#network-social -->
			
				
		</div>
	</div><!-- /.network-header -->


	<header id="banner">
		<a id="mobile-offscreen-toggle" class="ss-standard ss-rows" href="javascript://"></a>
		<div id="logo">
			<a href="/" class="ir banner-logo" id="logoImage">Home</a>		
		</div>
		<div id="mobile-search-toggle" class="ss-standard ss-search"></div>
	</header>


	



















<div id="main-nav">
	<div class="container clearfix">
		<ul class="fmenu" id="panel-nav">
			<li class="newsNav"><a href="/news/" id="whatsHotNav">News</a></li>
			<li class="reviewsNav"><a href="/reviews/" id="reviewsNav">Reviews</a></li>
			<li class="howtoNav"><a href="/howto/" id="howtoNav">How-To</a></li>
			<li class="videoNav"><a href="/video/" id="videoNav">Video</a></li>
		</ul>

		<ul class="fmenu" id="site-nav">
			
				<li><a href="/category/macs/">Macs</a>
					
				</li>
			
				<li class="selected"><a href="/category/iphone-ipad/" class="active">iPhone/iPad</a>
				
					<ul>
						
								
									
									
										<li><a href="/category/apple-phone/">iPhone</a></li>
									
													
						
								
									
									
										<li><a href="/category/ipad/">iPad</a></li>
									
													
						
								
									
									
										<li class="sub-selected"><a href="/category/ios/">iOS</a></li>
									
													
						
					</ul>
					
				</li>
			
				<li><a href="/category/os-x/">macOS</a>
					
				</li>
			
				<li><a href="/category/ios-apps/">iOS</a>
					
				</li>
			
				<li><a href="/category/mac-apps/">Apps</a>
					
				</li>
			
				<li><a href="/category/computers-accessories/">Accessories</a>
					
				</li>
			
				<li><a href="/category/enterprise/">Enterprise</a>
					
				</li>
			
				<li><a href="/category/entertainment/">Entertainment</a>
					
				</li>
			
			
					
					<li class="displayMobileOnly"><a href="/subscribe/">Subscribe</a></li>
		</ul>
		
			<div id="extra-nav-toggle"><a href="#extra-nav" class="ss-dropdown"></a></div>
			
			<div id="extra-nav">
				<ul>
					
						<li><a href="/resources/">Resources</a></li>
					
						<li><a href="/category/macs/">Macs</a></li>
					
						<li><a href="/category/macbook/">MacBooks</a></li>
					
						<li><a href="/category/mac-desktop/">iMacs</a></li>
					
						<li><a href="/category/apple-phone/">iPhones</a></li>
					
					<li><a href="/blogs">Blogs</a></li>
				</ul>
				<ul>
					
						<li><a href="/category/ipad/">iPads</a></li>
					
						<li><a href="/category/computers-accessories/">Accessories</a></li>
					
						<li><a href="/category/mac-apps/">Apps</a></li>
					
						<li><a href="/category/software-music/">Audio</a></li>
					
						<li><a href="/category/enterprise/">Enterprise</a></li>
					
						<li><a href="/category/cameras/">Cameras</a></li>
					
						<li><a href="/category/components/">Components</a></li>
					
						<li><a href="/category/software-development/">Development Software</a></li>
					
				</ul>
				<ul>
					
						<li><a href="/category/displays/">Displays</a></li>
					
						<li><a href="/category/e-readers/">E-readers</a></li>
					
						<li><a href="/category/home-theater/">Home Theater</a></li>
					
						<li><a href="/category/ios-apps/">iOS</a></li>
					
						<li><a href="/category/phone-accessories/">iPhone Accessories</a></li>
					
						<li><a href="/category/ipad-accessories/">iPad Accessories</a></li>
					
						<li><a href="/category/ipods/">iPods</a></li>
					
						<li><a href="/category/os-x/">macOS</a></li>
					
				</ul>
				<ul>
					
						<li><a href="/category/printers/">Printers</a></li>
					
						<li><a href="/category/networking/">Networking</a></li>
					
						<li><a href="/category/software-productivity/">Productivity Software</a></li>
					
						<li><a href="/category/smartwatches/">Smartwatches</a></li>
					
						<li><a href="/category/storage/">Storage</a></li>
					
						<li><a href="/category/input-stylus/">Styluses</a></li>
					
				</ul>
			</div>
		
	</div>
</div>	<!--/#main-nav-->


<div id="section-nav">
		<div class="container clearfix">
			<ul class="fmenu">
				
					<li >
						
							
							
								<a href="/category/apple-phone/">iPhone</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/ipad/">iPad</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/ios/" class="active">iOS</a>
							
						
					</li>

				
			</ul>
		</div>
</div><!--/#section-nav-->










		</div> 
	</div> 




			<!-- Events Header -->
		
			
				
				 
					
						
						
						
						
						
									    			
						
					
					
					
					
					
				
				 
				 
				 
				 
				  
				  
				 
				 
			











	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<!-- blx4 #2737 blox4.banners  -->
			

		
			
				
					
					
					
						
							
					
						
					
					
					
					
					
				
				
			
		















 
	
		
		
			<link rel="stylesheet" type="text/css" href="/www.idgcsmb/css/banner.css">
			
				<style type="text/css">
					.promoBannerFrame { 
						background-color: transparent;
					}
				</style>
			
		
	
	<div class="promoBannerFrame">	
		<div class="innerPromoBanner" >		
			<a class="promoBannerImage" href="/category/amazon-prime-day/"><img  class="originalImage  imgId100764181 " src="https://images.idgesg.net/images/article/2018/07/prime-day-18-banner-mw-100764181-orig.jpg" /></a>
		</div>
	</div>

	


		


<script>
$(document).ready(function(){
	$('.searchbox-input-class').each(function(){
	    $(this).change(function(){
	    	var qStr=$(this).val();
	    	if($(this).val().indexOf('@')!=-1){
	    		qStr=qStr.replace(/@/g,' ');
	    		$(this).val(qStr);
	    	}
	    });
	});
});
</script>


		
		
		
		
		
		











<div id="page-wrapper" class="page-wrapper">
	
	










	
	<section role="main">

		<article itemscope itemtype="http://schema.org/NewsArticle"  >

		











	
	
























	
			















<header  class='cat'>

	
	
	
	
	
	
	
	
	
		<!-- CSMB Horizontal Responsive -->
<ins class="adsbygoogle"
     style="display:block;"
     data-ad-client="ca-pub-4268075595326305"
     data-ad-slot="9945794902"
     data-ad-format="link"></ins>


<script>
consent.ads.queue.push(function(){
	$.getScript( "//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" )
		  .done(function( script, textStatus ) {
		    //need to add  && publisherConsents.gdprApplies back to the end of this conditional after testing
			  if (!consent.personalization && consent.isEU)  {
				   (adsbygoogle=window.adsbygoogle||[]).requestNonPersonalizedAds=1
				   console.log('*****GDPR: loaded adsense in non-personalized mode')
			  }
			  else {
			   		(adsbygoogle = window.adsbygoogle || []).push({});
			   	 	console.log('*****GDPR: loaded adsense in normal mode');
			  } 
		  })
		  .fail(function( jqxhr, settings, exception ) {
		    console.log( "Triggered ajaxError handler." );
		});
});
</script>
	
	
	
	<nav class="breadcrumbs horiz">
		<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
			<li><a href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
			
				
				
				
					<li><a href="/category/ios/" itemprop="url"><span itemprop="title">iOS</span></a></li>
				
			
		</ul>
	</nav>
	
	
	
	
	
	
	
		
		
			<div class="category"><a href="/news" itemprop="genre">News</a></div>
		
	
	

	<h1 itemprop="headline">Macworld's August Digital Magazine: First look at iOS 12 and macOS Mojave</h1>
	
	
	
	
	
	
	
		<div class="cat-social">
			
				
			


















	

				

	
	
		
	



	
	


	


<div id="sharer" class="cat sidecar show">
<ul id="share-tool" class="expand">



	<li class="sosh">
		<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.macworld.com%2Farticle%2F3290359%2Fios%2Fmacworlds-august-digital-magazine-first-look-at-ios-12-and-macos-mojave.html" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/facebook.svg" />
		</a>
	</li>
	<li class="sosh">
		<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.macworld.com%2Farticle%2F3290359%2Fios%2Fmacworlds-august-digital-magazine-first-look-at-ios-12-and-macos-mojave.html&via=macworld&text=Macworld%27s+August+Digital+Magazine%3A+First+look+at+iOS+12+and+macOS+Mojave" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/twitter.svg" />
		</a>	
	</li>
	<li class="sosh">
		<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.macworld.com%2Farticle%2F3290359%2Fios%2Fmacworlds-august-digital-magazine-first-look-at-ios-12-and-macos-mojave.html" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/gplus.svg" />
		</a>	
	</li>
	<li class="sosh">
		<a class="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?url=https%3A%2F%2Fwww.macworld.com%2Farticle%2F3290359%2Fios%2Fmacworlds-august-digital-magazine-first-look-at-ios-12-and-macos-mojave.html&description=Macworld%27s+August+Digital+Magazine%3A+First+look+at+iOS+12+and+macOS+Mojave" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/pinterest.svg" />
		</a>
	</li>
	<li class="sosh">
		<a href="http://reddit.com/submit?url=https%3A%2F%2Fwww.macworld.com%2Farticle%2F3290359%2Fios%2Fmacworlds-august-digital-magazine-first-look-at-ios-12-and-macos-mojave.html&title=Macworld%27s+August+Digital+Magazine%3A+First+look+at+iOS+12+and+macOS+Mojave" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/reddit.svg" />
		</a>
	</li>
	<li class="sosh cat">
		<a href="#email" id="email-icon">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/mail.svg" />
		</a>
	</li>
	<li class="sosh hide cat print">
		<a href="javascript:window.print();">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/print.svg" />
		</a>
	</li>



</ul>
</div>
<script type="text/javascript">
var isValidEmailAddress = isValidEmailAddress || function(emailAddress) {
    var pattern = new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);
    return pattern.test(emailAddress);
};
function encodeQueryData(params) {
	var ret = [];
	for (var paramKey in params) {
		ret.push(encodeURIComponent(paramKey) + "=" + encodeURIComponent(params[paramKey]));
	}
	return ret.join("&");
}	
function bindEmailModal() {
	$('#emailModal').on("click",".close-btn",function(event) {
		event.preventDefault();
        $('#emailModal').hide();
        $("#emailModal .eml-friend").show();
        $(".eml-friend-success").hide();
        $(".eml-friend-error").hide();
		$('#emailModal').fadeOut(200);
		$('#email-to').val('');
		$('#email-from').val('');
		$('#name').val('');
		$('#personalization').val('');
		$('#eml-from-address-message').html("");
		$('#eml-to-address-message').html("");
		$('#eml-friend-captcha-message').html("");
	});

	$('#emailModal').on("submit","form",function(event) {
		event.preventDefault();
		var $form = $(this);
		var action = $form.attr('action');
		var formData = $form.serialize();
		var emailFrom = $('#email-from').val();
		var emailTo = $('#email-to').val();
		var uresponse=$('#g-recaptcha-response').val();
		$('#eml-from-address-message').html("");
		$('#eml-to-address-message').html("");
		$('#eml-friend-captcha-message').html("");
		if (isValidEmailAddress(emailFrom) && isValidEmailAddress(emailTo) && uresponse !="") {
			// eloqua
			
			// email
			$.ajax(action, {
				type: 'POST',
				data: formData,
				success: function(data, textStatus, xhr) {
					$("#emailModal .eml-friend").hide();
					$(".eml-friend-success").fadeIn(800);	
				},
				error: function(xhr, textStatus, errorThrown) {
					$("#emailModal .eml-friend").hide();
					$(".eml-friend-error").fadeIn(800);						
				}
			});
		}
		else {	
			if(uresponse==""){
				$('#eml-friend-captcha-message').html("Please verify you're not a robot!");	
			}
			if(!isValidEmailAddress(emailTo)){
			  $('#eml-to-address-message').html("Please enter a valid email address.");		
			}
			if(!isValidEmailAddress(emailFrom)){
			  $('#eml-from-address-message').html("Please enter a valid email address.");		
			}
		}
	});
} //bindEmailModal() end

$(document).ready(function() {
	$(document).on("click","#email-icon",function(event) {
		event.preventDefault();
		bindEmailModal();
		$('#emailModal').fadeIn(800);
	});
});
</script>
<div class="modal eml-friend-wrapper" id="emailModal" style="display:none;">	
	<form class="eml-friend" action="/eloquaemail/article?eloqua=false&id=3290359">
		<input type="hidden" name="title" value="Macworld\'s August Digital Magazine: First look at iOS 12 and macOS Mojave" />
		<input type="hidden" name="url" value="https://www.macworld.com/article/3290359/ios/macworlds-august-digital-magazine-first-look-at-ios-12-and-macos-mojave.html" />
		<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
		<h3>Email a friend</h3>

		<div class="input-row">
			<div id="eml-to-address-message" class="error-msg"></div>
			<h4 class="input-label">To</h4>
			<input id="email-to" value="" placeholder="Email address (required)" type="email" name="recipients" tabindex="1">
			<p class="addl-text">Use commas to separate multiple email addresses</p>
		</div>
		<hr />
		<div class="input-row">
			<div id="eml-from-address-message" class="error-msg"></div>
			<h4 class="input-label">From</h4>
			<input id="name" value="" placeholder="Name (optional)" type="text" name="name" tabindex="2">
		</div>
		<div class="input-row">
			<input id="email-from" value="" placeholder="Email address (required)" type="email" name="sender" tabindex="3">
		</div>
		<div class="input-row">
			<textarea name="message" placeholder="Check out this article I found on Macworld." id="personalization" tabindex="4"></textarea>
		</div>
		<hr />
		<div class="input-row">
			<div id="eml-friend-captcha-message" class="error-msg"></div>
		
		
 			











<script src="https://www.google.com/recaptcha/api.js" async defer></script>

<div class="g-recaptcha" data-sitekey="6LczmkcUAAAAANEO7J277KwH6Kzp6BEQjPTWP4S4"></div>
 		</div>
		<hr />
		<div class="submit">
			<input type="submit" value="Send" class="input-submit" tabindex="5">
			<a href="/about/privacy.html" class="submit-privacy" target="_blank">Privacy Policy</a>
		</div>
	</form>

	<div class="eml-ty eml-friend-success" style="display:none;">
		<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
		<h3>Thank you</h3>
		<p class="msg-sent">Your message has been sent.</p>
	</div>
	<div class="eml-friend-error" style="display:none;">
		<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
		<h3>Sorry</h3>
		<p class="msg-sent">There was an error emailing this page.</p>
	</div>
</div>

		</div>
	
	
	

	
		
			
				
				<div class="cat byline vcard author with-image">		
					<div class="byline-wrapper">
						<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
							
						
							
							
							
							
						
















<a href="/author/Macworld-Staff/" rel="author" title="Macworld Staff"><img  class="bylineImage  imgId100007367 " src="https://images.techhive.com/images/article/2012/10/w2j2tqytk5fm03lobjc-100007367-byline.png" width="34" width="34" alt="Macworld Staff" itemprop="image" /></a>

						
							
								
							
















<span class="by">By </span><span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/Macworld-Staff/"><span itemprop="name">Macworld Staff</span></a></span>
						</p>
						<p class="dateline">
						
							Editors, 
								
									
								












<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name">Macworld</span><meta itemprop="logo" content=""/></span> <span class="divider break">|</span>
							
										
							<span class="pub-date" class='break-date' itemprop="datePublished" content="2018-07-17T17:09-0700">Jul 17, 2018 5:09 PM
								 PT
							</span>
						</p>
					</div>
				</div>
			
		
	
	
		
	
	
	
	
		
			<div id="articleLeaderboardWrapper">
				<div id="articleLeaderboardInner">
						
						
								
									
								




















	
		
		
		
		
			<div id="gpt-leaderboard" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-leaderboard", "true");
	    			$('#gpt-leaderboard').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-leaderboard [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	
						
				</div>
			</div>
			
				
			




















	
		
		
		
		
			<div id="gpt-leaderboardmobile" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-leaderboardmobile", "true");
	    			$('#gpt-leaderboardmobile').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-leaderboardmobile [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	 
		
	
	
	
</header>



	
	
	
	
		
		
			
                
                	
                	
                
                
				
				
				
			
			
			
			
			<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
				<meta itemprop="representativeOfPage" content="1" />
				<meta itemprop="height" content="468" />
				<meta itemprop="width" content="700" />
	    		
	    		<img src="https://images.idgesg.net/images/article/2018/07/mwdigitaledition_primary-aug18-100764619-large.jpg" alt="mwdigitaledition primary aug18" itemprop="contentUrl" itemprop="url" />
	    		
	    		<figcaption>
	    			
	    			
	    				<span class="credit" itemprop="copyrightHolder">
	    					
			    				
			    				IDG
		    				

			    			
			    				
			    				
			    				
								
								  	
								
								  	
								
								  	
								
								  	
								
								  	
								
								  	
								
								  	
								
								  	
								
								  	
								
								  	
								
								  	
								
								  	
								
			    				
			    				
								
							
					
						</span>
	    			
					
	    		</figcaption>
			</figure>
			

		
		
	











	
	
	
	
		
	



<section class="epo cat-narrow" id="drr-top-ad">
	
		
		
				
   	
   	
   	
   		
   			
   		











<!-- Related -->










	<div class="related-promo-wrapper">
		<div class="promo apart">
			<div class="hed">More like this</div>
	    	<ul class="">
		    	
		    		
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="/article/3282465/security/what-to-do-when-your-two-step-apple-id-account-is-locked.html"><img  class="small.3x2Image  imgId100761846 " src="https://images.idgesg.net/images/article/2018/06/hand-iphone-pixabay-100761846-small.3x2.jpg" alt="hand iphone pixabay" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="/article/3282465/security/what-to-do-when-your-two-step-apple-id-account-is-locked.html">What to do when your two-step Apple ID account is locked</a></div>
	</div>
</li>
		    	
		    		
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="/article/3268804/software/mcafee-endpoint-security-for-mac-review.html"><img  class="small.3x2Image  imgId100755236 " src="https://images.idgesg.net/images/article/2018/04/mcafeelogo2-2-100755236-small.3x2.jpg" alt="mcafee logo" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="/article/3268804/software/mcafee-endpoint-security-for-mac-review.html">McAfee Total Protection for Mac review: Thin on features and weak on security</a></div>
	</div>
</li>
		    	
		    		
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="/article/3282832/software/mcafee-total-protection-for-mac-review.html"><img  class="small.3x2Image  imgId100762142 " src="https://images.idgesg.net/images/article/2018/06/2018-mtp_boxshot_uk-100762142-small.3x2.jpg" alt="2018 mtp boxshot uk" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="/article/3282832/software/mcafee-total-protection-for-mac-review.html">McAfee Total Protection for Mac review: Good at detecting malware, but lacks...</a></div>
	</div>
</li>
		    	
		    	
					
					
						
						
						
							
							
							
							
							
							
							
							
							
							
						




























































	
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
							
						
					














<li class="clearfix with-image">
	
		<a  class="play" href="/video/88975/5-features-that-have-us-excited-about-ios-12"><i class="ss-play"></i></a>
		<a  href="/video/88975/5-features-that-have-us-excited-about-ios-12"><img  class="small.3x2Image  imgId100763033 " src="https://images.idgesg.net/images/article/2018/07/mre18_019_ios12-100763033-small.3x2.jpg" alt="iOS 12" itemprop="image" /></a>
    
	<div class="item">
		<div class="item-eyebrow">Video</div>
		<div class="title"><a  href="/video/88975/5-features-that-have-us-excited-about-ios-12">5 features that have us excited about iOS 12</a></div>
	</div>
</li>
				
				
			
		
	




					
				
		    </ul>
		</div>
	</div>

   	


				<div class="ad top-ad">
	
		
		
			
				
					
						
					
					
				
				
				
			





















	

		
			
			
			
			
			
				<div id="gpt-showcase" class="adunit ad-container">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				if($(window).width() >= 930) {
					IDG.GPT.addDisplayedAd("gpt-showcase", "true");
					$('#gpt-showcase').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: gpt-showcase - [971 1115]");
				}
				});
				</script>
			
		
	
 	
 
 
		
	
</div>
		
	
</section>













		<section class="bodee">

			
				
				
					



















	







	<div class="ad placement">
		
			
		





















	

		
			
			
				<!--  Begin gpt-skin/inread -->
				<div id="inread" class=" ad-container">					
				</div>
				<script type="text/javascript">
				consent.ads.queue.push(function(){
					IDG.GPT.addDisplayedAd("inread", "true");
					IDG.GPT.displayGoogleTagSlot('inread');
				});
				</script>
				<!--  End gpt-skin/inread -->	
			
			
			
			
		
	
 	
 
 
	</div>








	
	
		
		
		<script>
			var dataLayer = window.dataLayer = window.dataLayer || [];
			dataLayer.push({
				'event': 'loadTopCollectionModule'
				});
		</script>
		
	


















<script type="text/javascript">

$(document).ready(function() {
	$('.articleBloxAd').filter( ":visible" ).each(function(index, item) {
		var id = $(item).attr('id');
		var divClass = $(item).attr('class');
		var adString = IDG.GPT.getLazyAdCode();
		$(item).replaceWith("<div id=\"" + id + "\" class=\"lazyload_blox_ad " + divClass + "\">" + adString + "</div>");
	});
	try {
		$("div.lazyload_blox_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
		}) ;
	}
	catch (exception){
		console.log("error loading lazyload_ad " + exception);
	}
});

</script>
		


		

		












	
	



<script type="text/javascript">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</script>






	
	
		
	





	
		
			
			
			
				
			
			
		
	
	


	
	
		<div id="drr-container" class='cat ' itemprop="articleBody">
	
	
	
	

	<p>Every day, <a href="http://www.macworld.com/">Macworld</a> brings you the essential daily news and other info about all things Apple. But staying on top of that torrent of information can be a constant challenge. One solution: the Macworld digital magazine. </p><h2>In the August issue</h2><p>This month we have our first look at iOS 12 and macOS Mojave, including everything you need to know about the new OSes and all of the best features to keep an eye out for. Take a peak into the future to see our vision of the Mac in 2020 and find out why the announcements that Apple didn’t make at WWDC might be more important than the ones they did.</p><p>Also in this month’s issue:</p><aside id="fsb-2399" class="fakesidebar fakesidebar-auto"><a href="https://www.macworld.com/article/3252034/ios/ios-12-features-release-date-and-how-to-install.html">[ Further reading: Everything you need to know about iOS 12 ]</a></aside><p>• <strong>MacUser:</strong> How to get student or teacher discounts on Apple products</p><p><strong>• MacUser Reviews:</strong> 1Password 7 for Mac, LifeFlix 2.5, Tweetbot 3 for Mac</p><p>• <strong>iOS Central:</strong> Why Apple's rumored 6.1-inch iPhone will be the model everyone wants</p><p>• <strong>iOS Central Reviews:</strong> Read our review of the podcast app Castro 3</p><p>• <strong>Working Mac:</strong> The best cloud storage services for Apple users</p><aside class="nativo-promo nativo-promo-1 smartphone tablet desktop" id=""> </aside><p>• <strong>Playlist:</strong> tvOS 12: Dolby Atmos, zero sign-in, and TV app improvements make Apple TV 4K the box to beat</p><p>• <strong>Mac 911:</strong> How to consolidate all the images on your Mac; understand how iCloud stores data</p><h2>Take note</h2><p>Check out the responsive view on our platform. While in the issue, swipe to an article page (for example, MacUser) tap the screen to reveal the app menu, go to the bottom menu and tap the viewer icon (first icon from the left). To go back to static view, tap the viewer icon again.</p><p>You’ll need your email and subscription password to access your issues on the new platform. If you haven’t created a password for your subscription, follow the steps below.</p><ul>
<li>To set up your account with a password for the Digital Edition of Macworld. Go to the Macworld app on your device. Tap upper left menu &gt; My Account. (You’ll need to be connected to wifi for the screen to appear.) Click on the Existing Subscribers tab. Click on option two and enter the email address tied to your account and create a password.</li>
<li>If your email address was found proceed to step 6. If your email address was not found, go back and choose option one and enter your name and address.</li>
<li>To complete the process and ensure your new password has been set up correctly, click on the Login tab and enter your email and new password.</li>
</ul><p>From a desktop, go to <a href="https://ssl.palmcoastd.com/31401/apps/LOGINSSO" rel="nofollow">macworld.com/customer_service</a> to create a password for your subscription. (If you read the Replica edition through Zinio, your process will not change.)</p><p>Should you need assistance, please call 800-288-6848, or email us at <a href="mailto:macworld@emailcustomerservice.com" rel="nofollow">macworld@emailcustomerservice.com</a>, and we’ll be happy to help you.</p><p>Please update to the <a href="https://itunes.apple.com/us/app/macworld-digital-magazine-u-s/id505331062?mt=8" rel="nofollow">latest version of our app in the App Store</a>.</p><h2>How to subscribe</h2><p>Sign up for our <a href="https://ssl.palmcoastd.com/31401/apps/MCWDIGITAL?ikey=I**A08" rel="nofollow">digital magazine</a>. Existing subscribers can <a href="https://ssl.palmcoastd.com/31401/apps/LOGINSSO" rel="nofollow">log in</a> to access to their issues.</p><aside class="nativo-promo nativo-promo-2 tablet desktop smartphone" id=""> </aside><p>Our magazine can also be found through a variety of other digital newsstands such as <a href="http://www.nextissue.com/magazines/macworld/?gclid=CNWeq_-JjcICFQVafgodZiIA7w" rel="nofollow">Next Issue</a>, <a href="https://play.google.com/store/newsstand/details/Macworld?id=CAown_Z5&amp;hl=en" rel="nofollow">Google Play</a>, <a href="http://www.amazon.com/Macworld/dp/B0064QHPNE/" rel="nofollow">Kindle</a> and <a href="http://www.barnesandnoble.com/w/macworld-us-edition-mac-publishing-llc/1115274923" rel="nofollow">Nook</a>.</p>

	
	
		
	
	
	
	
		
		
		
		










<div class="end-note">
	
		
	











	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<!-- blx4 #2007 blox4.html  -->
			

		
			
				
					
					
					
						
							
					
						
					
					
					
					
					
				
				
			
		
















	
		
		
			<div id="" class="blx blxParticleendnote blxM2007  blox4_html  blxC24067"><aside>
To comment on this article and other Macworld content, visit our <a href="https://www.facebook.com/Macworld/" target="_blank">Facebook</a> page or our <a href="https://twitter.com/macworld" target="_blank">Twitter</a> feed. 
</aside></div>
		
	

	


</div>
	
	
</div>





<script>
$("a[data-product-id]").on('click',function(e){
	var e = e || window.event;
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var prodName = $(this).attr("data-product-name");
	prodName = prodName.replace("\\'","'"); // to counter the effects of over-escaping
	
	if ( $(this).parents('.slideshow').length > 0 ) {
		var productLinkPosition = "Slideshow";
	} else if ( $(this).parents('.emo-sb').length > 0 ) {
		var productLinkPosition = "Product Sidebar";
	} else if ( $(this).parents('.at-a-glance.top').length > 0 ) {
		var productLinkPosition = "AAG Top";
	} else if ( $(this).parents('.at-a-glance').length > 0 ) {
		var productLinkPosition = "AAG Bottom";
	} else if ( $(this).parents('.product-chart').length > 0 ) {
		var productLinkPosition = "Product Chart";
	} else if ( $(this).parents('.emo-list').length > 0 ) {
		var productLinkPosition = "Product List";
	} else {
		var productLinkPosition = "Body Text";
	}
	
	dataLayer.push({
		'event': 'affiliateLink', 
	  	'eventCategory': 'Affiliate Link', // Hardcoded, not dynamic
	  	'eventAction': 'Click', // Hardcoded, not dynamic
	  	'eventLabel': ''+e.target+'', // The URL the affiliate link leads to
	  	'productVendor': $(this).attr("data-bkvndr"), // The vendor of the product
	  	'productManufacturer': $(this).attr("data-bkmfr"), // The manufacturer of the product
	  	'productName': prodName, // The name of the product
	  	'productId': $(this).attr("data-product-id"), // The ID of the product
	  	'productLinkPosition': productLinkPosition // location of product link (Product Sidebar, Product Chart, etc.)
	});
});
</script>


	<script>
$("#drr-container a").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickParentsUntilDrr = $clickEl.parentsUntil("#drr-container");
	var clickText = $clickEl.text().trim();
	var linkLocation;
	var linkType;
	var regex = new RegExp("cio|csoonline|computerworld|itnews|itworld|infoworld|networkworld|javaworld|techconnect|techhive|macworld|pcworld|greenbot|gamestar", "i");
	
	if (clickParentsUntilDrr.hasClass("fakesidebar")) {
		linkLocation = "FSB";
	}
	else if (clickParentsUntilDrr.hasClass("end-note")) {
     	 linkLocation = "End Note";
   }
	else {
		linkLocation = "Body";
	}
	
	if (regex.test(clickUrl)) {
	      linkType = "Internal";
	    }
	else {
		linkType = "External";
	}
		
	
	dataLayer.push({
		'event': 'editBodyLink', 
	  	'eventCategory': 'Editorial Body Links',
	  	'eventAction': linkType,
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>







    <div class="apart-alt tags">
    <span class="related">Related: </span>
    <ul>
		
			<li><a href="/category/ios">iOS</a></li>
		
			<li><a href="/category/macs">Macs</a></li>
		
			<li><a href="/category/iphone-ipad">iPhone/iPad</a></li>
		
			<li><a href="/category/macbook">MacBooks</a></li>
		
			<li><a href="/category/apple-phone">iPhone</a></li>
		 
		
			
			
				 
					 
			    				
				
			
				
		
    </ul>
   
	</div>









		
   		
		












		
	
	
	
	
		
		
		







	
	


















 




	
	
	
	
	
	












	
	
	
	
	
	
	
	
	
	
	
	
	
	





<script src="/www/js/video/embedder.js"></script>

					










				
			
		
		</section><!-- /.bodee -->

		














		
			
				













<div id="content-recommender">
	<div class="OUTBRAIN" data-widget-id="AR_1" data-ob-template="MacWorld_1"></div>  
	<script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
</div>
			
				
		
	
		<div id="amazon-bottom-widget">
			<div class="amzn-custom-header">Shop Tech Products at Amazon</div>
				<script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&storeId=httpwwwidgcsm-20&adInstanceId=f28f8449-ab80-4ceb-941b-6f3ebf8ef345"></script>
			</div>
	


		</article>

	</section><!-- /role=main -->

</div><!-- /#page-wrapper -->
		
		













<div id="panel-loader"></div>
<!-- IDGMPM-11812, category.getCategoryType() returns an integer, and 9 stands for tentpole-->
 



	
		










<link rel="stylesheet" href="/www.idgcsmb/css/tso-links.css?v=20180712120429" />

	<div id="tso-wrapper"><div id="tso" style="display:none"></div></div>
	<script type="text/javascript">
	function renderTSO(ads, requireHttps) {
		$thm.debug("renderTSO:"+ads.length);
		if (ads && ads.length > 0) {
			var selectedAds = selectTSOAds(ads,6);
			if (null != selectedAds && selectedAds.length > 0) {
				var html = "<h3>Today's Special Offers</h3>";
				html += "<ul>";
				for (var i=0; i<selectedAds.length;i++) {
					html += "<li>";
					html += "<a href='"+selectedAds[i].url+" "+selectedAds[i].title+"</a>";
					html += "<span>"+selectedAds[i].body+"</span>";
					if (null != selectedAds[i].pixel && selectedAds[i].pixel.length > 0 && selectedAds[i].pixel.indexOf('http') == 0) {
						if(!requireHttps || selectedAds[i].pixel.indexOf('https://') == 0){
							html += "<img src='"+selectedAds[i].pixel+"' style='height:0;width:0;'/>";
						}
					}
					html += "</li>";
				}
				html += "</ul>";
				$("#tso").html(html).show();
			}
		}
	}
	function selectTSOAds(ads,max) {
		if (ads.length <= max) {
			return ads;
		} else {
			var uniq = {};
			var found = 0;
			var selectedAds = [];
			while (found < max) {
				var ad = ads[Math.floor(Math.random()*ads.length)];
				if (uniq[ad.id] != null) {
					continue;
				} else {
					uniq[ad.id] = true;
					found++;
					selectedAds.push(ad);
				}
			}
			return selectedAds;
		}
		return null;
	}
	</script>
	

	




		










<link rel="stylesheet" href="/www.idgcsmb/css/footer.css?v=20180712120429" />
<link rel="stylesheet" href="/www.idgcsmb.mw/css/footer.css?v=20180712120429" />
<div id="network"></div>

	












<footer id="footer" class="clearfix">
    <div class="container clearfix">
    	<div class="footer-col">
    		<a href="http://macworld.com" id="footer-logo-mw" class="ir">Macworld</a>
    		<p>Macworld is your best source for all things Apple. We give you the scoop on what's new, what's best and how to make the most out of the products you love.</p>
    		<ul>
    			<li><a href="/about/about.html">About Us</a></li>
				<li><a href="/about/contact.html">Contact Us</a></li>
				<li><a href="http://hints.macworld.com/" rel="nofollow">Mac OS X Hints</a></li>
				<li><a href="https://www.idg.com/about-adchoices-macworld/" rel="nofollow">Ad Choices</a></li>
				<li><a href="/faq" rel="nofollow">Digital Magazines</a></li>
				<li><a href="/newsletters/signup.html">Newsletters</a></li>
				<li><a href="/about/cookie-policy.html">Cookie Policy</a></li>
			</ul>
			<ul class="right">
				<li><a href="/about/member-preferences.html">Member Preferences</a></li>
				<li><a href="/about/privacy.html" rel="nofollow">Privacy Policy</a></li>
				<li><a href="/index.rss">RSS</a></li>
				<li><a href="https://www.idg.com/terms-of-service-agreement/" rel="nofollow">Terms of Service Agreement</a></li>
				<li><a href="/about/affiliates.html">E-commerce Affiliate Relationships</a></li>
			</ul>
    	</div>
    	<div class="footer-col">
    		<h2>Macworld Categories</h2>
    		<ul>
    			<li><a href="/category/business/">Business</a></li>
				
				<li><a href="/category/creative/">Creative</a></li>
				<li><a href="/category/entertainment/">Entertainment</a></li>
				<li><a href="/category/ios-apps/">iOS Apps</a></li>
				<li><a href="/category/mac-apps/">Mac Apps</a></li>
			</ul>
			<ul class="right">
				<li><a href="/category/macs/">MacCentral</a></li>
				<li><a href="/category/iphone-ipad/">iPhone/iPad</a></li>
				<li><a href="/category/os-x/">OS X</a></li>
				<li><a href="/column/mwpodcast">Podcasts</a></li>
				<li><a href="/video/">Video</a></li>
			</ul>
			<h3>IDG Network Sites</h3>
			<ul>
				<li><a href="http://resources.idg.com/contact/contact-idg" rel="nofollow">Advertise</a></li>
				<li><a href="https://www.idg.com/technetwork/technetwork-permissions-guildelines/" rel="nofollow">Permissions</a></li>
				<li><a href="http://www.pcworld.com/" rel="nofollow">PCWorld</a></li>
				<li><a href="http://www.techadvisor.co.uk/">Tech Advisor</a></li>
				<li><a href="http://www.techhive.com/" rel="nofollow">TechHive</a></li>
			</ul>
			<ul class="right">
				<li><a href="https://www.idg.com/technetwork/" rel="nofollow">IDG TechNetwork</a></li>
				<li><a href="https://www.idg.com/" rel="nofollow">IDG</a></li>
				<li><a href="http://blog.idg.com/" rel="nofollow">IDG Blog</a></li>
				<li><a href="https://www.idg.com/work-here/" rel="nofollow">Careers at IDG</a></li>
			</ul>			
    	</div>
    	<div class="footer-col">
    		<div id="footer-subscribe" class="clearfix">
	    		<a href="https://ssl.palmcoastd.com/31401/apps/MCWDIGITAL?ikey=I**A03" rel="nofollow">
	    			<img src="//alt.idgesg.net/images/furniture/macworld/footer-subscribe-mag-mw.png" alt="Macworld Magazine Cover">
	    			<h2>Try Macworld <span>Risk-Free</span></h2>
	    			<span class="btn-link">Subscribe Now</span>
	    		</a>
    		</div>
    		<div id="footer-social">
    			<span>Follow us</span> <a href="http://www.facebook.com/Macworld" class="network-fb ss-icon ss-social-circle banner-social banner-fb" alt="Facebook" itemprop="sameAs" rel="nofollow">
						&#xF610;
					</a>
					<a href="https://twitter.com/macworld" class="network-tw ss-icon ss-social-circle banner-social banner-tw" alt="Twitter" itemprop="sameAs" rel="nofollow">
						&#xF611;
					</a>
					<a href="https://plus.google.com/+macworld/posts" class="network-google ss-icon ss-social-circle banner-social banner-google" alt="Google+" itemprop="sameAs" rel="publisher">
						&#xF613;
					</a> 
					
						<a href="https://www.youtube.com/user/macworld" class="network-youtube ss-icon ss-social-circle banner-social banner-youtube" alt="YouTube">
							&#xF630;
						</a>
					 			
    		</div>
    		
    		 <p>Visit other IDG sites:</p>
    		
    		<div id="idgInfo" class="styled-select">		
		            <select onchange="location = this.options[this.selectedIndex].value;" id="jumpMenu" name="jumpMenu" d30tagged="1" style="visibility: visible;">
		                <option value="">Select One</option>
						
							
						













	
		<option value="https://www.cio.com">CIO</option>
	
		<option value="https://www.cio-asia.com">CIO Asia</option>
	
		<option value="https://www.computerworld.com">Computerworld</option>
	
		<option value="https://www.csoonline.com">CSO</option>
	
		<option value="https://www.gamestar.com">Gamestar</option>
	
		<option value="https://www.greenbot.com">Greenbot</option>
	
		<option value="https://www.idgconnect.com">IDG Connect</option>
	
		<option value="https://www.idg.tv">IDG.tv</option>
	
		<option value="https://www.infoworld.com">InfoWorld</option>
	
		<option value="https://www.itnews.com">IT News</option>
	
		<option value="https://www.itworld.com">ITworld</option>
	
		<option value="https://www.javaworld.com">JavaWorld</option>
	
		<option value="https://www.macworld.com">Macworld</option>
	
		<option value="https://www.networkworld.com">Network World</option>
	
		<option value="https://www.pcworld.com">PCWorld</option>
	
		<option value="https://www.techhive.com">TechHive</option>
	
		<option value="https://www.thefullnerd.com/">The Full Nerd</option>
	

		            </select>
		    </div>
		    
		        <p><small><a href="http://idgcsmb.com/terms-of-service-agreement/">Copyright</a> &copy; 2018 IDG Communications, Inc.</small></p>
    	</div>
    </div> 
</footer>
 


		
				
		
			
				
			




















	
		
		
		
		
			<div id="gpt-infunnel" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-infunnel", "true");
	    			$('#gpt-infunnel').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-infunnel [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	
		
		
			
		












<script src="/www/js/analytics/mouse_down.js"></script> 



<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script> 

<script src="/www.idgcsmb/js/jquery/jquery-ui-tools.js"></script>


	<script>
		$(document).ready(function() {
			if (typeof $.cookie("geoPromoDontShow") === 'undefined' && typeof $.cookie("geoPromoSeen") === 'undefined' && navigator.languages.indexOf("es") > -1 && $thm.deviceWidthAtLeast($thm.deviceBreakpoints.wide)) {
				$.get("/napi/tile?def=international.promo", 
					function(data) {
						$("body").prepend(data);
						var visitTime = new Date();
						visitTime.setTime(visitTime.getTime()+1000*60*60*24); //24 hours
				      	$.cookie('geoPromoSeen', 'true', { expires: visitTime, path: '/' });
						$(".geo-promo .ss-delete, a.cont-here, a.dont-show").click(function(e) {
							e.preventDefault();
							if ($(this).is(".dont-show")) {
								visitTime.setTime(visitTime.getTime()+1000*60*60*24*30); //30 days
						      	$.cookie('geoPromoDontShow', 'true', { expires: visitTime, path: '/' });
							}
							$(".geo-promo").fadeOut(function() {$(".geo-promo").remove()})
						});
					}
				);
			}
		});
	</script>

<script src="/www.idgcsmb/js/thm_post.js?v=20180712120429"></script>

<script src="/www.idgcsmb/js/jquery/plug-ins/jquery.md5.js"></script>

	<script src="/www.idgcsmb/js/jquery/plug-ins/jquery.colorbox-min.js"></script>


<script src="/www.idgcsmb/js/autocomplete.js"></script>









<script src="/www/js/jquery/jquery.lazyload.min.js"></script>
<script>
$(function() {
    $("img.lazy").lazyload({ 
    	effect : "fadeIn", 
    	threshold: 200,
    	failure_limit:25
    });
});
</script>

<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js"></script>















<script type="text/javascript">

$(document).ready(function() {
	$('.articleBloxAd').filter( ":visible" ).each(function(index, item) {
		var id = $(item).attr('id');
		var divClass = $(item).attr('class');
		var adString = IDG.GPT.getLazyAdCode();
		$(item).replaceWith("<div id=\"" + id + "\" class=\"lazyload_blox_ad " + divClass + "\">" + adString + "</div>");
	});
	try {
		$("div.lazyload_blox_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
		}) ;
	}
	catch (exception){
		console.log("error loading lazyload_ad " + exception);
	}
});

</script>

<script type="text/javascript">
// -- Load Lazy Advertisement placement as deferred
try {
	$("div.lazyload_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
	}) ;
}
catch (exception) {
	console.log("Error with lazyLoadAd: "+exception);
}
</script>

<script src="/www.idge/js/jquery/jquery.tablesorter.min.js"></script>
<script>
$(document).ready(function() {
	$("table.tablesorter").tablesorter({
		widgets: ['zebra']
	});
	
	$("table.tablesorter tbody tr").hover(function() {
		$(this).toggleClass("selected");
	});
	
	$("table.tablesorter thead tr th").each(function(){			
		if ($(this).find('.ss-icon').length < 1) {
			$(this).append('<i class="ss-icon"></i>');
		}
	});
	
});
</script>

<script>
	//click event for BrandPost "Learn More" buttons
	$(".learn-more").click(function(event) {
		 var brandpost_txt = "<div class=\"about-brandposts\"><p>BrandPosts are written and edited by members of our sponsor community. BrandPosts create an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of BrandPosts.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";
		 if ($(".blog-byline.sponsored-post").length > 0) { //for Nativo sponsoredPosts
			 brandpost_txt = "<div class=\"about-brandposts\"><p>SponsoredPosts are written and edited by members of our sponsor community. SponsoredPosts create an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of SponsoredPosts.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";
		 }
		 $("body").append(brandpost_txt);
		 $(".about-brandposts").css("top",event.pageY);
		 if ($("body").width() >= 955) { // need different behavior at desktop breakpoint and above
			 //find difference between X position clicked and body width and set as right attr 
			 //this is so tooltip doesn't overflow window
			 var xpos = $("body").width() - event.pageX;
			 $(".about-brandposts").css({"right":xpos,"margin-right":"0"});
		 }
		 $(".about-brandposts .close-bar").click(function() {
			 $(".about-brandposts").remove();
			 return false;
		 });
		 return false;
	});
</script>





	<!-- LiveRamp Sources -->
	<script type="text/javascript"src="//storage.googleapis.com/cdn.pippio.com/sdk/pippio.min.js" async></script>
	<script src="/www/js/utils/liveRamp.js"></script>
	<!-- End of LiveRamp -->


<script type='text/javascript'>

	
	$(document).ready(function(){

	$('#extra-nav-toggle a').click(function(){
		if($(this).hasClass('open')){
			$('#extra-nav').hide();
			$(this).removeClass('open');
			$('#extra-nav-toggle a').removeClass('ss-delete');
			$('#extra-nav-toggle a').addClass('ss-dropdown');		
		} else {
			$('#extra-nav').show();
			$(this).addClass('open');
			$('#extra-nav-toggle a').removeClass('ss-dropdown');
			$('#extra-nav-toggle a').addClass('ss-delete');					
		}
		return false;
	});
		   
						  
	});//-- end document Ready
		
	


	g_bRequireHttps = true;
	 
		$.ajax('/ads/tso',{
			dataType: 'json',
			success: function(data){
				renderTSO(data.tsoLinks, g_bRequireHttps);
			},
			error: function(jqXHR,error,thrown){
				$thm.debug("TSO AJAX Status: "+error+": "+thrown,true);
			}
		});
	
</script>

		<script type="text/javascript">a=top;f=self;if(a!=f){a.location=f.location;}</script>

 		














	
	
	    
	    
		   	
		   	
		   	
	    
    	
    	
	    
	












	
	
	
	
	
	
	
	
	
	
	
	
	
	





<!-- Begin BlueKai Tag-->
<iframe name="__bkframe" height="0" width="0" frameborder="0" src="javascript:void(0)"></iframe>
<script type="text/javascript" src="https://tags.bkrtx.com/js/bk-coretag.js"></script>
<!-- CryptoJS -->
<script src="/www/js/utils/md5.js"></script>
<script type="text/javascript" src="/www/js/analytics/idg_bk_coreapi.js"></script>

<script type="text/javascript">
bk_allow_multiple_calls=true;
var blueKaiId=13977;
var blueKaiPort=10;
var brandCode = "mw";
var regUrl="https://regdev.idge.int/api/"
var daysToRefresh=30;
var bk_debug_log=false;


regUrl="https://reg.idgenterprise.com/api/";



daysToRefresh=30;


	




//CMS-Specific
bk_addPageCtx("cmscatids", "[3144,3800,3028,3706,3183]");



	bk_addPageCtx("goldenIds", "[230,740,931,741,746]");


bk_addPageCtx("cmpy", "[]");

bk_addPageCtx('tid', '2');

	










try{
	IDG.bkCoreApi.start();
}
catch(e){
	//alert("Triggering catch")
	bk_doJSTag(blueKaiId ,blueKaiPort);
	if (window.console && window.console.log){
		window.console.log("Error Occured While Processing Profile Siubmission")
	}
}



//bk_doJSTag(13977, 10);











$('article, #slideshowCarousel').on('click', '.product-list-price, .btn-amazon, .productLink', function(e) {
	var $linkEl = $(e.target);
	var po = $linkEl.data('po');
	if ($.inArray(po, ['amazon', 'vendor', 'other']) >= 0) {
		if (po == 'amazon') {
			var prCat = $linkEl.data('bkc');
			if (typeof prCat != 'undefined') {
				bk_addPageCtx('event', 'AmazonClick'+prCat);
			}
			
			bk_addPageCtx('event', 'AmazonClickiOS');
			
			bk_addPageCtx('event', 'AmazonClickMacs');
			
			bk_addPageCtx('event', 'AmazonClickiPhone/iPad');
			
			bk_addPageCtx('event', 'AmazonClickMacBooks');
			
			bk_addPageCtx('event', 'AmazonClickiPhone');
			
		}
		var prMfr = $linkEl.data('bkmfr');
		if (typeof prMfr != 'undefined') {
			bk_addPageCtx('event', 'eCommerceMFR'+prMfr);
		}
		var prVndr = $linkEl.data('bkvndr');
		if (typeof prVndr != 'undefined') {
			bk_addPageCtx('event', 'eCommerceClickVendor'+prVndr);
		}
		bk_doJSTag(34202, 1);
	}
});
</script>
<!-- End BlueKai Tag -->

 		
		











<script type="text/javascript">
$thm.logPlEvent({"b":"mw","e":"view","t":"article","id":"3290359"});
</script>


	
	
		<div id="loginModal"></div>
		<div id="logoffModal"></div>
		<div id="abuseModal"></div>

		
			<!-- rev: 20180712120429  -->
		
		
		
		
			
				
			




















	
		
			<div id="gpt-skin" class=" ad-container"></div>
    			<script type="text/javascript">
    			consent.ads.queue.push(function(){
    				try {
	    				IDG.GPT.addDisplayedAd("gpt-skin", "true");
	    				IDG.GPT.displayGoogleTagSlot('gpt-skin');
	    			}
	    			catch (exception) {
	    				console.log("Error with IDG.GPT: " + exception);
	    			}
    			});
    			</script>
		
		
		
		
	
 
 
			
			
	</body>
</html>
