










<!DOCTYPE html>


	
	
		
	
		
	
	
	
	

<html lang="en">
	












<head>
	<link rel="alternate" hreflang="en" href="https://www.macworld.com/article/3331839/iphone-11-rumors-the-new-iphones-have-a-sensor-coprocessor-named-rose-or-r1.html" />	
	<meta charset="utf-8" />
	<title>iPhone 11 rumors: Everything you need to know | Macworld</title>
	<meta name="viewport" content="width=device-width, initial-scale=1.0" />
	
	
	<script>
	function getQueryVariable(variable) {
		var query = window.location.search.substring(1);
		var vars = query.split("&");
		for (var i=0;i<vars.length;i++) {
			var pair = vars[i].split("=");
			if(pair[0] == variable){return pair[1];}
		}
		return(false);
	}
	</script>
	
	<!-- ad-related js -->
	
	<script src="/www/js/jquery/jquery-1.10.2.min.js"></script>
	
	<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
	
	
	<script type="text/javascript" src="/www/js/apollo-locales.js"></script>
	
	












<script>
var consent = consent || {};
consent.isEU = consent.isEU || null;
consent.personalization = consent.personalization || null;
consent.ads = consent.ads || {};
consent.ads.queue = consent.ads.queue || [];

consent.infostorage = consent.infostorage || {};
consent.infostorage.queue = consent.infostorage.queue || [];

consent.adsel = consent.adsel || {};
consent.adsel.queue = consent.adsel.queue || [];

consent.contentsel = consent.contentsel || {};
consent.contentsel.queue = consent.contentsel.queue || [];

consent.socmedia = consent.socmedia || {};
consent.socmedia.queue = consent.socmedia.queue || [];

consent.tealium = consent.tealium || {};
consent.tealium.queue = consent.tealium.queue || [];

consent.digitalelement = consent.digitalelement || {};
consent.digitalelement.queue = consent.digitalelement.queue || [];

consent.purposes = consent.purposes || {};
consent.purposes.standard = consent.purposes.standard || [];
consent.purposes.custom = consent.purposes.custom || [];
consent.vendors = consent.vendors || {};
consent.vendors.standard = consent.vendors.standard || [];
consent.vendors.custom = consent.vendors.custom || [];

var dataLayer = window.dataLayer = window.dataLayer || [];
</script>



<style type="text/css">
#sp_privacy_manager_container {
	z-index: 10000000 !important;
}
</style>

<script> 											
window._sp_ = window._sp_ || {};
window._sp_.config = window._sp_.config || {};

//Replace YOUR_ACCOUNT_ID with the account ID provided
//by Sourcepoint
window._sp_.config.account_id = 146;

// replace 'mms.sp-prod.net' with your CNAME'd messaging subdomain		
window._sp_.config.mms_domain = 'cmp.macworld.com' ; 
//window._sp_.config.mms_domain = 'mms.sp-prod.net' ; 

// messaging-specific configuration
window._sp_.mms = window._sp_.mms || {};
window._sp_.mms.cmd = window._sp_.mms.cmd || [];

//CMP Flags
window._sp_.config.cmp = _sp_.config.cmp || {};
window._sp_.config.cmp.enabled = true;
window._sp_.config.cmp.waitForConsentData = true;

//Code to call the server and display a message
window._sp_.mms.cmd.push( function () {
    window._sp_.mms.startMsg();
});						
</script>

<script src="//d2zv5rkii46miq.cloudfront.net/0/latest/cmp_shim.js"></script>
<script src="/www/js/messaging.js"></script>



<script>
__cmp('getConsentData',null,function(e){
	
	consent.isEU = e.gdprApplies;
	if (!consent.isEU) {
		
		consent.personalization=true;
		$(window).trigger("runConsent", [consent.ads.queue]);
		$(window).trigger("runConsent", [consent.infostorage.queue]);
		$(window).trigger("runConsent", [consent.adsel.queue]);
		$(window).trigger("runConsent", [consent.contentsel.queue]);
		$(window).trigger("runConsent", [consent.socmedia.queue]);
		$(window).trigger("runConsent", [consent.digitalelement.queue]);
		$(window).trigger("runConsent", [consent.tealium.queue]);
		dataLayer.push({
			'event': 'consentKnown' 
		});
	}
	else if (e.consentData !== null && e.consentData !== "") { // else if.. visitor is from EU and consent is known...
		getConsentInfo();
		bindReshowCmp();
	}
	else { //else consent is not known
	    bindReshowCmp();
	}
});

function getConsentInfo() {
	
	__cmp('getVendorConsents',[],function (e) {
		
		consent.purposes.standard = Object.keys(e.purposeConsents);
		consent.vendors.standard = Object.keys(e.vendorConsents);
		
		consent.personalization = consent.purposes.standard.includes("2");
		
		
		
		
		
		
		
		if (consent.purposes.standard.includes("1")) { // if information storage consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.infostorage.queue]);
		}
		if (consent.purposes.standard.includes("3")) { // if ad selection consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.adsel.queue]);
		}
		if (consent.purposes.standard.includes("4")) { // if content selection consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.contentsel.queue]);
		}
		//special case for Tealium
		if (consent.purposes.standard.includes("1") && consent.purposes.standard.includes("2") && consent.purposes.standard.includes("3") && consent.purposes.standard.includes("4") && consent.purposes.standard.includes("5") && consent.vendors.standard.includes(522)) {
			
			$(window).trigger("runConsent", [consent.tealium.queue]);
		}
		
		//special case for Digital Element
		if (consent.purposes.standard.includes("2") && consent.purposes.standard.includes("3") && consent.purposes.standard.includes("4") && consent.purposes.standard.includes("5")) {
			
			$(window).trigger("runConsent", [consent.digitalelement.queue]);
		}
	});

	__cmp('getCustomVendorConsents',[],function (e) { 
		
		consent.purposes.custom = [];
		e.consentedPurposes.forEach(function(item, index) {
			consent.purposes.custom.push(item.name);
		});
		
		consent.vendors.custom = [];
		e.consentedVendors.forEach(function(item, index) {
			consent.vendors.custom.push(item.name);
		});
		
		
		
		if (consent.purposes.custom.includes("Social Media Consents")) { // if social media consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.socmedia.queue]);
		}
		
		
		if (consent.vendors.custom.includes("Google Ad Manager")) {
			
			$(window).trigger("runConsent", [consent.ads.queue]);
		}
		
	});
	
	dataLayer.push({
		'event': 'consentKnown' 
	});
}

var idgCMPSourcepointCallback = function(){
	if (consent.isEU) {		
		getConsentInfo();
	}
}

$(window).on("runConsent", function(event, queueToRun) {
		watchConsentQueue(queueToRun)
});

function runQueue(queue){
	for (var x=0;x<queue.length;x++) {
		var nextFn = queue.shift();
		nextFn();
		
	}	
}

function watchConsentQueue(queue){
	setInterval(function() { runQueue(queue); },500);
}
function bindReshowCmp() {
	var url = document.location.pathname;
	if (url.indexOf("/about/member-preferences") > -1) {
		$(document).ready(function() {
			$(".cmpSettings").show();
			$(".reshowLink").on("click", function(e) {
				e.preventDefault();
				window._sp_.privacyManager.loadPrivacyManagerModal(3932, '5cd195e5f9f3332a80a0e25f');
			});
		});
	}
}
</script>




	
	
	
		










<script>
// this javascript is for retrieving locale-specific ad units for DFP - see mapping in apollo-locales.js
// getting locale and editions for the site the reader is viewing
let brandAbbrev = "mw";
let brandConfigBrandId = "1";
//let myLocale = getLocale(); // getting locale on page load from URL, IP, geolocation - this will always be something. If 0, it's the global/default/core view.
let countryCode = "";
let getSlugFromId = getApolloLocaleIdMap();
let getIdFromSlug = getApolloLocaleSlugMap();

// if selectedLocale cookie exists, get locale
if (typeof getSelectedLocale() !== 'undefined'  && getSelectedLocale() === getLocale()) { // get locale from cookie if available otherwise, use another locale source (from geolocation, url slug, etc.)
 	countryCode = getSlugFromId[getSelectedLocale()];
} else {
	countryCode = getSlugFromId[getLocale()];
}
//console.log("+++ 1) in locales.editions.jsp - COUNTRY CODE IS DEFINED AS: "+countryCode+"+++");
// if countryCode is empty string at this point, it means localeId = 0 which is global (default/core)...
if (countryCode == "") {
	countryCode = "us"; // country code for default global is currently US
}
//console.log("====INSIDE locales-editions.jsp - getSelectedLocale() = " + getSelectedLocale() + " and getLocale() = " + getLocale() + " and countryCode = " + countryCode);
//US social media accounts are the default if locale cannot be determined
var twitterUrl = "https://twitter.com/macworld";
var linkedInUrl = "";
var facebookUrl = "http://www.facebook.com/Macworld";
var youTubeUrl = "";
var twitterHandle = "macworld";

if (countryCode === 'asean') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'middle-east') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'uk') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'in') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
	youTubeUrl = "";
}
if (countryCode === 'africa') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
	youTubeUrl = "";
}

//US business unit is the default if locale cannot be determined
var busUnit = "";
//cookie policy page
var localeEdition = "";
var busUnitAddress = "";
if (countryCode === 'asean') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'middle-east') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'uk') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'in') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'africa') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
</script>

	

	
    <script src="/www/js/init_device.js"></script>    
    
    	
    
    
   	
   	
		
			















	<script async="async" src="//cdn.adsafeprotected.com/iasPET.1.js"></script>




	<script async src="//js-sec.indexww.com/ht/p/183980-23539077446987.js"></script>

	
<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20190909113443"></script>

<script type="text/javascript">
	if (adLayer==null || adLayer=='undefined') {
		var adLayer=[];
	}
	
		
			adLayer["itemType"]="article";
		
		
	
</script>
	
<script type="text/javascript">
	// Set up ad related variables
	try {
		IDG.GPT.unitName = "/8456/IDG.US_CSMB_Macworld.com";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}

	try {
		IDG.GPT.unitName = IDG.GPT.unitName + "/" + "ios_section";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	// global variables
	var global_ShowSuper = true;
	var global_ShowHero = false;
	
	//XFP global targeting, more targeting thm_pre
	var url = window.location.href;
	if(url.indexOf("?")>1){
		url=url.split('?')[0];
	}
	

	try {
		IDG.GPT.addTarget("URL", encodeURIComponent(url));
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	try {IDG.GPT.addTarget("zone", 'article/ios');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("channel", 'ios,apple-phone');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("articleId", '3331839');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("type", 'news');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("typeId", '2');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("manufacturer", 'sony');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("templateType", 'article-default');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	
	try {IDG.GPT.addTarget("categoryIds", ['3144','3183']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("categorySlugs", ['ios','apple-phone']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {IDG.GPT.addTarget("goldenIds", ['230','746']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {
		if (null != IDG.GPT.getQsVal("env")) {		
			IDG.GPT.addTarget("env", IDG.GPT.getQsVal("env").replace(/\W/g, "") );
		}
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	
	
		try {
			IDG.GPT.addTarget("author", 'Macworld Staff');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
		

	try {
		IDG.GPT.addTarget("page_type", '');
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	

	
	
	
	
		try {
			IDG.GPT.addTarget("insiderContent", 'false');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
	
	
	try {
		IDG.GPT.welcomeFreqCap = true;
	}
	catch (exception) {
        console.log("Welcome Ad Frequency Cap: google_dfp can't use IDG.GPT " + exception);
	}
	
</script>



<script type="text/javascript">
	
	
	
	
		
		
		
		
		
		
		
		
	
	
	
	
</script>
  
<script src="/www.idgcsmb/js/thm_pre.js?v=20190909113443"></script>


	
	
		<script>
		// IDGMPM-16419 - moved out of adsel queue for IDGMPM-16933
		googletag.cmd.push(function() {
		  if (googletag.pubads().getTargeting('permutive').length == 0) {
		    var kvs = localStorage.getItem('_pdfps');
		    googletag.pubads().setTargeting('permutive', kvs ? JSON.parse(kvs) : []);
		    console.log('ad targeting permutive kvs: ', kvs);
		  }
		});
		</script>
	

<script type="text/javascript" src="/www/js/ads/gpt_starter.js?1234"></script>
	<script>
		loadGPT();
	</script>

	
		<script type="text/javascript" src="/www/js/ads/ias_gpt_launcher.js?v=20190909113443"></script>
	

	



		
		
	

	

    <link rel="canonical" href="https://www.macworld.com/article/3331839/iphone-11-rumors-the-new-iphones-have-a-sensor-coprocessor-named-rose-or-r1.html" />
	
	
	
	
	
	<meta name="description" content="What will be in Apple’s next iPhone? We’ll keep track of all the rumors right here." />
	<meta itemprop="image" content="https://images.idgesg.net/images/article/2019/05/iphone-2019-rumor-render-100796240-medium.jpg">
	
	
		
			<meta name="DC.date.issued" content="2019-09-09" />
			<meta name="date" content="2019-09-09" />
			
		
		
		
		 
	
	
	<link rel="amphtml" href="https://www.macworld.com/article/3331839/iphone-11-rumors-the-new-iphones-have-a-sensor-coprocessor-named-rose-or-r1.amp.html" />

	
		<link rel="stylesheet" href="https://use.typekit.net/lzq5miu.css" />
	
	
	<meta property="twitter:account_id" content="611823" />
	<meta property="fb:app_id" content="865450560227169" />
	
		
		
		
			
			
				
			
			
			
		
		
	<meta property="og:type" content="article">	
	<meta property="og:url" content="https://www.macworld.com/article/3331839/iphone-11-rumors-the-new-iphones-have-a-sensor-coprocessor-named-rose-or-r1.html">
    <meta property="og:site_name" content="Macworld">   
    
    
    	<meta property="og:image" content="https://images.idgesg.net/images/article/2019/05/iphone-2019-rumor-render-100796240-large.3x2.jpg">
    	<meta property="og:image:width" content="1200">
    	<meta property="og:image:height" content="800">
    
    
    
    
    
    
    	<meta property="og:title" content="iPhone 11 rumors: The new iPhones have a sensor coprocessor named 'Rose' or 'R1'"> 
    
    
    <meta property="og:description" content="What will be in Apple’s next iPhone? We’ll keep track of all the rumors right here.">
    
    

	
	<meta name="displaytype" content="article" />
	
	<meta name="source" content="macworld" />
	
	<meta name="category" content="ios,iphone" />
	
	<meta name="storytype" content="news" />
	
	
	
		<meta name="google-site-verification" content="1NJELq6F-S44I5ACepf9_rYYEBLuwwVjJUv5PrT91SA" />
	
	
	
		<meta name="msvalidate.01" content="05F49F041AAA61528A0A3329A6C0C02D" />
	
	
	
	
	
		<link id="mobile-size" rel="stylesheet" href="/www.idgcsmb/css/inline-header-mobile.css?v=20190909113443" />
		<script>
			if (window.matchMedia("(min-width: 768px)").matches) {
				document.getElementById('mobile-size').insertAdjacentHTML('afterend', '<link id="desktop-size" rel="stylesheet" href="/www.idgcsmb/css/inline-header.css?v=20190909113443" />');
			}
		</script>
		<link rel="stylesheet" href="/www.idgcsmb.mw/css/inline-header.css?v=20190909113443" />
	 
	
	
	    
	
	<link rel="stylesheet" href="/www.idgcsmb/css/print.css" media="print" />
	
	<!-- this must be first -->
	<link href="/www.idgcsmb/css/colorbox.css" rel="stylesheet" />
	<!-- <link href="/www.idgcsmb/css/equalizer.css" rel="stylesheet" /> -->
	<link href="/www.idgcsmb/css/global-layout.css?v=20190909113443" rel="stylesheet" />
	<link href="/www.idgcsmb.mw/css/global-layout.css?v=20190909113443" rel="stylesheet" />
	<link href="/www.idgcsmb/css/global-colors.css?v=20190909113443" rel="stylesheet" />
	<link href="/www.idgcsmb.mw/css/global-colors.css?v=20190909113443" rel="stylesheet" />
	<link href="/www.idgcsmb/css/global-typography.css?v=20190909113443" rel="stylesheet" />
	<link href="/www.idgcsmb.mw/css/global-typography.css?v=20190909113443" rel="stylesheet" />
	
	
	
	
		
		
			
			
			
				<link rel="stylesheet" href="/www/css/article.css?v=20190909113443" />	
			
			
		<link href="/www.idgcsmb.mw/css/article.css?v=20190909113443" rel="stylesheet" />
	
	
	<link href="/www.idgcsmb/css/video.player.css?v=20190909113443" rel="stylesheet" media="all" />
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	  
	<!-- this must be last -->
	<link href="/www.idgcsmb/css/helpers.css" rel="stylesheet" />
	
	
	<!--  fav and touch icons -->
	<link rel="shortcut icon" href="/www.idgcsmb.mw/favicon.ico"/>
	<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://csmb.staticworld.net/images/furniture/macworld/mw-apple-touch-icon-precomposed-144.png" />
	<link rel="apple-touch-icon-precomposed" sizes="129x129" href="https://csmb.staticworld.net/images/furniture/macworld/mw-apple-touch-icon-precomposed-129.png" />
	<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://csmb.staticworld.net/images/furniture/macworld/mw-apple-touch-icon-precomposed-114.png" />
	<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://csmb.staticworld.net/images/furniture/macworld/mw-apple-touch-icon-precomposed-72.png" />
	<link rel="apple-touch-icon" href="https://csmb.staticworld.net/images/furniture/macworld/mw-apple-touch-icon-precomposed.png" />
	
	

	
		
	
	
	
	
	<script type="text/javascript">
	var _sf_async_config={};
	_sf_async_config.uid = 29363;
	
	
	
		_sf_async_config.useCanonical = true;
	
	
	
		
						
	_sf_async_config.authors="Macworld Staff";
			
		
			
			
	_sf_async_config.sections="ios";	
		
		
		
		
	_sf_async_config.domain = "macworld.com";
	</script>
	
	
	
	
	
	<!-- <link href="/www.idgcsmb/webfonts/ss-social.css" rel="stylesheet" />
	<link href="/www.idgcsmb/webfonts/ss-standard.css" rel="stylesheet" />  -->
	<!--[if lte IE 8]>  
		<link href="/www.idgcsmb/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]-->


	
	<!-- Use Twitter Summary Card with Large Image for articles and videos; summary otherwise -->
	
		
				<meta name="twitter:card" content="summary_large_image">
		
		
	
	<meta property="twitter:description" content="What will be in Apple’s next iPhone? We’ll keep track of all the rumors right here.">
	
	
		
			<meta name="twitter:site" content="@macworld">
			
			
				
					<meta name="twitter:image" content="https://images.idgesg.net/images/article/2019/05/iphone-2019-rumor-render-100796240-orig.jpg" />
				
				
						
			
				
				
					<meta name="twitter:title" content="iPhone 11 rumors: The new iPhones have a sensor coprocessor named &#039;Rose&#039; or &#039;R1&#039;">
				
				
			
			
				
				
					<meta name="twitter:url" content="www.macworld.com">
				
			
		
		
		
		
		
	
	












<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "WebSite",
		"url": "https://www.macworld.com/ ",
		"potentialAction": {
		"@type": "SearchAction",
		"target": "https://www.macworld.com/search?query={search_term}",
		"query-input": "required name=search_term"
		}
	}
</script>
	
	
	
	
	<script src="/www/js/ads/ads.js"></script>
	
	<script>var oneRegPlacementID = "";</script>
	
	
	
	
	
		
			
				
			
			
			
			
			
			
		
		
		
	
	
	
		
		
		
		
		  
		
	
	
	
	
	
	
	
	  	 
	    
	    
	 
	 
	
	
	
	
	
	
	
	
	<script>
	var supMontMods = false;
	</script>
	


	
	
			
			
			
				
					
					
				











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<!-- blx4 #2806 blox4.simple  -->
			

		
			
				
					
					
					
						
							
					
						
					
					
					
					
					
					
						
					
				
				
			
		















	
		
		
	
		
		
	


	


			
	
	
	
	
	




	
		
	
		
	
	



	
	
	
	
	
	
		
			
				
				
				
					
				
			
			
			
			
		
		
		
	
	
	
	
	
	
	
	 
	 
		<script>
		window.ntvConfig = window.ntvConfig || {} ;
		window.ntvConfig.keyValues = window.ntvConfig.keyValues || {};
		var segs = localStorage.getItem('_pnativo');
		if (segs) {
		  window.ntvConfig.keyValues.permutive = JSON.parse(segs).join(",");
		}
		</script>
	
	 
	 
	
		<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
	
	
	
	<script type="text/javascript">
		var prodNames = '';
		var prodManufacturers = '';
		var prodCategories = '';
		var prodVendors = '';
	</script>
		
	
	
	<script>
	var idg_uuid = $.cookie('idg_uuid') || "";
	
	//get edition from countryCode
	var edition = '';
	if (typeof countryCode !== 'undefined') {//should be defined in locales-editions.jsp if brand has editions
		edition = countryCode;
	}

	var dlJobFunction = '';
	var dlJobPosition = '';
	var dlIndustry = '';
	
	dataLayer.push({
		'articleId': '3331839',
		'articleDisplayId':'1',
		'articleHasVideo':'false',
		'articleLocale': '',
		'articleTitle': 'iPhone 11 rumors: The new iPhones have a sensor coprocessor named \'Rose\' or \'R1\'',
		'articleType': 'News',
		'audience':'consumer',
		'author':'Macworld Staff',
		'blogName':'',
		'brandpost': '',
		'categoryIdList':'3144,3183',
		'categoryIdPrimary': '3144',
		'contentStrategy': '',
		'contentType':'news',
		'datePublished':'2019-01-07',
		'dateUpdated':'2019-01-07',
		'daysSincePublished':'0',
		'daysSinceUpdated':'0',
		'displayType':'article',
		'edition':edition,
		'environment':'production',
		'ga_enabled':'true',
		'gaTrackingId':'UA-870741-1',
		'geolocEnabled':'true',
		'goldenTaxonomyIdPrimary': '230',
		'goldenTaxonomyIdList': '746',
		'isBlog':'false',
		'isInsiderContent':'',
		'isICN': 'false',
		'oneRegPlacementID':oneRegPlacementID,
		'pageNumber':'1',
		'platform':'Web',
		'podcastSponsored': 'false',
		'primaryCategory': 'ios',
		'prodCategories':prodCategories.slice('|', -1),
		'prodManufacturers':prodManufacturers.slice('|', -1),
		'prodNames':prodNames.slice('|', -1),
		'prodVendors':prodVendors.slice('|', -1),
		'ancestorGoldenCategories': '',
		'primaryCategoryList': 'iphones',
		'primaryAncestorCategoryList': '',
		'property': 'macworld',
		'propertyCountry':'US',
		'purchaseIntent':'',
		'skimlinksId':'111346X1569486',
		'source':'macworld',
		'sponsorName':'',
		'suppressMonetization': supMontMods.toString(),
		'tags': '',
		'userId':idg_uuid,
		'videoAutoplay':'false',
		'youtubeId':''
	});
	</script>
	 
	
	
	










<script>
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var adBlockStatus = 'false';
	
	function AdBlockEnabled() {
		var ad = document.createElement('ins');
		ad.className = 'AdSense';
		ad.style.display = 'block';
		ad.style.position = 'absolute';
		ad.style.top = '-1px';
		ad.style.height = '1px';

		if (document.body != null) {
			document.body.appendChild(ad);
			var isAdBlockEnabled = !ad.clientHeight;
			document.body.removeChild(ad);
		}

		return isAdBlockEnabled; 
	}
	// AdBlockEnabled() was successful document.body not null
	if (AdBlockEnabled() != undefined) {
		adBlockStatus = AdBlockEnabled().toString();
	}
	// not successful - look for ads.js
	if (document.body == null) {
		if (window.canRunAds === undefined) {
			adBlockStatus = 'true';
		} else {
			adBlockStatus = 'false';
		}
	}
	
	dataLayer.push({
		'adBlockStatus': adBlockStatus
	});
</script>





	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-WR6LD2P"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-WR6LD2P');</script>
	<!-- End Google Tag Manager -->

	
	
	
	
	
	<script src="https://www.google.com/recaptcha/api.js" async defer></script>
	
	
	
		<script>
			var numberFromDataLayer = function(property) {
			  if (window.dataLayer && dataLayer[0] && typeof dataLayer[0][property] == "number") {
			    return dataLayer[0][property];
			  }
			  return null;
			};
			
			var stringFromDataLayer = function(property) {
			  if (window.dataLayer && dataLayer[0] && typeof dataLayer[0][property] == "string") {
			    return dataLayer[0][property];
			  }
			  return "";
			};
		</script>
	
	
	
	
	
	

	
		










<script>
// IDGMPM-16419 - updated in IDGMPM-16933
	!function(n,e,o,r,i){if(!e){e=e||{},window.permutive=e,e.q=[],e.config=i||{},e.config.projectId=o,e.config.apiKey=r,e.config.environment=e.config.environment||"production";for(var t=["addon","identify","track","trigger","query","segment","segments","ready","on","once","user","consent"],c=0;c<t.length;c++){var f=t[c];e[f]=function(n){return function(){var o=Array.prototype.slice.call(arguments,0);e.q.push({functionName:n,arguments:o})}}(f)}}}(document,window.permutive,"f5b3be27-f789-4ef1-8867-37c67da5b361","84c7e805-5ce9-41f4-b988-3529488bab1c",{});
	  permutive.addon('web', {
	    page: {
	      type: stringFromDataLayer('displayType'),
	      language: 'en',
	      tags: stringFromDataLayer('tags').split(","),
	      audience: stringFromDataLayer('audience'),
	      description: 'What will be in Apple’s next iPhone? We’ll keep track of all the rumors right here.',
	      
	      article: {
	        authors: stringFromDataLayer('author').split(","),
	        description: 'What will be in Apple’s next iPhone? We’ll keep track of all the rumors right here.',
	        id: stringFromDataLayer('articleId'),
	        isInsiderContent: (stringFromDataLayer('isInsiderContent') == "true"),
	        modifiedAt: "2019-01-07T16:25:22Z",
	        publishedAt: "2019-01-07T16:25:22Z",
	        source: stringFromDataLayer('source'),
	        title: stringFromDataLayer('articleTitle'),
	        type: stringFromDataLayer('articleType'),
	        purchaseIntent: stringFromDataLayer('purchaseIntent')
	      },
	      
	      ads: {
	        adblocker: (adBlockStatus == "true"), //detected further up the page
	        enabled: true
	      },
	      gTax: {
	        primaryIds: [230,],
	        secondaryIds: [746,]
	      },
	      tax: {
	    	  primaryCategories: stringFromDataLayer('ancestorGoldenCategories').length > 0 ? stringFromDataLayer('ancestorGoldenCategories').split(",").concat(stringFromDataLayer('primaryCategory')) : [stringFromDataLayer('primaryCategory')] ,
	          secondaryCategories: stringFromDataLayer('primaryAncestorCategoryList').length > 0 ? stringFromDataLayer('primaryCategoryList').split(",").concat(stringFromDataLayer('primaryAncestorCategoryList').split(",")) : stringFromDataLayer('primaryCategoryList').split(",")
	      }
	    }
	  });

	  dlJobPosition = dlJobPosition || null;
	  dlIndustry = dlIndustry || null;

	  if (dlJobPosition !== '' || dlIndustry !== '' || stringFromDataLayer('userId') !== '') {
		  window.permutive.track('User', {
			  companySize: null,
			  country: null,
			  id: (stringFromDataLayer('userId') !== "" ? stringFromDataLayer('userId') : null),
			  jobIndustry: (dlIndustry !== "" ? dlIndustry : null),
			  jobPosition: (dlJobPosition !== "" ? dlJobPosition : null),
			  loggedIn: (stringFromDataLayer('insiderSignedIn') == 'true')
			})
	  }
	
	  //product js vars defined in document-head	  
	  if (prodNames !== '' || prodManufacturers !== '' || prodCategories !== '' || prodVendors !== '') {
		  window.permutive.track('Product', {
			  names: stringFromDataLayer('prodNames').split("|"),
			  categories: stringFromDataLayer('prodCategories').split("|"),
			  manufacturers: stringFromDataLayer('prodManufacturers').split("|"),
			  vendors: stringFromDataLayer('prodVendors').split("|")
		});

	  }
		 

</script>

<script>
	$.ajax({
		url: "https://cdn.permutive.com/f5b3be27-f789-4ef1-8867-37c67da5b361-web.js",
	  	dataType: "script",
	  	cache: true, // default is false
	  	async: true // default is true
	});
</script>
	
	
	
	
</head>

	<body id="article3331839" class="article macworld">
		 
		
			<div id="skinAdTarget"></div>
		

		
			<div id="superadunit" class="hidden">
			    <div class="ad">
			    	<div class="ad-header">
						<div class="brand-logo"></div>
						<a href="javascript:unhide('superadunit');" id="superstitial-text">Close Ad</a>
					</div>
					
						
						
						
					




















	
		
		
		
		
			
		  		<script type="text/javascript">
		  		
		  		
				document.write('<div id="gpt-superstitial" class=" ad-container"></div>');
				consent.ads.queue.push(function(){
			  		try {			  			
			   			IDG.GPT.addDisplayedAd("gpt-superstitial", "true");
			   			$('#gpt-superstitial').responsiveAd({screenSize:'971 1115', scriptTags: []});
			   			IDG.GPT.log("Creating ad: gpt-superstitial [971 1115]");
			   		}
					catch (exception) {
						console.log("Error with IDG.GPT: " + exception);
					}
		  		});
				
				</script>
		
		
	
 
 
	
			    </div><!-- / ad -->
			</div><!-- / super -->		
		

		











	
	
		
		
		
		
		
			
		
				
					
				











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	


		
		
		
		
		
		
		
		
		
		
		
		<div id="page-top">
				<div class="page-top-inner" itemscope itemtype="http://schema.org/Organization">
				<link itemprop="url" href="http://www.macworld.com"> 
			    
		
		
		
		
		<div class="network-header">
				<div class="network-header-inner">
					<div id="network-tools">
		
						<div id="saved-comparisons"></div>				
						<ul class="hmenu" id="heroLogin">				
							
							<li class="subscribeHeader"><a href="https://mcw.pcdfusion.com/pcd/Order?iKey=I**A02">Subscribe</a><div class="subscribe-hover" style="">
		                        <div class="pointer">&#9650;</div>
		                        <span>Learn more about Macworld's Digital Edition</span>
		                        <img alt="Macworld Magazine Cover" src="//alt.idgesg.net/images/furniture/macworld/footer-subscribe-mag-mw.png">
		                      </div></li>
						</ul>
					</div><!-- /#network-tools -->
		
						<div id="network-social">					
		                  
							
							<a href="http://www.facebook.com/Macworld" class="network-fb ss-icon ss-social-circle banner-social banner-fb" alt="Facebook" itemprop="sameAs" rel="nofollow">
								&#xF610;
							</a>
							<a href="https://twitter.com/macworld" class="network-tw ss-icon ss-social-circle banner-social banner-tw" alt="Twitter" itemprop="sameAs" rel="nofollow">
								&#xF611;
							</a>
							<a href="https://www.youtube.com/user/macworld" class="network-youtube ss-icon ss-social-circle banner-social banner-youtube" alt="YouTube">
								&#xF630;
							</a>
		
						<form id="search-form" action="/search">
							<input type="search" name="query" id="banner-search-term" class="inactive searchbox-input-class" value="">
							<input type="submit" name="submit" id="banner-search-submit" value="search" />
							<a id="magGlassClick" class="ss-icon ss-standard" type="submit">&#x1F50E;</a>
						</form>
		
						</div><!-- /#network-social -->
					
						
				</div>
			</div><!-- /.network-header -->
		
		
			<header id="banner">
				<a id="mobile-offscreen-toggle" class="ss-standard ss-rows" href="javascript://"></a>
				<div id="logo">
					<a href="/" class="ir banner-logo" id="logoImage">Home</a>		
				</div>
				<div id="mobile-search-toggle" class="ss-standard ss-search"></div>
			</header>
		
		
			



















<div id="main-nav">
	<div class="container clearfix">
		<ul class="fmenu" id="panel-nav">
			<li class="newsNav"><a href="/news/" id="whatsHotNav">News</a></li>
			<li class="reviewsNav"><a href="/reviews/" id="reviewsNav">Reviews</a></li>
			<li class="howtoNav"><a href="/howto/" id="howtoNav">How-To</a></li>
			<li class="videoNav"><a href="/video/" id="videoNav">Video</a></li>
			<li class="dealsNav"><a href="/deals" id="dealsNav">Deals</a></li>
			

		</ul>

		<ul class="fmenu" id="site-nav">
			
				<li><a href="/category/macs/">Macs</a>
					
				</li>
			
				<li><a href="/category/apple-phone/">iPhones</a>
					
				</li>
			
				<li><a href="/category/ipad/">iPads</a>
					
				</li>
			
				<li class="selected"><a href="/category/ios/" class="active">iOS</a>
				
					<ul>
						
								
									
									
										<li><a href="/category/mobile-apps/">Mobile Apps</a></li>
									
													
						
					</ul>
					
				</li>
			
				<li><a href="/category/wearables/">Wearables</a>
					
				</li>
			
				<li><a href="/category/home-tech/">Home Tech</a>
					
				</li>
			
				<li><a href="/category/business/">Business</a>
					
				</li>
			
			
			<li class="displayMobileOnly"><a href="/subscribe/">Subscribe</a></li>
		</ul>
		
			<div id="extra-nav-toggle"><a href="#extra-nav" class="ss-dropdown"></a></div>
			
			<div id="extra-nav">
				<ul>
					
						<li><a href="/resources/">Resources</a></li>
					
						<li><a href="/category/macs/">Macs</a></li>
					
						<li><a href="/category/macbook/">MacBooks</a></li>
					
						<li><a href="/category/mac-desktop/">iMacs</a></li>
					
						<li><a href="/category/apple-phone/">iPhones</a></li>
					
					<li><a href="/blogs">Blogs</a></li>
				</ul>
				<ul>
					
						<li><a href="/category/ipad/">iPads</a></li>
					
						<li><a href="/category/computers-accessories/">Computer Accessories</a></li>
					
						<li><a href="/category/desktop-apps/">Desktop Software</a></li>
					
						<li><a href="/category/software-music/">Audio</a></li>
					
						<li><a href="/category/enterprise/">Enterprise</a></li>
					
						<li><a href="/category/cameras/">Cameras</a></li>
					
						<li><a href="/category/components/">Components</a></li>
					
						<li><a href="/category/development-tools/">Development Tools</a></li>
					
				</ul>
				<ul>
					
						<li><a href="/category/displays/">Displays</a></li>
					
						<li><a href="/category/e-readers/">E-readers</a></li>
					
						<li><a href="/category/home-theater/">Home Theater</a></li>
					
						<li><a href="/category/mobile-apps/">Mobile Apps</a></li>
					
						<li><a href="/category/phone-accessories/">Phone Accessories</a></li>
					
						<li><a href="/category/tablet-accessories/">Tablet Accessories</a></li>
					
						<li><a href="/category/mp3-players/">MP3 Players</a></li>
					
						<li><a href="/category/mac-os-x/">MacOS</a></li>
					
				</ul>
				<ul>
					
						<li><a href="/category/printers/">Printers</a></li>
					
						<li><a href="/category/networking/">Networking</a></li>
					
						<li><a href="/category/software-productivity/">Productivity Software</a></li>
					
						<li><a href="/category/smartwatches/">Smartwatches</a></li>
					
						<li><a href="/category/storage/">Storage</a></li>
					
						<li><a href="/category/input-stylus/">Styluses</a></li>
					
				</ul>
			</div>
		
	</div>
</div>	<!--/#main-nav-->


<div id="section-nav">
		<div class="container clearfix">
			<ul class="fmenu">
				
					<li >
						
							
							
								<a href="/category/mobile-apps/">Mobile Apps</a>
							
						
					</li>

				
			</ul>
		</div>
</div><!--/#section-nav-->








		
		
				</div> 
			</div> 
		
		
		
		
					<!-- Events Header -->
				
					
						
						 
							
								
								
								
								
								
											    			
								
							
							
							
							
							
						
						 
						 
						 
						 
						  
						  
						 
						 
					











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	


				
		
		
		<script>
		$(document).ready(function(){
			$('.searchbox-input-class').each(function(){
			    $(this).change(function(){
			    	var qStr=$(this).val();
			    	if($(this).val().indexOf('@')!=-1){
			    		qStr=qStr.replace(/@/g,' ');
			    		$(this).val(qStr);
			    	}
			    });
			});
		});
		</script>
	


		
		













<div id="page-wrapper" class="page-wrapper">
	
	










	
	<section role="main">
	
		
		
		

		<article itemscope itemtype="http://schema.org/NewsArticle"  >

		











	
	




































<script src="/www/js/date-time-moments.js"></script>


	
	
		<script>
		// non-edition sites
		$(document).ready(function() {
			var fullDate = "2019-09-09T10:16-0700";
			var dateFormat = "MMM D, YYYY h:mm a z";
			timeDate = moment(fullDate).tz('America/Los_Angeles').format(dateFormat); // 12 hour format
			document.querySelector(".format-date").textContent = timeDate;
		});
		</script>
	




	
			















<header class='cat'>

	
	
	
	
	
	
	
	
	
		<!-- CSMB Horizontal Responsive -->
<ins class="adsbygoogle"
     style="display:block;"
     data-ad-client="ca-pub-4268075595326305"
     data-ad-slot="9945794902"
     data-ad-format="link"></ins>


<script>
consent.ads.queue.push(function(){
	$.getScript( "//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" )
		  .done(function( script, textStatus ) {
		    //need to add  && publisherConsents.gdprApplies back to the end of this conditional after testing
			  if (!consent.personalization && consent.isEU)  {
				   (adsbygoogle=window.adsbygoogle||[]).requestNonPersonalizedAds=1
				   console.log('*****GDPR: loaded adsense in non-personalized mode')
			  }
			  else {
			   		(adsbygoogle = window.adsbygoogle || []).push({});
			   	 	console.log('*****GDPR: loaded adsense in normal mode');
			  } 
		  })
		  .fail(function( jqxhr, settings, exception ) {
		    console.log( "Triggered ajaxError handler." );
		});
});
</script>
	
	
	
	<nav class="breadcrumbs horiz">
		<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
			<li><a class="edition-link-url" href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
			
				
				
				
					<li><a class="edition-link-url" href="/category/ios/" itemprop="url"><span class="article-primary-cat" itemprop="title">iOS</span></a></li>
				
			
		</ul>
	</nav>
	
	
	
	
	
	
	
		
		
			<div class="category">Updated</div>
		
	
	

	<h1 itemprop="headline">iPhone 11 rumors: The new iPhones have a sensor coprocessor named 'Rose' or 'R1'</h1>
	
	
	
	
		<section class="deck viewability">
			<h3 itemprop="description">What will be in Apple’s next iPhone? We’ll keep track of all the rumors right here.</h3>
		</section>
	
	
	
	
			<div class="cat-social">
				
					
				
















 



	

				

	
	
		
		
	



	
	


	


<div id="sharer" class="cat sidecar show">
<ul id="share-tool" class="expand">



	<li class="sosh">
		<a data-socialsite="Facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.macworld.com%2Farticle%2F3331839%2Fiphone-11-rumors-the-new-iphones-have-a-sensor-coprocessor-named-rose-or-r1.html" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/facebook.svg" />
		</a>
	</li>
	<li class="sosh">
		<a data-socialsite="Twitter" class="twit-hand" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.macworld.com%2Farticle%2F3331839%2Fiphone-11-rumors-the-new-iphones-have-a-sensor-coprocessor-named-rose-or-r1.html&via=macworld&text=iPhone+11+rumors%3A+The+new+iPhones+have+a+sensor+coprocessor+named+%27Rose%27+or" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/twitter.svg" />
		</a>	
	</li>
	<li class="sosh">
		<a data-socialsite="Pinterest" class="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?url=https%3A%2F%2Fwww.macworld.com%2Farticle%2F3331839%2Fiphone-11-rumors-the-new-iphones-have-a-sensor-coprocessor-named-rose-or-r1.html&description=iPhone+11+rumors%3A+The+new+iPhones+have+a+sensor+coprocessor+named+%27Rose%27+or" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/pinterest.svg" />
		</a>
	</li>
	<li class="sosh">
		<a data-socialsite="Reddit" href="http://reddit.com/submit?url=https%3A%2F%2Fwww.macworld.com%2Farticle%2F3331839%2Fiphone-11-rumors-the-new-iphones-have-a-sensor-coprocessor-named-rose-or-r1.html&title=iPhone+11+rumors%3A+The+new+iPhones+have+a+sensor+coprocessor+named+%27Rose%27+or" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/reddit.svg" />
		</a>
	</li>
	<li class="sosh cat">
		<a href="mailto:?Subject=iPhone 11 rumors: The new iPhones have a sensor coprocessor named 'Rose' or 'R1'&Body=Check%20out%20this%20article%20from%20Macworld%3A%20https%3A%2F%2Fwww.macworld.com%2Farticle%2F3331839%2Fiphone-11-rumors-the-new-iphones-have-a-sensor-coprocessor-named-rose-or-r1.html" target="_blank" rel="nofollow" id="email-icon">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/mail.svg" />
		</a>
	</li>
	<li class="sosh hide cat print">
		<a href="javascript:window.print();">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/print.svg" />
		</a>
	</li>



</ul>
</div>

<script type="text/javascript">
$(document).ready(function() {
	if (twitterHandle != "") {
		$("a[href*=via]").attr("href", function(_, href) {
			  return href.replace(/via=macworld/, "via="+twitterHandle);
		});
	}
	
	//Add Social Share Event Tag in GTM - IDGMPM-17271
	$("a[data-socialsite]").click(function() {
		var dataLayer = window.dataLayer = window.dataLayer || [];
		dataLayer.push({
			'event': 'socialShare', 
		  	'eventCategory': 'Social Share',
		  	'eventAction': $(this).attr("data-socialsite"), 
		  	'eventLabel': window.document.title
		});
		
	});
});
</script>

<script type="text/javascript">
var isValidEmailAddress = isValidEmailAddress || function(emailAddress) {
    var pattern = new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);
    return pattern.test(emailAddress);
};
function encodeQueryData(params) {
	var ret = [];
	for (var paramKey in params) {
		ret.push(encodeURIComponent(paramKey) + "=" + encodeURIComponent(params[paramKey]));
	}
	return ret.join("&");
}
</script>

			</div>
	
	
	

	
		
			
				
				<div class="cat byline vcard author with-image">		
					<div class="byline-wrapper">
						<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
							
						
							
							
							
							
						
















<a href="/author/Macworld-Staff/" rel="author" title="Macworld Staff"><img  class="bylineImage  imgId100007367 " src="https://images.techhive.com/images/article/2012/10/w2j2tqytk5fm03lobjc-100007367-byline.png" width="34" width="34" alt="Macworld Staff" itemprop="image" /></a>

						
							
								
							
















<span class="by">By </span><span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/Macworld-Staff/"><span itemprop="name">Macworld Staff</span></a></span>
						</p>
						<p class="dateline">
						
							Editors, 
								
									
								












<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name">Macworld</span><meta itemprop="logo" content=""/></span> <span class="divider break">|</span>
							
	
							<span class="pub-date" class='break-date' itemprop="datePublished" 
							    content="2019-09-09T10:16-0700"><span class="format-date"></span>
								
							</span>
						</p>
					</div>
				</div>
			
		
	
	
		
	
	
	
	
		
			<div id="articleLeaderboardWrapper">
				<div id="articleLeaderboardInner">
						
						
								
									
								




















	
		
		
		
		
			<div id="gpt-leaderboard" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-leaderboard", "true");
	    			$('#gpt-leaderboard').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-leaderboard [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	
						
				</div>
			</div>
			
				
			




















	
		
		
		
		
			<div id="gpt-leaderboardmobile" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-leaderboardmobile", "true");
	    			$('#gpt-leaderboardmobile').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-leaderboardmobile [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	 
		
	
	
	
</header>




	
	
	
	
		<div class="lede-container">
			
			
			
				
				
					
		                
		                	
		                	
		                
		                
						
						
						
					
					
					
					
					<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
						<meta itemprop="representativeOfPage" content="1" />
						<meta itemprop="height" content="800" />
						<meta itemprop="width" content="1200" />
			    		
			    		<img data-original="https://images.idgesg.net/images/article/2019/05/iphone-2019-rumor-render-100796240-large.jpg" class="lazy" loading="lazy" alt="iphone 2019 rumor render" itemprop="contentUrl" itemprop="url" />
			    		
			    		<figcaption>
			    			
			    			
			    				<span class="credit" itemprop="copyrightHolder">
			    					
					    				
					    					<a href="https://www.digit.in/news/mobile-phones/exclusive-first-look-at-2019-iphone-xi-renders-45655.html" target="_blank" rel="nofollow">Digit.in/@onleaks</a>
					    				
					    				
				    				
		
					    			
					    				
					    				
					    				
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
					    				
					    				
										
									
							
								</span>
			    			
							
			    		</figcaption>
					</figure>
					
		
				
				
			
		</div>
	




<section class="epo cat-narrow" id="drr-top-ad">

	
	
	
		<div class="techDeals">
				<div class="hed">
					<p>Today's Best Tech Deals</p>
					<p>Picked by Macworld's Editors</p>
				</div>
			  	
					
					
					
					
					
					
					
				




























































	<ul>
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="/article/3436821/save-big-on-apple-watch-series-4-and-macbook-pros.html"><img  class="small.3x2Image  imgId100774383 " src="https://images.idgesg.net/images/article/2018/09/apple-watch-s4-40mm-hero-100774383-small.3x2.jpg" alt="apple watch s4 40mm hero" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="/article/3436821/save-big-on-apple-watch-series-4-and-macbook-pros.html">Save big on Apple Watch Series 4 and MacBook Pros ahead of next week’s event</a></div>
	</div>
</li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="https://www.techhive.com/article/3436778/this-55-inch-4k-roku-tv-is-only-300-today.html"><img  class="small.3x2Image  imgId100810285 " src="https://images.idgesg.net/images/article/2019/09/tcl_roku_tv-100810285-small.3x2.jpg" alt="tcl roku tv" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="https://www.techhive.com/article/3436778/this-55-inch-4k-roku-tv-is-only-300-today.html">This 55-inch, 4K Roku TV is only $300 today</a></div>
	</div>
</li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="/article/3435768/the-2018-12-9-inch-ipad-pro-with-wi-fi-and-cellular-drops-to-its-lowest-price-ever.html"><img  class="small.3x2Image  imgId100780116 " src="https://images.idgesg.net/images/article/2018/11/ipad-pro-2018-100780116-small.3x2.jpg" alt="ipad pro 2018" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="/article/3435768/the-2018-12-9-inch-ipad-pro-with-wi-fi-and-cellular-drops-to-its-lowest-price-ever.html">The 2018 12.9-inch iPad Pro with Wi-Fi and cellular drops to its lowest price...</a></div>
	</div>
</li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="/article/3435859/upgrade-your-wi-fi-and-ditch-isp-fees-in-amazons-1-day-netgear-sale.html"><img  class="small.3x2Image  imgId100718446 " src="https://images.techhive.com/images/article/2017/04/netgear-nighthawk-x10-100718446-small.3x2.jpg" alt="netgear nighthawk x10" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="/article/3435859/upgrade-your-wi-fi-and-ditch-isp-fees-in-amazons-1-day-netgear-sale.html">Upgrade your Wi-Fi and ditch ISP fees in Amazon&#039;s 1-day Netgear sale</a></div>
	</div>
</li>
				
				
			
		
	</ul>




				<div class="moreDeals"><a href="/deals/">Find More Hand-Picked Tech Deals</a></div>
		</div>
	
	
	
	
		<div class="ad top-ad">
	
		
		
			
				
					
						
					
					
				
				
				
			





















	

		
			
			
			
			
			
			
				<div id="gpt-showcase" class="adunit ad-container test">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				if($(window).width() >= 930) {
					IDG.GPT.addDisplayedAd("gpt-showcase", "true");
					$('#gpt-showcase').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: gpt-showcase - [971 1115]");
                    
				}
				});
				</script>
			
		
	
 	
 
 
		
	
</div>
	
	
	
	
		<div class="topDeals topper">
					<div class="hed">
						<p>Top Deals On Great Products</p>
						<p>Picked by Techconnect's Editors</p>
					</div>
				  	
						
						
						
						
						
						
						
						
					




























































	<ul>
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
							
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="https://www.techconnect.com/article/3436792/boost-battery-on-the-go-with-this-35-ravpower-usb-c-portable-charger.html"><img  class="small.3x2Image  imgId100810381 " src="https://images.idgesg.net/images/article/2019/09/ravpower_charger-100810381-small.3x2.jpg" alt="ravpower charger" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="https://www.techconnect.com/article/3436792/boost-battery-on-the-go-with-this-35-ravpower-usb-c-portable-charger.html">Boost battery on the go with this $35 RAVPower USB-C portable charger</a></div>
	</div>
</li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
							
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="https://www.techconnect.com/article/3436958/create-your-own-arcade-room-this-3-in-1-street-fighter-unit-is-now-187-50.html"><img  class="small.3x2Image  imgId100810379 " src="https://images.idgesg.net/images/article/2019/09/street_fighter_arcade-100810379-small.3x2.jpg" alt="street fighter arcade" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="https://www.techconnect.com/article/3436958/create-your-own-arcade-room-this-3-in-1-street-fighter-unit-is-now-187-50.html">Create your own arcade room! This 3-in-1 Street Fighter unit is now $187.50</a></div>
	</div>
</li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
							
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="https://www.techconnect.com/article/3436820/grab-an-internova-1000-led-camping-lantern-for-29-50-today.html"><img  class="small.3x2Image  imgId100810279 " src="https://images.idgesg.net/images/article/2019/09/internova_lantern-100810279-small.3x2.jpg" alt="internova lantern" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="https://www.techconnect.com/article/3436820/grab-an-internova-1000-led-camping-lantern-for-29-50-today.html">Grab an Internova 1000 LED camping lantern for $29.50 today</a></div>
	</div>
</li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
							
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="https://www.techconnect.com/article/3436836/this-powerblock-adjustable-dumbbell-set-is-now-just-240.html"><img  class="small.3x2Image  imgId100810275 " src="https://images.idgesg.net/images/article/2019/09/power_block_dumbells-100810275-small.3x2.jpg" alt="power block dumbbells" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="https://www.techconnect.com/article/3436836/this-powerblock-adjustable-dumbbell-set-is-now-just-240.html">This PowerBlock adjustable dumbbell set is now just $240</a></div>
	</div>
</li>
				
				
			
		
	</ul>




					<div class="moreDeals"><a href="http://www.techconnect.com/deals/">See More Hand-Picked Deals</a></div>
		</div>
	
	
	
	
	
	
</section>















		<section class="bodee">

			
				
				
					





















<style>
	#drr-container figure.large.video {
		border-bottom: 0 none;
	}
	figure#page-lede.thm-gallery.rr-gallery-vid #bcplayer-gallery #bcplayer-gallery_ad > div {
		width: 300px !important;
		height: 169px !important;
		transition: all 0.5s ease;
	}
	figure#page-lede.thm-gallery #bcplayer-gallery #bcplayer-gallery_ad > div {
		width: 100%;
		height: 100%;
		transition: all 0.5s ease;
	}
</style>
<style>
.jwplayer.jw-state-paused .jw-display {
	display: table !important;
	padding: 0;
}
.jwplayer .jw-display-icon-container {
    float: none;
    padding: 0;
    margin: 0;
}
.jw-flag-small-player .jw-display {
	padding-top: 0px;
}
.jwplayer .jw-display-icon-container .jw-icon-rewind {
	visibility: hidden;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play path,
.jw-state-idle .jw-svg-icon-play path,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay path,
.jw-state-complete .jw-svg-icon-replay path {    
    display: none;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    background-size: contain;
    background-repeat: no-repeat;
    background-color: transparent;
    background-image: url(//idge.staticworld.net/idgtv/btn-play-default.svg);
    background-position: center center;
    bottom: 0;
    border-radius: 0;
    box-shadow: none;
    left: 0;
    margin: auto;
    right: 0;
    top: 0;
}
.jwplayer .jw-display-icon-container .jw-icon,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    height: 81px;
    width: 78px;
}
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container .jw-icon,
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.thm-gallery.rr-gallery-vid .jw-state-idle .jw-svg-icon-play,
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.thm-gallery.rr-gallery-vid .jw-state-complete .jw-svg-icon-replay  {
	height: 65px;
    width: 62px;
}
</style>


	



	
	
	
	
		<div class="ad placement">
			
				
			





















	

		
			
			
			
				<script>
					var supLocaleEd = false;
					if (typeof countryCode !== 'undefined' && countryCode !== "" && countryCode === 'in') {
						supLocaleEd = true;
					}
				</script>
				<!--  Begin inread -->
				<div id="inread" class=" ad-container">					
				</div>
				
				<script>
					if (supLocaleEd === true) {
						$("div#inread").remove();
					} else {
						consent.ads.queue.push(function(){
							IDG.GPT.addDisplayedAd("inread", "true");
							IDG.GPT.displayGoogleTagSlot('inread');
						});
					}
				</script>
				
				<!--  End inread -->	
			
			
			
			
		
	
 	
 
 
		</div>
	
	
	
	
	
	
	
	
		
			
				<div class="tocWrapper scaleArticleToc some-toc" data-tracking-category="In-article TOC">
					<legend>Table of Contents <i class="ss-navigatedown"></i></legend>
					<ul class="articleToc">
						
							
								
								
							
							<li data-pagenum="1" data-tocnum="1"><a href="#toc-1" class="trackLink">New ‘Rose’ or ‘R1’ sensor co-processor</a></li>
						
							
								
								
							
							<li data-pagenum="1" data-tocnum="2"><a href="#toc-2" class="trackLink">Three new iPhones coming in September</a></li>
						
							
								
								
							
							<li data-pagenum="1" data-tocnum="3"><a href="#toc-3" class="trackLink">A smaller Apple Pencil incoming?</a></li>
						
							
								
								
							
							<li data-pagenum="1" data-tocnum="4"><a href="#toc-4" class="trackLink">iPhone Pro</a></li>
						
							
								
								
							
							<li data-pagenum="1" data-tocnum="5"><a href="#toc-5" class="trackLink">Improved Haptics</a></li>
						
							
								
								
							
							<li data-pagenum="1" data-tocnum="6"><a href="#toc-6" class="trackLink">No more 3D Touch</a></li>
						
							
								
								
							
							<li data-pagenum="1" data-tocnum="7"><a href="#toc-7" class="trackLink">A look at the logic board</a></li>
						
							
								
								
							
							<li data-pagenum="1" data-tocnum="8"><a href="#toc-8" class="trackLink">Case renders show camera bump, mute slider</a></li>
						
							
								
								
							
							<li data-pagenum="1" data-tocnum="9"><a href="#toc-9" class="trackLink">18-watt USB-C power adapter included</a></li>
						
							
								
								
							
							<li data-pagenum="1" data-tocnum="10"><a href="#toc-10" class="trackLink">Two-way wireless charging and a bigger battery</a></li>
						
					</ul>
					<div class="toc-show-more">Show More <i class="ss-navigatedown"></i></div>
				</div>
	
					
				<script>
					var dataLayer = window.dataLayer = window.dataLayer || [];
					dataLayer.push({
						'event': 'loadInArticleToc'
						});
				</script>    
			
		
		
	
	
	
	
	













<script type="text/javascript">

$(document).ready(function() {
	$('.articleBloxAd').filter( ":visible" ).each(function(index, item) {
		var id = $(item).attr('id');
		var divClass = $(item).attr('class');
		var adString = IDG.GPT.getLazyAdCode();
		$(item).replaceWith("<div id=\"" + id + "\" class=\"lazyload_blox_ad " + divClass + "\">" + adString + "</div>");
	});
	try {
		$("div.lazyload_blox_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
		}) ;
	}
	catch (exception){
		console.log("error loading lazyload_ad " + exception);
	}
});

</script>
			
	
		
	
			
			













<style>
@media only screen and (min-width: 60.625em) {
	article .apart.ad.not-lazy {
		margin-left: 0;
		float: right;
	}
}
/* this spaces the ads in the right rail */
@media only screen and ( min-width: 48em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 390px; /*originally 354px*/
	}
	.topDeals.topper {
		margin-top: 390px;
	}
}
@media only screen and ( min-width: 48em ) and ( max-width: 58.063em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 0;
	}
}
@media only screen and ( min-width: 60.625em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 390px; /*originally 354px*/
	}
	.topDeals.topper {
		margin-top: 390px;
	}
}
@media only screen and ( min-width: 48em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 390px;
	}
}
@media only screen and ( min-width: 48em ) and ( max-width: 58.063em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 0;
	}
}
@media only screen and ( min-width: 60.625em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 390px;
	}
}
</style>


<script type="text/javascript">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</script>
			
			
	
	
	
	
	
		
		
			
		
	
	
	
	
	
		
			
				
				
				
					
				
				
			
		
		
	
	
		
		
			<div id="drr-container" class='cat ' itemprop="articleBody">
		
		
		
		
	
		
			
			
				<p>What’s in store for the new iPhone in 2019? We won’t officially know until the fall (most likely in September), but until then, you can bet that the rumor mill will be fully operational. This page will keep track of what’s being rumored as new features of the 2019 iPhones, and we’ll provide some analysis and whether or not a rumor seems feasible.</p><p><strong style="font-style: italic;">Updated 09/09/19:</strong><i> A new rumor from MacRumors states that the 2019 iPhones have a new sensor co-processor code-named “Rose” or “R1.”</i></p><h2 class="toc" id="toc-1">New ‘Rose’ or ‘R1’ sensor co-processor</h2><p>Apple has used motion co-processors in the iPhone since the iPhone 5S in 2013. The first two (M7 and M8) were separate chips, but M9-M12 were integrated into the A-series processor. They process data from the accelerometer, gyroscope, compass, barometer, and even enable the microphone to listen for “Hey, Siri.” Basically, it’s custom circuitry to process sensor info in a very high-performance and low-power way, so it can be done even while the phone is in sleep mode.</p><aside id="fsb-2399" class="fakesidebar fakesidebar-auto"><a href="https://www.macworld.com/article/3252034/ios/ios-12-features-release-date-and-how-to-install.html">[ Further reading: Everything you need to know about iOS 12 ]</a></aside><p>According to a <a href="https://www.macrumors.com/2019/09/09/rose-r1-coprocessor-2019-iphones/" rel="nofollow">new report from MacRumors</a>, the iPhone 11 will include a new sensor coprocessor that goes by the codenames “Rose” or “R1.” MacRumors has seen reference to it in code from an internal build of iOS 13. It supposedly performs a similar function to the M-series co-processors, only it processes data from many more types of sensors in order to get a more accurate picture of the phone’s position and orientation. </p><p>It adds support for an inertial measurement unit (IMU), which is like a gyroscope and accelerometer, some Bluetooth 5.1 features like Angle of Arrival and Angle of Departure, Ultra-Wideband (UWB), and even some camera tracking features.</p><p>The new capabilities are expected to be especially useful for the new Apple Tags product and augmented reality.</p><h2 class="toc" id="toc-2">Three new iPhones coming in September</h2><p>Bloomberg has a <a href="https://www.bloomberg.com/news/articles/2019-08-22/iphone-11-new-ipad-pro-16-inch-macbook-pro-airpods-3-features" rel="nofollow">report</a> on what Apple plans to announce during its September event, which has yet to be announced. According to Bloomberg, the featured products of the event are the “Pro” iPhones that will succeed the iPhone XS and XS Max, as well as a follow-up to the iPhone XR.</p><p>The list of the new features on the phones have been spinning through the rumor mill for months. They include the three-sensor camera on the Pro models with improvements to low-light and wide-angle still shots, as well as extensive video recording enhancements; Face ID with a wider field of view; A13 processors; reverse wireless charging; improved water resistance; and an outside matte finish instead of glossy.</p><aside class="nativo-promo nativo-promo-1 smartphone tablet desktop" id=""> </aside><p>Bloomberg also said that 3D Touch will be replaced by Haptic Touch, similar to what’s on the iPhone XR. The successor to the iPhone XR will have a second back camera for optical zoom and enhanced portrait mode.</p><p>5G will not be available on the new iPhones. This will be available in 2020.</p><h2 class="toc" id="toc-3">A smaller Apple Pencil incoming?</h2><p>File this one under Weird Last-Minute iPhone Rumors. Online retailer Mobile Fun is selling <a href="https://www.mobilefun.co.uk/apple/iphone-11-pro/cases" rel="nofollow">an iPhone 11 Pro case by Olixar</a> with an interesting feature: a slot on the rear of the case for a smaller Apple Pencil. Normally we’d completely dismiss such a odd rumor as ridiculous, but there are a few reasons why we’re lending some credence to this one. For one, it’s already being sold, but more importantly, Mobile Fun has a decent track record of predicting phone designs before launch. Earlier this year, it nailed the Galaxy S10’s hole-punch design, and it was one of first to accurately predict that the Note 10 would be dumping the headphone jack. But this one is certainly going out on a limb. Not only does Olixar think the iPhone 11 Pro will have Apple Pencil support, it also think Apple will be making a shorter Apple Pencil for it.</p><p><strong>Plausible:</strong> While we wouldn’t be surprised to see this rumor go up in smoke, it’s just crazy enough to be believable. If Apple is actually going to differentiate its flagship iPhone with the “Pro” moniker this year, it’s going to need something other than a bigger screen to justify it. Apple Pencil support would fill that need well, and the current Pencil isn’t exactly iPhone friendly, in that it’s taller than every model. So maybe a smaller Pencil that only works with the iPhone 11 Pro isn’t so crazy.</p><aside class="nativo-promo nativo-promo-2 tablet desktop smartphone" id=""> </aside><h2 class="toc" id="toc-4">iPhone Pro</h2><p>A random Twitter post about the next iPhone doesn’t usually rise to the level of plausibility, but CoinX’s 13 posts have been remarkably accurate. Not only did CoinX predict <a href="https://twitter.com/coiiiiiiiin/status/1082846618368393216" rel="nofollow">the return of the iPad mini</a>, <a href="https://twitter.com/coiiiiiiiin/status/1037844774261153792" rel="nofollow">the weight of the iPhone XS Max</a>, and the <a href="https://twitter.com/coiiiiiiiin/status/1050821076790300672" rel="nofollow">lack of a headphone jack on the latest iPad Pro</a>, he also nailed the 2018 iPhone naming scheme. And now CoinX is claiming to know the name of Apple’s next top-of-the-line iPhone: iPhone Pro. Presumably this will pertain to the 6.5-inch model, but CoinX doesn’t specify in the <a href="https://twitter.com/coiiiiiiiin/status/1160064724177784833" rel="nofollow">cryptic tweet</a>, which reads: “‘Pro’ for iPhone? Crazy naming schemes over the past few years.”</p><p><strong>Plausible?</strong> We’re been hearing rumors about a supposed iPhone Pro for more years than we care to remember, so it’s pretty clear that Apple has been toying with the name for a while. Since rumors have suggested that the larger iPhone won’t include any additional features this year (other than the bigger screen, of course), we’re not sure what will give it “pro” status, but we’re definitely intrigued. </p><h2 class="toc" id="toc-5">Improved Haptics</h2><p>A <a href="https://9to5mac.com/2019/07/23/iphone-11-models-camera-processor/" rel="nofollow">report from 9to5Mac</a> primarily reiterates the rumors we’ve heard before, with one significant new wrinkle: This year’s new iPhones will feature “a new type of Taptic Engine, known by the codename leap haptics.” It’s not known what the new features of this improved Taptic Engine would be. Apple is already one of the very few to use a linear resonant actuator for its haptics, which provide much greater fidelity than the eccentric rotating mass vibration motors used in so many other phones.</p><p><strong>Plausible?</strong> Apple is introducing a new Core Haptics framework in iOS 13 to give third-party developers greatly expanded control over the Taptic Engine, which has thus far been quite limited. Introducing new, more advanced haptics hardware at the same time would be excellent timing. In fact, it seems reasonable to assume that Apple’s plans to introduce more advanced haptic hardware is the very reason it created a new developer framework for haptics.</p><h2 class="toc" id="toc-6">No more 3D Touch</h2><p>We’ve heard several rumors claiming that 3D Touch will be absent from <em>all</em> 2019 iPhones. <a href="https://www.wsj.com/articles/apple-plans-new-lcd-iphone-this-year-despite-xrs-stumble-11547199263" rel="nofollow">The Wall Street Journal</a> predicted as much back in January, and then analysts from Barclays “confirmed” it by talking with suppliers in May. The latest rumor comes from <a href="https://www.digitimes.com/news/a20190709PD201.html" rel="nofollow">Digitimes</a> in an article about the future sales of touch interface suppliers TPK Holding and General Interface Solution. It says the companies, “may see sales grow in the second half of 2019 though Apple may remove 3D touch sensors from all 2019 iPhone devices, according to industry sources.”</p><p><strong>Plausible?</strong> 3D Touch has been a fixture of iPhones since its introduction in the iPhone 6s, but is missing from the more affordable iPhone XR. It’s said to be an expensive technology, and difficult to implement on larger displays, which is why we’ve never seen it on iPads.</p><p>We can’t help but notice that iOS 13 greatly expands the “Haptic Touch” feature used by the iPhone XR, where users just tap and hold for a second to get a context menu with a little haptic feedback. In the upcoming version of iOS, the most important features of 3D Touch are replicated by Haptic Touch. This makes us think it’s likely that Apple will get rid of this expensive technology that <a href="https://www.macworld.com/article/3398438/its-time-for-apple-to-kill-3d-touch-ios.html">sometimes confuses users</a>, and better unify touch interaction features across all iPhones and iPads.</p><h2 class="toc" id="toc-7">A look at the logic board</h2><p>Over on anonymous leaking site Slashleaks, there are a pair of images that claim to show the iPhone XI logic board (six of them, in fact). </p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2019/07/iphone-xi-slashleaks-100801224-orig.jpg" rel="nofollow"><img border="0" alt="iphone xi slashleaks" width="1200" height="1258" data-imageid="100801224" data-license="Supplied Art" data-original="https://images.idgesg.net/images/article/2019/07/iphone-xi-slashleaks-100801224-large.jpg" class="lazy" loading="lazy"/></a> <small class="credit"><a href="http://www.slashleaks.com/l/iphone-xi-redesigned-logic-board-leaks-out" rel="noopener nofollow" target="_blank">Slashleaks</a> </small>
<figcaption>
<p>The alleged logic board for one of the 2019 iPhone models.</p>
</figcaption>
</figure><p>Of course we don’t yet know if any of the phones will be called the iPhone XI, and we don’t know which particular model this is supposed to be a logic board for (there are three rumored models for this year, just as last year). The back side of these logic boards have not yet been printed, and the chips have not yet been bonded to it—we’re just looking at a single side of a mystery printed circuit board.</p><p><strong>Plausible?</strong> Sure, these could be an iPhone PCB. Of the current models, only the iPhone XR has a rectangular circuit board like this; the iPhone XS and XS Max have L-shaped circuit boards. Therefore, this could be a look at the iPhone XR’s successor, or it could be an indication that the iPhone XS successors will use a rectangular logic board and therefore have a different internal layout. There just isn’t too much we can glean from this without the chips attached.</p><h2 class="toc" id="toc-8">Case renders show camera bump, mute slider</h2><p>Case maker Olixar is already offering preorders on a set of cases for the iPhone 11 Max (which may or may not be the name of the phone Apple introduces this fall). You can see them at the U.K. retail site <a href="https://www.mobilefun.co.uk/apple/iphone-11-max/cases" rel="nofollow">MobileFun</a>, where you’ll see rendered versions of the cases in rendered versions of the iPhone 11 Max.</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2019/06/olixar-case-100800058-orig.jpg" rel="nofollow"><img border="0" alt="olixar case" width="1200" height="600" data-imageid="100800058" data-license="Supplied Art" data-original="https://images.idgesg.net/images/article/2019/06/olixar-case-100800058-large.jpg" class="lazy" loading="lazy"/></a> <small class="credit">Olixar</small>
<figcaption>
<p>Olixar thinks it knows what the next iPhone will look like.</p>
</figcaption>
</figure><p>There are a few items of note. One is the square camera bump, which after several rumors we have come to expect. The other is the somewhat smaller “notch” for the TrueDepth module—it could be smaller in the new iPhones, or this could be something of an optical illusion since we expect the iPhone 11 Max to be even bigger than the iPhone XS Max. Finally, eagle-eyed observers will note that the mute switch is a rounded slider that moves up and down, instead of the current switch that flips front-to-back. </p><p><strong>Plausible?</strong> None of these details are far-fetched, but it’s highly unlikely that any case manufacturer has learned about the minutia of the next iPhone already. In order to have cases available right at launch, manufacturers make a best guess based on their contacts in the manufacturing and supply chain, tweaking the design with more precise CAD dimensions closer to launch. These sort of early renders from case makers often get small details wrong, with corrections made as we get closer to launch.</p><h2 class="toc" id="toc-9">18-watt USB-C power adapter included</h2><p>Stop me if you’ve heard this one before: Apple is finally going to ditch the pitiful little 5-watt USB power adapter in favor of an 18-watt USB-C power adapter.</p><p>That’s the latest rumor from <a href="http://www.macotakara.jp/blog/rumor/entry-37401.html" rel="nofollow">Mac Otakara</a>, who claims its information comes from Chinese suppliers. All three new iPhone models are said to include the same 18-watt USB-C adapter as does the new iPad Pro, but that doesn’t mean the iPhones will have USB-C ports. Instead, they’ll come with USB-C Lightning cables in place of the current USB-A Lightning cables.</p><p><strong>Plausible?</strong> We want nothing more than for Apple to catch up to 2016 Android phones in providing decent power adapters in the box. For a few years, iPhones have been capable of <a href="https://www.macworld.com/article/3236904/iphone-power-adapters.html">charging <em>much</em> more quickly</a> than the 5-watt in-box power adapter will allow.</p><p>But we’ve been burned before. The 18-watt USB-C power adapter was a prominent rumor for last year’s iPhones—there were even leaked photos!—and it never came to pass. It turns out the power adapter everyone was excited about was intended for the new <a href="https://www.macworld.com/article/3321139/2018-ipad-pro-review.html">iPad Pro</a>. So call us <em>hopeful</em> but not <em>optimistic</em>. </p><h2 class="toc" id="toc-10">Two-way wireless charging and a bigger battery</h2><p>Analyst Ming-Chi Kuo, who’s forecasts on Apple products have been amazingly accurate, released a new supply chain report with some new predictions about the 2019 iPhone.</p><figure class="medium right"><img border="0" alt="new airpods" width="300" height="200" data-imageid="100791661" data-license="Supplied Art" data-original="https://images.idgesg.net/images/article/2019/03/new-airpods-100791661-medium.jpg" class="lazy" loading="lazy"/> <small class="credit"><a href="https://www.apple.com/newsroom/2019/03/airpods-the-worlds-most-popular-wireless-headphones-are-getting-even-better/" rel="noopener nofollow" target="_blank">Apple</a> </small>
<figcaption>
<p>If you have the AirPods Wireless Charging Case, you may be able to charge it with the 2019 iPhone.</p>
</figcaption>
</figure><p>Kuo’s latest said that he expects the new iPhone to support two-way wireless charging—in other words, you can use the iPhone to charge other devices. For example, if you have <a href="http://macworld.com/article/3385527/airpods-2nd-generation-review.html" rel="nofollow">AirPods with a wireless charging case</a>, you can place the encased earbuds on the new iPhone, and the iPhone will charge the AirPods.</p><p>As a result of this feature, Kuo said that Apple plans to make the iPhone batteries bigger. The successor to the iPhone XS could have a battery that’s about 25 percent bigger, while the iPhone XS Max follow-up could see an increase of about 15 percent. The iPhone XR successor will see a smaller battery gain of about 5 percent.</p><p><strong>Plausible?</strong> Android phones with two-way wireless charging have already hit the market, so the technology already exists and it doesn’t seem far-fetched for Apple to adopt it. When you consider the monster success of the AirPods and the recent release of the wireless charging case (and even the <a href="https://www.macworld.com/article/3385086/apple-airpower-canceled.html">demise of AirPower</a>), it seems fitting (and inevitable) that Apple would implement this feature.</p><h2 id="toc-11" class="toc">Three-camera system (two on XR)</h2><p>Earlier this year we saw a render that most people dismissed as a concept that would never see the light of day. The funky design showed an iPhone with a giant square bump in the top left corner that housed three cameras and an LED flash. It didn’t seem like something Apple would make. </p><p>Oft-accurate leaker Steve Hemmerstoffer (@onleaks), who posted the original render, has returned with <a href="https://twitter.com/OnLeaks/status/1111353645768028160" rel="nofollow">a complete schematic of the rear case</a>, which appears to leaves telltale holes for three cameras and a flash positioned in the same way as the earlier leak. In fact, Hemmerstoffer overlaid the original render on the schematic and it matches up nearly perfectly.</p><p>Back in January, a report by <a href="https://www.bloomberg.com/news/articles/2019-01-30/apple-is-said-to-prep-new-3-d-camera-for-2020-iphones-in-ar-push" rel="nofollow">Bloomberg</a> says that Apple is currently testing iPhones with a rear three-camera system that will be found on larger iPhone models.</p>
			
		
		
	
		
		
			
		
		
		
		
		
	</div>
	
	
	
	
	
	<script>
$("a[data-product-id]").on('click',function(e){
	var e = e || window.event;
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var prodName = $(this).attr("data-product-name");
	prodName = prodName.replace("\\'","'"); // to counter the effects of over-escaping
	
	if ( $(this).parents('.slideshow').length > 0 ) {
		var productLinkPosition = "Slideshow";
	} else if ( $(this).parents('.emo-sb').length > 0 ) {
		var productLinkPosition = "Product Sidebar";
	} else if ( $(this).parents('.at-a-glance.top').length > 0 ) {
		var productLinkPosition = "AAG Top";
	} else if ( $(this).parents('.at-a-glance').length > 0 ) {
		var productLinkPosition = "AAG Bottom";
	} else if ( $(this).parents('.quick-hits.medium').length > 0 ) {
		var productLinkPosition = "Quick Hit Medium";
	} else if ( $(this).parents('.quick-hits').length > 0 ) {
		var productLinkPosition = "Quick Hit Full";
	} else if ( $(this).parents('.product-chart').length > 0 ) {
		var productLinkPosition = "Product Chart";
	} else if ( $(this).parents('.emo-list').length > 0 ) {
		var productLinkPosition = "Product List";
	} else {
		var productLinkPosition = "Body Text";
	}
	
	dataLayer.push({
		'event': 'affiliateLink', 
	  	'eventCategory': 'Affiliate Link', // Hardcoded, not dynamic
	  	'eventAction': 'Click', // Hardcoded, not dynamic
	  	'eventLabel': ''+e.target+'', // The URL the affiliate link leads to
	  	'productVendor': $(this).attr("data-bkvndr"), // The vendor of the product
	  	'productManufacturer': $(this).attr("data-bkmfr"), // The manufacturer of the product
	  	'productName': prodName, // The name of the product
	  	'productId': $(this).attr("data-product-id"), // The ID of the product
	  	'productLinkPosition': productLinkPosition // location of product link (Product Sidebar, Product Chart, etc.)
	});
	
	
	
});
</script>
	
	
		<script>
$("#drr-container a:not('[data-product-id]')").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickParentsUntilDrr = $clickEl.parentsUntil("#drr-container");
	var clickText = $clickEl.text().trim();
	var linkLocation;
	var linkType;
	var regex = new RegExp("cio.com|csoonline.com|computerworld.com|itnews.com|itworld.com|infoworld.com|networkworld.com|javaworld.com|techconnect.com|techhive.com|macworld.com|pcworld.com|greenbot.com|gamestar.com", "i");
	
	if (clickParentsUntilDrr.hasClass("fakesidebar")) {
		linkLocation = "FSB";
	}
	else if (clickParentsUntilDrr.hasClass("end-note")) {
     	 linkLocation = "End Note";
   }
	else {
		linkLocation = "Body";
	}
	
	if (regex.test(clickUrl)) {
	      linkType = "Internal";
	    }
	else {
		linkType = "External";
	}
		
	
	dataLayer.push({
		'event': 'editBodyLink', 
	  	'eventCategory': 'Editorial Body Links',
	  	'eventAction': linkType,
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>
	
	
	<script>
$("#drr-top-ad .related-promo-wrapper .title > a").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickText = $clickEl.text().trim();
	var linkLocation = "Promo";		
	
	dataLayer.push({
		'event': 'promoModuleLink', 
	  	'eventCategory': 'Promotion module',
	  	'eventAction': 'Click',
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>
	
	
	
	
	
	
	    <div class="apart-alt tags">
	    <span class="related">Related: </span>
	    <ul>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/ios"><span class="primary-cat-name2">iOS</span></a></li>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/apple-phone"><span class="primary-cat-name2">iPhone</span></a></li>
			 
			
				
				
					 
						 
				    				
					
				
					
			
	    </ul>
	   
		</div>
	
	
	
	
	
	
	
	
	
	
		
		
	

















	
	<section class="pagination">
		
	    
		    <span class="page-numbers">
			    
			    	<a href="/article/3331839/iphone-11-rumors-the-new-iphones-have-a-sensor-coprocessor-named-rose-or-r1.html" class="page-link current">1</a>
			    
			    	<a href="/article/3331839/iphone-11-rumors-the-new-iphones-have-a-sensor-coprocessor-named-rose-or-r1.html?page=2" class="page-link ">2</a>
			    
		    </span>
		    <span class="current-page">
		    	Page 1
		    </span>
		
		
			<a href="/article/3331839/iphone-11-rumors-the-new-iphones-have-a-sensor-coprocessor-named-rose-or-r1.html?page=2" class="page-link next" rel="next">Next <i class="ss-icon ss-navigateright"></i></a>
		
	</section>
	
	
	<div class="mobile-page-nav">
		
			
				
				<div id="article-top-page-number">Page 1 of 2</div>
				
					<a href="/article/3331839/iphone-11-rumors-the-new-iphones-have-a-sensor-coprocessor-named-rose-or-r1.html?page=2" class="page-link next" rel="next"><i class="ss-icon ss-navigateright"></i></a>
				
			
		
			
		
	</div>


	 
	



	
	
	
	
	
	












	
	
	
	
	
	
	
	
	
	
	
	
	
	
	





<script src="/www/js/video/embedder-jwp.js?v=20190909113443"></script>


					










				
			
		
		</section><!-- /.bodee -->

		














		
			
				











<script>var suppressEd = false;</script>







<div id="content-recommender">
	<div class="OUTBRAIN" data-widget-id="AR_1" data-ob-template="MacWorld_1"></div>  
</div>
<script>
	var obEdition = edition ||  countryCode || '';
	var widgetId="";
	
	if (obEdition === "asean") {
		widgetId="AR_3";
		if ($("body").hasClass("slideshow")) {
			widgetId="AR_4";
		}
	}
	if (widgetId !== "") {
		$(".OUTBRAIN").attr("data-widget-id", widgetId);
	}
	// suppressed for certain editions
	if (!suppressEd) {
		$.getScript("//widgets.outbrain.com/outbrain.js");
	}
</script>


			
				
		
	
		<div id="amazon-bottom-widget">
			<div class="amzn-custom-header">Shop Tech Products at Amazon</div>
			<div id="amazon-links" class="rr sector" original="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&storeId=httpwwwidgcsm-20&adInstanceId=f28f8449-ab80-4ceb-941b-6f3ebf8ef345">
				<code type="text/javascript"><!--
				           console.log('lazyloaded amazon widget links in footer');
				           //-->
				</code>
			</div>
		</div>
		<script>
		$(window).load(function() {
			consent.adsel.queue.push(function(){
				try {
					$("div#amazon-links").lazyLoadAd({
				          threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
				          forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
				          onLoad       : false,       // Callback function on call ad loading
				          onComplete   : false,       // Callback function when load is loaded
				          timeout      : 2000,        // Timeout ad load
				          debug        : false,       // For debug use : draw colors border depends on load status
				          xray         : false      // For debug use : display a complete page view with ad placements
				    });
				} catch (exception){
					console.log("ERROR loading amazon widget links " + exception);
				}
			});
		});
		</script>
	



	<div class="lazyload_ad">
		<code type="text/javascript">
						<!--
						var slotName = 'bottomleaderboard';
						var slotSize = [];
						if ($thm.deviceClass == 'mobile') {
							slotSize = [[300,50],[320,50],[300,250]];
						}
						else if ($thm.deviceClass == 'tablet') {
							slotSize = [[728,90],[468,60]];
						}
						else {
							slotSize = [[728,90],[970,90],[970,250]];
						}
						IDG.GPT.addDisplayedAd(slotName, "true");
						document.write('<div id="' + slotName + '" class="ad-container">');
						consent.ads.queue.push(function(){
							IDG.GPT.defineGoogleTagSlot(slotName, slotSize, false, true);});
						document.write('</div>');
						consent.ads.queue.push(function(){
							$('#' + slotName).responsiveAd({screenSize:'971 1115', scriptTags: []}, true);});
						//-->
		</code>
	</div>



		</article>

	</section><!-- /role=main -->

	
	
	

</div><!-- /#page-wrapper -->
		
		













<div id="panel-loader"></div>
<!-- IDGMPM-11812, category.getCategoryType() returns an integer, and 9 stands for tentpole-->
 



	
		










<link rel="stylesheet" href="/www.idgcsmb/css/tso-links.css?v=20190909113443" />

	<div id="tso-wrapper"><div id="tso" style="display:none"></div></div>
	<script type="text/javascript">
	function renderTSO(ads, requireHttps) {
		$thm.debug("renderTSO:"+ads.length);
		if (ads && ads.length > 0) {
			var selectedAds = selectTSOAds(ads,6);
			if (null != selectedAds && selectedAds.length > 0) {
				var html = "<h3>Today's Special Offers</h3>";
				html += "<ul>";
				for (var i=0; i<selectedAds.length;i++) {
					html += "<li>";
					html += "<a href='"+selectedAds[i].url+"'> "+selectedAds[i].title+"</a>";
					html += "<span>"+selectedAds[i].body+"</span>";
					if (null != selectedAds[i].pixel && selectedAds[i].pixel.length > 0 && selectedAds[i].pixel.indexOf('http') == 0) {
						if(!requireHttps || selectedAds[i].pixel.indexOf('https://') == 0){
							html += "<img src='"+selectedAds[i].pixel+"' style='height:0;width:0;'/>";
						}
					}
					html += "</li>";
				}
				html += "</ul>";
				$("#tso").html(html).show();
			}
		}
	}
	function selectTSOAds(ads,max) {
		if (ads.length <= max) {
			return ads;
		} else {
			var uniq = {};
			var found = 0;
			var selectedAds = [];
			while (found < max) {
				var ad = ads[Math.floor(Math.random()*ads.length)];
				if (uniq[ad.id] != null) {
					continue;
				} else {
					uniq[ad.id] = true;
					found++;
					selectedAds.push(ad);
				}
			}
			return selectedAds;
		}
		return null;
	}
	</script>
	

	




		










<link rel="stylesheet" href="/www.idgcsmb/css/footer.css?v=20190909113443" />
<link rel="stylesheet" href="/www.idgcsmb.mw/css/footer.css?v=20190909113443" />
<div id="network"></div>

	












<footer id="footer" class="clearfix">
    <div class="container clearfix">
    	<div class="footer-col">
    		<a href="http://macworld.com" id="footer-logo-mw" class="ir">Macworld</a>
    		<p>Macworld is your best source for all things Apple. We give you the scoop on what's new, what's best and how to make the most out of the products you love.</p>
    		<ul>
    			<li><a href="/about/about.html">About Us</a></li>
				<li><a href="/about/contact.html">Contact Us</a></li>
				<li><a href="http://hints.macworld.com/" rel="nofollow">Mac OS X Hints</a></li>
				<li><a href="https://www.idg.com/about-adchoices-macworld/" rel="nofollow">Ad Choices</a></li>
				<li><a href="/faq" rel="nofollow">Digital Magazines</a></li>
				<li><a href="/newsletters/signup.html">Newsletters</a></li>
				<li><a href="/about/cookie-policy.html">Cookie Policy</a></li>
				<li><a href="/about/member-preferences.html">Member Preferences</a></li>
				<li><a href="/about/privacy.html" rel="nofollow">Privacy Policy</a></li>
				<li><a href="/index.rss">RSS</a></li>
				<li><a href="https://www.idg.com/terms-of-service-agreement/" rel="nofollow">Terms of Service Agreement</a></li>			
			</ul>
			<ul class="right">
				<li><a href="https://shop.macworld.com">Shop</a></li>
				<li><a href="https://www.pcworld.com/couponcodes">Coupon Codes</a>
					<ul>
						<li><a href="https://www.pcworld.com/couponcodes/aliexpress">Aliexpress</a></li>
						<li><a href="https://www.pcworld.com/couponcodes/ebay">Ebay</a></li>
						<li><a href="https://www.pcworld.com/couponcodes/home-depot">Home Depot</a></li>
						<li><a href="https://www.pcworld.com/couponcodes/hp">HP</a></li>
						<li><a href="https://www.pcworld.com/couponcodes/jcpenney">jcpenney</a></li>
						<li><a href="https://www.pcworld.com/couponcodes/oneplus">OnePlus</a></li>
						<li><a href="https://www.pcworld.com/couponcodes/walmart">Walmart</a></li>
						<li><a href="https://www.pcworld.com/couponcodes/target">Target</a></li>
						<li><a href="https://www.pcworld.com/couponcodes/6pm-com">6PM</a></li>
					</ul>
				</li>
				<li><a href="/about/affiliates.html">E-commerce Affiliate Relationships</a></li>				
			</ul>
    	</div>
    	<div class="footer-col">
    		<h2>Macworld Categories</h2>
    		<ul>
    			<li><a href="/category/business/">Business</a></li>
				
				<li><a href="/category/creative/">Creative</a></li>
				<li><a href="/category/entertainment/">Entertainment</a></li>
				<li><a href="/category/ios-apps/">iOS Apps</a></li>
				<li><a href="/category/mac-apps/">Mac Apps</a></li>
			</ul>
			<ul class="right">
				<li><a href="/category/macs/">MacCentral</a></li>
				<li><a href="/category/iphone-ipad/">iPhone/iPad</a></li>
				<li><a href="/category/os-x/">OS X</a></li>
				<li><a href="/column/mwpodcast">Podcasts</a></li>
				<li><a href="/video/">Video</a></li>
				<li><a href="/deals">Deals</a></li>
			</ul>
			<h3>IDG Network Sites</h3>
			<ul>
				<li><a href="https://www.idg.com/advertise-with-us/macworld/" rel="nofollow">Advertise</a></li>
				<li><a href="https://www.idg.com/technetwork/technetwork-permissions-guildelines/" rel="nofollow">Permissions</a></li>
				<li><a href="http://www.pcworld.com/" rel="nofollow">PCWorld</a></li>
				<li><a href="http://www.techadvisor.co.uk/">Tech Advisor</a></li>
				<li><a href="http://www.techhive.com/" rel="nofollow">TechHive</a></li>
			</ul>
			<ul class="right">
				<li><a href="https://www.idg.com/technetwork/" rel="nofollow">IDG TechNetwork</a></li>
				<li><a href="https://www.idg.com/" rel="nofollow">IDG</a></li>
				<li><a href="http://blog.idg.com/" rel="nofollow">IDG Blog</a></li>
				<li><a href="https://www.idg.com/work-here/" rel="nofollow">Careers at IDG</a></li>
			</ul>			
    	</div>
    	<div class="footer-col">
    		<div id="footer-subscribe" class="clearfix">
	    		<a href="https://mcw.pcdfusion.com/pcd/Order?iKey=I**A09" rel="nofollow">
	    			<img src="//alt.idgesg.net/images/furniture/macworld/footer-subscribe-mag-mw.png" alt="Macworld Magazine Cover">
	    			<h2>Try Macworld <span>Risk-Free</span></h2>
	    			<span class="btn-link">Subscribe Now</span>
	    		</a>
    		</div>
    		<div id="footer-social">
    			<span>Follow us</span> <a href="http://www.facebook.com/Macworld" class="network-fb ss-icon ss-social-circle banner-social banner-fb" alt="Facebook" itemprop="sameAs" rel="nofollow">
						&#xF610;
					</a>
					<a href="https://twitter.com/macworld" class="network-tw ss-icon ss-social-circle banner-social banner-tw" alt="Twitter" itemprop="sameAs" rel="nofollow">
						&#xF611;
					</a> 
					
						<a href="https://www.youtube.com/user/macworld" class="network-youtube ss-icon ss-social-circle banner-social banner-youtube" alt="YouTube">
							&#xF630;
						</a>
					 			
    		</div>
    		
    		 <p>Visit other IDG sites:</p>
    		
    		<div id="idgInfo" class="styled-select">		
		            <select onchange="location = this.options[this.selectedIndex].value;" id="jumpMenu" name="jumpMenu" d30tagged="1" style="visibility: visible;">
		                <option value="">Select One</option>
						
							
						













	
		<option value="https://www.gamestar.com">GameStar</option>
	
		<option value="https://www.greenbot.com">Greenbot</option>
	
		<option value="https://www.macworld.com">Macworld</option>
	
		<option value="https://www.pcworld.com">PCWorld</option>
	
		<option value="https://www.techhive.com">TechHive</option>
	

		            </select>
		    </div>
		    
		        <p><small><a href="http://idgcsmb.com/terms-of-service-agreement/">Copyright</a> &copy; 2019 IDG Communications, Inc.</small></p>
    	</div>
    </div> 
</footer>


	
	<script src="/www/js/ads/stickyLb.js"></script>
	<script>
		(function(){
			var parallaxArgs = {
				topNavEl: 'main-nav',
				topNavIsSticky: false,
				leaderboadrdId: 'gpt-leaderboard', 
				adContainer: 'articleLeaderboardWrapper',
				adUnit: 'articleLeaderboardInner',
				viewabilityTime: 7000
			}
			parallaxLb(parallaxArgs) ;
		})();
		
	</script>



		
				
		
			
				
			




















	
		
		
		
		
			<div id="gpt-infunnel" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-infunnel", "true");
	    			$('#gpt-infunnel').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-infunnel [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	
		
		
			
		
















<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script> 

<script src="/www.idgcsmb/js/jquery/jquery-ui-tools.js"></script>


	<script>
		$(document).ready(function() {
			if (typeof $.cookie("geoPromoDontShow") === 'undefined' && typeof $.cookie("geoPromoSeen") === 'undefined' && navigator.languages.indexOf("es") > -1 && $thm.deviceWidthAtLeast($thm.deviceBreakpoints.wide)) {
				$.get("/napi/tile?def=international.promo", 
					function(data) {
						$("body").prepend(data);
						var visitTime = new Date();
						visitTime.setTime(visitTime.getTime()+1000*60*60*24); //24 hours
				      	$.cookie('geoPromoSeen', 'true', { expires: visitTime, path: '/' });
						$(".geo-promo .ss-delete, a.cont-here, a.dont-show").click(function(e) {
							e.preventDefault();
							if ($(this).is(".dont-show")) {
								visitTime.setTime(visitTime.getTime()+1000*60*60*24*30); //30 days
						      	$.cookie('geoPromoDontShow', 'true', { expires: visitTime, path: '/' });
							}
							$(".geo-promo").fadeOut(function() {$(".geo-promo").remove()})
						});
					}
				);
			}
		});
	</script>

<script src="/www.idgcsmb/js/thm_post.js?v=20190909113443"></script>
<script src="/www/js/product-toc.js?v=20190909113443"></script>
<script src="/www.idgcsmb/js/jquery/plug-ins/jquery.md5.js"></script>

	<script src="/www.idgcsmb/js/jquery/plug-ins/jquery.colorbox-min.js"></script>


<script src="/www.idgcsmb/js/autocomplete.js"></script>











<script src="/www/js/jquery/jquery.lazyload.min.js"></script>
<script>
$(function() {
    $("img.lazy").lazyload({ 
    	effect : "fadeIn", 
    	threshold: 200,
    	failure_limit:25
    });
});
</script>

<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js"></script>















<script type="text/javascript">

$(document).ready(function() {
	$('.articleBloxAd').filter( ":visible" ).each(function(index, item) {
		var id = $(item).attr('id');
		var divClass = $(item).attr('class');
		var adString = IDG.GPT.getLazyAdCode();
		$(item).replaceWith("<div id=\"" + id + "\" class=\"lazyload_blox_ad " + divClass + "\">" + adString + "</div>");
	});
	try {
		$("div.lazyload_blox_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
		}) ;
	}
	catch (exception){
		console.log("error loading lazyload_ad " + exception);
	}
});

</script>

<script type="text/javascript">
// -- Load Lazy Advertisement placement as deferred
try {
	$("div.lazyload_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
	}) ;
}
catch (exception) {
	console.log("Error with lazyLoadAd: "+exception);
}
</script>

<script src="/www.idge/js/jquery/jquery.tablesorter.min.js"></script>
<script>
$(document).ready(function() {
	$("table.tablesorter").tablesorter({
		widgets: ['zebra']
	});
	
	$("table.tablesorter tbody tr").hover(function() {
		$(this).toggleClass("selected");
	});
	
	$("table.tablesorter thead tr th").each(function(){			
		if ($(this).find('.ss-icon').length < 1) {
			$(this).append('<i class="ss-icon"></i>');
		}
	});
	
});
</script>

<script>
	//click event for BrandPost "Learn More" buttons
	$(".learn-more").click(function(event) {
		 var brandpost_txt = "<div class=\"about-brandposts\"><p>BrandPosts are written and edited by members of our sponsor community. BrandPosts create an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of BrandPosts.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";
		 if ($(".blog-byline.sponsored-post").length > 0) { //for Nativo sponsoredPosts
			 brandpost_txt = "<div class=\"about-brandposts\"><p>SponsoredPosts are written and edited by members of our sponsor community. SponsoredPosts create an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of SponsoredPosts.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";
		 }
		 $("body").append(brandpost_txt);
		 $(".about-brandposts").css("top",event.pageY);
		 if ($("body").width() >= 955) { // need different behavior at desktop breakpoint and above
			 //find difference between X position clicked and body width and set as right attr 
			 //this is so tooltip doesn't overflow window
			 var xpos = $("body").width() - event.pageX;
			 $(".about-brandposts").css({"right":xpos,"margin-right":"0"});
		 }
		 $(".about-brandposts .close-bar").click(function() {
			 $(".about-brandposts").remove();
			 return false;
		 });
		 return false;
	});
</script>




	<!-- LiveRamp Sources -->
	<script src="/www/js/utils/liveRamp.js"></script>
	<!-- End of LiveRamp -->


<script type='text/javascript'>

	
	$(document).ready(function(){

		$('#extra-nav-toggle a').click(function(){
			if($(this).hasClass('open')){
				$('#extra-nav').hide();
				$(this).removeClass('open');
				$('#extra-nav-toggle a').removeClass('ss-delete');
				$('#extra-nav-toggle a').addClass('ss-dropdown');		
			} else {
				$('#extra-nav').show();
				$(this).addClass('open');
				$('#extra-nav-toggle a').removeClass('ss-dropdown');
				$('#extra-nav-toggle a').addClass('ss-delete');					
			}
			return false;
		});
		
		var isMobile = window.matchMedia("only screen and (min-width: 60.625em)");
			
			if (!isMobile.matches) {
				$("#dealsNav span").removeClass("ss-dropdown").addClass("ss-directright");
				$("a.couponCodeMob span.rightArrow").remove();
				$("a.couponCodeMob").append('<span class="mobCoupons ss-directright"></span>');
				$('#dealsNav').click(function() {
					if ($("#dealsNav span").hasClass("ss-directright")) {
						$("#dealsNav span").removeClass("ss-directright").addClass("ss-dropdown");
						$(".dealsList").css({ 'display':'block'});
					}
					else {
						$("#dealsNav span").removeClass("ss-dropdown").addClass("ss-directright");
			    		$(".dealsList").css({ 'display':'none'});
					}
				});
				$("a.couponCodeMob").click(function() {
					if ($(".couponCodeMob .mobCoupons").hasClass("ss-directright")) {
						$(".couponCodeMob .mobCoupons").removeClass("ss-directright").addClass("ss-dropdown");
						$(".couponChildLinks").css({ 'display':'block'});
					}else {
						$(".couponCodeMob .mobCoupons").removeClass("ss-dropdown").addClass("ss-directright");
						$(".couponChildLinks").css({ 'display':'none'});
					}
				
				});      
			}
			else {
				$('li.dealsNav').mouseenter(function() {
			    	$(".dealsList").css({ 'display':'block'});
				});           
		
				$('ul.dealsList').mouseleave(function() {  
				    $(".dealsList,couponChildLinks").css({ 'display':'none'});	    
				});
				
				$('li.couponCodes').mouseenter(function() {
				    $(".couponChildLinks").css({ 'display':'block'});
				});           
			
				$('ul.couponChildLinks').mouseleave(function() {  
				    $(".couponChildLinks").css({ 'display':'none'});	    
				});
			}

    	<!-- if (isMobile.matches) {	 -->
    		
			
		
		<!-- } -->
		  				  
	});//-- end document Ready
		
	


					$(document).ready(function() {
						var tocTopper = 10;
						if ( $('body').hasClass('macworld') || $('body').hasClass('pcworld') || $('body').hasClass('techhive')) {
							tocTopper = 0;
						}
						
						$(window).resize(function() { 
							var scaleTocFixBegin = $("#drr-container.cat").offset().top - tocTopper;
							var scaleTocFixEnd = $(".bodee").offset().top + $(".bodee").height();			
							var scaleTocStartOffsetTop = 5;
							doProductToc(true,false,scaleTocFixBegin,scaleTocFixEnd,scaleTocStartOffsetTop);
	
						}).resize();
					});
				

	g_bRequireHttps = true;
	 
		$.ajax('/ads/tso',{
			dataType: 'json',
			success: function(data){
				renderTSO(data.tsoLinks, g_bRequireHttps);
			},
			error: function(jqXHR,error,thrown){
				$thm.debug("TSO AJAX Status: "+error+": "+thrown,true);
			}
		});
	
</script>

		
		<script type="text/javascript">
			a=top;f=self;
			var acceptedDomains = ["lookbookhq.com"];
			var cleanedHost = a.location.hostname.split(".").slice(-2).join(".");
			if(a!=f && acceptedDomains.indexOf(cleanedHost) < 0) {
				a.location=f.location;
			}
		</script>	

 		














	
	
	    
	    
		   	
		   	
		   	
	    
    	
    	
	    
	












	
	
	
	
	
	
	
	
	
	
	
	
	
	
	




 		
		










<script type="text/javascript">
consent.digitalelement.queue.push(function(){
	$thm.logPlEvent({"b":"mw","e":"view","t":"article","id":"3331839"});
	
});
</script>
	
	
		<div id="loginModal"></div>
		<div id="logoffModal"></div>
		<div id="abuseModal"></div>

		
			<!-- rev: 20190909113443  -->
		
		
		
		
			
				
			




















	
		
			<div id="gpt-skin" class=" ad-container"></div>
    			<script type="text/javascript">
    			consent.ads.queue.push(function(){
    				try {
	    				IDG.GPT.addDisplayedAd("gpt-skin", "true");
	    				IDG.GPT.displayGoogleTagSlot('gpt-skin');
	    			}
	    			catch (exception) {
	    				console.log("Error with IDG.GPT: " + exception);
	    			}
    			});
    			</script>
		
		
		
		
	
 
 
			
		
		
		
			
		




















	
		
		
		
		
			<div id="gpt_custom_promo_2" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt_custom_promo_2", "true");
	    			$('#gpt_custom_promo_2').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt_custom_promo_2 [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	
			
	</body>
</html>
